Windows error Fehler 0xc00007b


(Lars Ebsen) #1

Dear community,

my first trial install with roon for latest Win 10 64bit pro. I am receiving error Fehler 0xc00007b with all available windows downloads from the roon download page. Tried the usual fixes (e.g. install All in One Runtimes, start .exe as admin) with no luck.

System is i7 4790k with 16GB Ram and a Samsung EVO 850 SSD. Norton NIS and the usual onboard security is running. Switching it off does not change the issue.

Any help would be appreciated, pls ask questions to narrow this down.

Thanks, Lars


(Ged) #2

This is due to missing run time components, most often .Net. Try installing the latest components.


(Lars Ebsen) #3

Thanks Ged for coming back. I had .net 4.7.2 installed and upgraded this to most recent .net 4.8. This did not help. Microsoft Visual C++ is also installed incl. latest version. Also updated GPU driver (Nvidia GTX1070) to exclude open GL issues.

Any further thoughts would be approeciated.

BR, Lars


(Ged) #4

I presume you have done a Windows update?


(Lars Ebsen) #5

All up to date


(Ged) #6

Try installing the 32 bit version of roon.


(Lars Ebsen) #7

Tried and same error


(Ged) #8

Well I’m out then I run W10 pro with no problems and there are no other occurrences on the forum so something is broken in your PC W10 installation combo but I out of ideas as to what. I’ve flagged @support .


(Lars Ebsen) #9

Thanks Ged for your time and your kind support…:slight_smile: Greets from Germany.


(Lars Ebsen) #10

Anyone from Roon @support please - Would really like to start testing your great software to be able to purchase this later on.

BR, Lars


(Philo Melos) #11

Did you tried to run roon with administrator rights? (To do that, right click on the shortcut or the actual executable for the game, select Properties and open the Compatibility tab. Tick the ‘Run this program as an administrator’ box, and click on OK.)
Ah, you tried that already. Did you put Roon and raat on the exclusion list of Norton and Windows Defender, Firewall?


(Ged) #12

Yes he described doing that in his opening posting.


(Tony) #13

Have you tried a windows repair? A quick Google of this issue points to a lot of ‘file corruption’ type issues, including graphics drivers.


(Ged) #14

Chkdsk? Bit of a weird idea but it wouldn’t hurt.


(Ged) #15

Don’t suppose you have another PC you could try Lars?


(Lars Ebsen) #16

thanks for the help. Chkdsk did not create any change, will try a different machine tonight and come back. Win repair left open yet. Greets, Lars


(Stefan) #17

Hi Lars,
have you tried
Dism /Online /Cleanup-Image /ScanHealth
in case it shows errors
Dism /Online /Cleanup-Image /CheckHealth
followed by
Dism /Online /Cleanup-Image /RestoreHealth

or perhaps
sfc /scannow

all from a cmd window with admin rights

I would still believe it got to do with a slightly corrupted C++ runtimes installation, but since you mentioned you’ve already tried with AIOruntimes … this uninstalls the old ones and re-installs them and I would have expected this to to have cured the issue.
DirectX (differnt versions) is also known to be part of this error, so you might want to try simply re-installing a directx from microsoft.


(Tony) #18

If the disk is healthy then it won’t pick up corrupt files but at least you have eliminated one potential hardware issue. As posted above, this looks very like missing or corrupt file(s).


(Tony) #19

Thanks Stefan, I didn’t know about that utility.
Cheers - Everyday is a school day!


(Lars Ebsen) #20

Hi again. I have tried Dism /Online /Cleanup-Image /ScanHealth and it shows no errors.

sfc /scannow has found corrupted files and repaired them (I have the .log but I am not allowed to upload this…). This however did not remove the problem

Downloaded DirectX End-User Runtime Web Installer from MS and it tells me already working DX12 is installed

I did the AIOruntime Install again, no changes…

Also tried to install Roon on a Win 10 Laptop for crosschecking purposes…immediately worked…

Really need my desktop PC to work as Roon Core in my setup so any additonal help on this is much appreciated.

This is a hard one to learn from it seems.

BR, Lars