Windows Roonbridge build 18 discovery and crashing [fix released]

Roonbridge build 18 updated itself and now Roonbridge is no longer showing up an an endpoint.

Roonbridge is on a Windows 10 box, no firewall etc etc. It was working fine before, event log is full of errors. Restarting it didn’t help. Computer restart didn’t help either. I’m just trying to uninstall and reinstall it from scratch.

Reinstall from scratch fixed it in case anyone else encounters this issue on windows.

Getting a RAATServer error running a bridge on an old laptop (Windows 7) off a Core on an i7 Windows 10 machine. That bridge worked perfectly before this build.

Continuing the discussion from Roonbridge build 18 crashing on reboot:

Does a reninstall fix it?

Yup! Perfect! Thank you!

Just note it might get messed up again after a reboot, @brian is aware of the issue and is working on it.

Good to know. In the interim, it sounds spectacular.

We know how to reproduce this, and have learned a few things about the problem.

@danny will pick it up tomorrow, since this build/update/reboot stuff is in his arena.

In the mean time–this is the situation:

  • After taking the Build 13->18 update you will need to reinstall RoonBridge
  • After a reboot, you will need to exit/restart RoonBridge.

We’re going to try to get this resolved quickly. Thanks for the reports, guys.

After updating to the latest Roon 1.2 Build 128 and RoonBridge 1.0 Build 18, Roon can’t see the networked device. I reinstalled the first version of RoonBridge Build 13 and Roon see the device again.

@brian it would be great to get some pointers for best practice in updating the Linux/Pi versions of RoonBridge.

Do you simply download the the latest release, run the installer script and it sorts it out for you, including stopping/restarting services etc, or do we need to do anything manually? Or is it automatic via Roon for any that are already installed?

@hifi_swlon, it self-updates like our other packages.

You can see bridges on Settings->About from any control point. If an update is available, you’ll be able to accept it from there. Likewise, if an update becomes available, you’ll get the little blue update popup.

In case you were concerned about this issue, I just clarified the title of this topic–this problem is on Windows only, so no manual intervention should be needed for Linux versions.

1 Like

In that case - very nicely done! :slight_smile:

We are testing a fix for this now…will make new RoonBridge Windows packages later today assuming all goes well.

@brian & @danny just so you know, RoonBridge will only run right after a clean install. As soon as you exit and restart it, it’s pooched. Forcing you to clean install again.

Or at least on my machine anyway.

Build 19 seems to be behaving. I did have to go back to 13 before it would upgrade through your automatic update system though. It kept reporting an error checking for the update or something along those lines.

Thanks for the quick turn around!

Wow, you beat me to announcing it @DrTone!

Roon Bridge 1.0 (Build 19) is now live for Windows only with a fix for these crashes.

If anyone else is having trouble on Windows, you should confirm you’re running Build 19, and if needed, download the installer off our site in order to update to the latest version.

Let us know how it’s going guys!

@mike - Thank you. Wouldn’t you know today was the day I decided to install RoonBridge on a Windows 10 PC. Spent a few hours trying to figure out why it wasn’t working, then I decided to check here, thanks for the quick fix.

@DrTone - Yes I get the error “There was an error checking for an update” with the current Build 19 as well.

@mike I am going to monitor this some to make sure it isn’t some other issue but with Build 19 I have twice had the RoonBridge Zone disappear, once I resolved by re starting the Windows PC running RoonBridge, the second time by restarting Roon Core running on my Mac Mini.

Both computers are connected via ethernet.

I’d uninstall and clean install Build 19. Firewall?

Firewall disabled on Windows 10 laptop.

I will wipe Build 19 from system, run CCleaner and re install to see if the issue persists.