Windows Server 2012 R2 - Radeon RX 550 - GL_ARB+framebuffer_object extension is missing


#1

I am getting the OpenGL 3.0 or higher is required issue.

I have a brand new build. It has an ASUS ROG Maximus X Hero with an Intel Core i7-8700K. Most germane to this issue though, it has an ASUS Radeon RX 550 DirectX 12 AREZ-PH-RX550-2G video card. I am running Windows Server 2012 R2 with the intent of running AudiophileOptimizer.

I am sure the the video card is new enough that it supports OpenGL 3.0. But the problem is that Windows doesn’t recognize the Radeon as a Radeon. Instead it thinks the Radeon is a “Microsoft Basic Display Adapter”. I have deleted the adapter, but, before I can load the correct Asus drivers, the Microsoft adapter reappears.

I found an old thread here that directs us to GLview. But all GLview does is have us run Microsoft Update. I am in the midst of doing that update right now, but I really don’t expect that to work.

I have torn the web apart to deal with Windows Server’s failure to detect the video card as something other than a Microsoft product. But the only things that are mentioned there that I HAVEN’T tried have to do with updating the BIOS. Frankly that scares me because that often causes more problems than it solves. And I don’t have any confidence in my ability to roll back the BIOS version (nor to update it in the first place, for that matter!)

So does anyone have any additional ideas how I can deal with this? I have wasted three days trying to solve this to no avail.

Thanks,
Kirk


#2

I have installed all of the Windows updates that are available but, as I feared, that did no good whatsoever. Does anyone have an idea what I can do from here? I am dying for some music!

Thanks,
Kirk


(Dylan Caudill) #3

Hi @Kirk,

Have you tried updating your graphics card driver? I’ve found some articles while searching that suggest giving this a try.


#4

Yes, that was the first thing I tried. But Windows won’t allow the upgrade because it thinks the Radeon drivers are the wrong drivers because it thinks the device is a generic Microsoft device. And Windows advises that the drivers currently installed are the most recent drivers for a generic Microsoft device.

I’m getting so desperate that I’m resorting to listening to my wife’s system, which no Roon member would ever say is hi-fi. Grrr.

Thanks,
Kirk


(Dylan Caudill) #5

Hi @Kirk,

Have you tried downloading the correct drivers from the Radeon website? It seems like Windows may be confused about the drivers, so it may require a manual install here.


(Tony) #6

Windows is not so much confused, as using the only driver it has. As Dylan said, you need to download the correct drivers for that board/card direct from the manufacturers website and install them. Windows will then allow you to use them, if compatible with Server 2012 (they may not support it…).

Apologies if this falls into the ‘teaching Grandma to suck eggs’ category…

https://www.asus.com/support/FAQ/1012339


#7

I loaded the correct drivers at least 5times to no avail. In desperation I finally bought a Windows 10 and all is well. Well mostly. I obviously had more expense by buying Windows 10. And Audiophile Optimizer works marginally better without a gui which is not possible with Windows 10. Oh well, at least I will be back to listening to my system tonight! :slight_smile: