Windows10 remote is freezing

Core Machine intel corei7 8ght gen 18gb ddr4 ram with attached usb 2tb for local files.machine is running roon as shell .AO and Fidelizer pro are used to optimize windows 10 pro 64 bits.roon 1.6 (Operating system/System info/Roon build number)


Network Details ethernet cat 6 is coming from my router and connected to a gigaethernet switch tplink , networking gear model/manufacturer and if on WiFi/Ethernet)


**Audio Devices (I use a Usb to spdif HalideBridge to enter my Stealth Krell DAC that miss usb inputs. Also Jitterbug is connectes on the usb port .I also connected My Antinode dual core2 via usb with same freezing resultas on remote laptop


**the main problem is that randomly the roon’s screen on the remote laptop becames freezed…and the only way to get in touch with the core machine is to close roon and open again (on the laptop that is the remote ) .I tried 64 bit and 32 bit versions of roon on the remote machine .getting better results working on 32 bits.the remote is on wired ethernet to the same switch .no wifi

I found the same problem using the same machine as core but under linux and running roonserver .and the output via other machine running linux ubuntu and running roonbridge …the problem is even worst in the remote freezing machine I tried with fixed ip address on remote machine but this procedure didn’t improves performance in this department.

have you tried the 32 bit client…there are known issues with Intel HD graphics chipset drivers - assuming your graphics are Intel HD that is

Hi @wilfredo_sanchez,

Can you confirm that your GPU drivers are fully up to date?

As wizardofoz mentioned, definitely give the 32 bit version a try and let us know if that yields any changes for you.

pls haw to know the gpu driver updated??any guide plse??

I updated de intel gpu drivers graphiwith I wiill take some time to test is something happens …i will tell of any news …regards!!!

Hi @wilfredo_sanchez,

Definitely let us know how this goes! If you’re still experiencing issues after the update, definitely give the 32 bit version of Roon a try and let us know if there are any changes in that configuration.


I’ve had the same problem with the 64-bit version of Roon Remote and it seems to be cured by chosing the 32-bit version.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.