WLAN-adapter in ropiee

Hi,

I managed to get RoPieee working. Thanks for providing it!

I did not get my wifi adapter to work, though, using the web interface. SSH-ing into the Pi and running sudo pacman -S netctl, creating a config file, and netctl enable did the trick. (as per wifi configuration on arch)

But now I wonder: will this remain working after there is an update to RoPieee? And would this be something that can be added to the web interface? (for other users like me)

It won’t stick.

RoPieee should not be treated as a regular distro where you can tinker around. This means that there is no guarantee what so ever that this will hold.

So what are you trying to achieve? RoPieee supports wifi out-of-the-box, so I’m not entirely sure why you did not get it working.

Thanks

Of course I first tried using the web interface, and that would still be my preference. But I’m using only a Pi 2 with an USB WiFi dongle which is supported by Raspbian/ArchLinux, but not the webinterface from RoPieee?

Again, it’s not about whether a dongle is supported or not by Rasbian or any other distro, as RoPieee is not ‘just a layer’.

This means that the only way this is going to work (long term) is adding support for it to RoPieee itself. What’s the brand/type of the WiFi dongle if I may ask?

Regards

it’s a Ralink Technology, Corp. RT5370 Wireless Adapter. I don’t know if it’s helpful, but I sent feedback with # 4cc24ed89fe4fa66.

Thanks for looking into this.

Ok thanks for the feedback. The device is recognized and the driver is there.

So basically this is purely a matter of implementing the detection in RoPieee’s wireless setup.

I’m willing to invest time in this, but it’s for you to ‘hold on’. Because obviously this can be done by using a different solution and as you are capable of some Linux magic the question is if RoPieee is the best fit for you.

No hard feelings if you move on; if you stick around we can test some stuff in the beta channel. I’m pretty convinced we’ll get it to work, but it’s up to you.

Thanks!

Perhaps I would be able to get things working using Raspbian for instance. But I don’t want to :slight_smile: The only function of the Pi is functioning as a Roon endpoint. And I’m attracted to your solution as I can use it without having to maintain it, update it …

So, if I can help, I’m very much pleased to do so. Just let me know how.

Ok cool.

Pretty simple: i’vevreleased a beta which should support your hardware.
It’s ‘should’ as I’m blind here, so it require some further debugging.

So go the ‘advanced tab’ in the web interface, select ‘beta’ at the ‘update channel’, commit changes, save changes reboot and wait until the update is pulled in (you can see progress in the web ui).

When finished the web ui will advise another reboot. Please do. After that you should be able to enable wifi in the web ui.

Thanks

Done.

After updating, when I click enable wifi, I get this screen:

Nothing about wifi. Not sure what should happen, but I would expect to get some fields to choose network and enter password.

Also, when I click save and reboot, the “enable wifi” setting doesn’t seem to stick.

Do you need more info?

Is sending logs helpful? After reboot I sent feedback with ID 3859d232c6d46b27

Thanks. So, is there a ‘enable wifi’ option in the UI visible?

Yes there is. I clicked the check box, hit commit and then I got the above screen

Yeah check. Found the issue.

Good news: detection works. The reason it’s not entirely working is an interface issue in the web interface.

Bad news: I need some time to fix this :wink:

No problem. If I can help or should test again, please let me know.

I’ve pushed out an update. Could you try that one out?

Be aware: configuring wifi goes in 2 steps. First is enable it, (after which you should be able to save it with this last patch) and when you then go back into the network tab you can select your wifi network and enter a passphrase.

Let me know how it goes.

Thanks!

Wifi works!

But now it’s not showing up in Roon anymore. I will have to check tonight what’s going on… Perhaps I did something wrong

Nice.

You use an USB DAC if I remember correctly. Make sure it’s powered on, otherwise it indeed won’t show up in Roon.

You can always send me a log so I can have a look.

Regards,

I ssh’ed into the pi again. The usb dac showed up with lsusb. I tried a reboot… and it works! I didn’t touch the dac or anything. :slight_smile:

Thanks for your help!

Thanks, it works fine now. I guess I should switch back to the stable channel? What’s your policy with stable releases?

I would just leave it as is.

As soon as I release an update to stable (I expect this weekend) you can switch back.

Thanks