WLAN-adapter in ropiee

Hi @spockfish we have a Pi2b and installed a Wifi Dongle with RT5370 chipset (gwf-3s03).
When we enable Wifi and reboot we are getting an IP address assigned.
When we enter this in our browser its very, very slow. (unreachable sometimes)

How do I know the onboard Wifi isn’t used when I have inserted the Wifi Dongle with RT5370 chipset (gwf-3s03)? (I can’t see this from the Ropieee GUI?)
Any ideas why its slow (if the external wifi dongle is used)?

The Raspberry Pi 2 does not have WiFi, so we can safely assume it’s using the dongle :wink:

The slow speed I don’t know… can you send me feedback? You can find it on the web ui in the ‘advanced’ tab. I can then have a look.

1 Like

You’re right, I thought the Pi2B1.2 was equipped with wifi, but its not.
I have restarted my wifi router and it seems ok now. Thanks for the ultrafast response!

Hi folks,

I need some help. I have installed RoPieeeXL on a Raspberry 3B with internal Wifi.
Wired and Wlan0 are working in case I don‘t add an additional Wlan USB stick to the Raspi during installation and setup (Edimax AC 600 dual-band EWx7811UAC, Realtek rtl8812au).
If I do so, I don‘t see any wlan in ifconfig afterwards.
If i plug it in later, I only see it in lsusb and the buildin wlan0 is working.

When is the right time to plug it in?
And / or is wlan0 to be disabled?
Or do I miss something?

Thanks in advance

Someone using a similar setup?
I‘ve used such a stick in a Squeezebox environment and had a wireless connection in the 5 GHz band with ~400Mbit speed. That worked more than reliable, but no Roon client…
In a metal housing and no ethernet available internal Wifi isn‘t an optimal choice…


Hi @Andreas_Bussemer,

In essence it should work as you described: plugin the USB stick when installing. RoPieee prefers external wifi adapters above it’s internal one so that’s that.

As the driver you mentioned is also supported we need to figure out why this is not working because it should.

So… can you set up a RoPieee with a wired connection, do not configure wireless, and send feedback? You can find that in the ‘advanced’ tab of the web interface.


Thanks for coming back!
The identifier is 97e243b86b65cbd0


That’s weird. It did not arrive. You have a wired connection?

Yes I do.
And if I don’t plug in the stick I can enable local wireless connection.
This installation I have reverted back to wired only.
Do You maybe need feedback from a fresh wired installation with or without plugging in the stick?

I need the feedback with the USB stick plugged in, but with a wired connection. So don’t configure wireless (yet).

I’ve sent feedback. ID: a1a79fe880d5b82a

This is a fresh installation, stick plugged in as of beginning, no wireless setup.
lsusb shows the stick


again, nothing.

Hmmm… there’s something wrong on my side with the infra. more people’s feedback is not arriving.
I’ll look into this immediately.

Hi @Andreas_Bussemer,

Sorry for this. Infra issue solved, can you send me feedback again? Thanks.

Hi, I‘ve sent the requested feedback. Id: 33e16d87231a07aa

Thank You for looking into that issue

Ok thanks. This one arrived :wink:

Can you go into the interface, enable wifi commit and save?
If that’s done, do not reboot the unit, but send me another feedback.

Done, id: ca9be6ef60f1a008


Hi @spockfish,
After looking for the chip in my wifi USB stick in other distributions as well, I found, that it‘s not supported by the official RTL packages. There (amongst many others) is a chip supported named RTL8812ae, but not RTL8812au (as I own). For the au chip you always need a special driver, that might not work with newer kernel versions…
I want to say thank You for looking into the issue and for creating this wonderful application.
Kind Regards

Hi @Andreas_Bussemer,

RoPieee has support for the 8812au, so I’m still somewhat puzzled that it does not work properly.
It has trouble in bringing up the interface, so that might be related to driver troubles, unfortunately.

Maybe you can try another one?

Regards Harry

Hi Harry,
I have tried with an old Fritz WLAN USB Stick N (Atheros AR9001U chip).
For me as an end user it looks similar.
I’ve pressed commit and save, but the box with WLAN networks did not come up. I could not choose.
After rebooting there was no Wifi access.
I don’t know if that stick is supported.
Do You want me to do tests? Let me know.

The workflow is different.

After enabling wifi and saving it, you should go back to the network tab. Then you should be able to choose a network and enter a passphrase.