Won't launch - 'Application error' / 'Unhandled exception' - Win10 Pro build 19043.1165 [Resolved - New driver wasn't working, but older driver worked]

Roon Core Machine

These are specs of the core machine, but it’s running okay:

|Processor|Intel(R) Core™ i3-3220 CPU @ 3.30GHz 3.30 GHz|
|Installed RAM|8.00 GB (7.88 GB usable)|
|System type|64-bit operating system, x64-based processor|
|Edition|Windows 10 Pro|
|Installed on|‎8/‎2/‎2020|
|OS build|19043.1165|
|Experience|Windows Feature Experience Pack 120.2212.3530.0|

These are details of the machine that’s having the problem:

|Processor|Intel(R) Core™ i7-6500U CPU @ 2.50GHz 2.60 GHz|
|Installed RAM|12.0 GB (11.9 GB usable)|
|System type|64-bit operating system, x64-based processor|

|Edition|Windows 10 Pro|
|Installed on|‎6/‎11/‎2020|
|OS build|19043.1165|
|Experience|Windows Feature Experience Pack 120.2212.3530.0|

Networking Gear & Setup Details

This laptop’s and core machine are both connected via Ethernet to a Netgear 8-port switch (which is also connected to a Ubiquiti switch powering 3 APs carrying Wi-Fi to other devices in the house).

Connected Audio Devices

I’m successfully using my iPad and Android phone to use Roon w 6 Sonos speakers in the house. 2 wired, 4 Wi-Fi.

Library Size

5 TB of .aiff files across 2 NASs.

Description of Issue

The only problem is on the laptop that’s my “main desk computer.” When I launch Roon, it does show up in Task Manager for a couple of seconds, and I can sometimes see its status change to ‘Suspended.’ Then it vanishes.

True with Room x32 and x64 builds. Have uninstalled it including a purge of local data.

Have reinstalled .NET Runtime, ran Intel sniffer to install current vid card drivers.

Text from Event Viewer:

.NET Runtime

Application: Roon.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at Broo.Gdi.ChoosePixelFormat(IntPtr, PIXELFORMATDESCRIPTOR ByRef)
at Broo.Engine.WglLoaderWindow.LoadWgl(PIXELFORMATDESCRIPTOR ByRef, System.String ByRef, System.String ByRef)
at Broo.Engine.GlWindow.InitializeContexts()
at Broo.Engine.GlWindow…ctor(Broo.Engine.OpenGlWindow)
at Broo.Engine.OpenGlWindow…ctor()
at Broo.Engine.DeviceTarget…ctor(Broo.Engine.Window ByRef)
at Broo.BrooLoader.Load(Boolean, System.String, System.String, System.String, Broo.Engine.Engine ByRef, Broo.Engine.Window ByRef, Broo.Engine.LoadContext ByRef, System.String ByRef)
at Sooloos.Application.Main(System.String[])

Application Error

Faulting application name: Roon.exe, version:, time stamp: 0x610014ef
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000000000000
Faulting process id: 0x19a8
Faulting application start time: 0x01d78fe6fb7b3dff
Faulting application path: C:\Users\I\AppData\Local\Roon\Application\Roon.exe
Faulting module path: unknown
Report Id: fa6f7dd0-7c15-4125-a84d-47f016afdbb6
Faulting package full name:
Faulting package-relative application ID:

Windows Error Reporting

Fault bucket 1585933193374632105, type 5
Event Name: BEX64
Response: Not available
Cab Id: 0

Problem signature:
P1: Roon.exe
P3: 610014ef
P4: StackHash_ac46
P6: 00000000
P7: PCH_2B_FROM_ntdll+0x000000000009D974
P8: c0000005
P9: 0000000000000008

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: fa6f7dd0-7c15-4125-a84d-47f016afdbb6
Report Status: 268435456
Hashed bucket: 3380cb7cd27457bbf6025dd6349888a9
Cab Guid: 0

Hi @Ian_Murphy

Please try each of these steps, and try to launch Roon after each.

  1. Reinstall the Roon app
  2. Disable the device’s firewall
    1. If this helps, please enter an exception in the firewall for Roon and RAATServer
  3. Uninstall and reinstall the graphics drivers directly from the manufacturer’s website
    1. Don’t use Window’s automatic driver updates for this — We’ve seen this cause issues in the past
  4. Use Intel’s Driver Tool to see if there are any missing drivers.
  5. Disable any overlay software (like MSI Afterburner)

Next Steps

If none of the above helps, please use these instructions to send us Roon logs from the device.

We’ll also want to take a look at Event Viewer logs, which give some insight into errors being reported by the OS — Please send those as well:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log… from the context menu
  5. image
  6. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  7. image
  8. Right click on the Application subsection again and pick Save filtered log file as… from the context menu
  9. Enter the log file name, for e.g. Roon_USERNAME , and press Save

Did all the above and thanks for your interest.

I will note: a year ago, I had a train wreck with this machine that stemmed from conflicting advice re graphics drivers from Dell, Intel and Nvidia. Currently, Dell and Intel say that I’m up to date; Nvidia Control Panel got me down a rabbit hold of trouble last year so is not currently installed.

After updating w Intel’s Driver Tool (above), I now get a different dialog box:

Roon could not find WGL functions required to initialize
It is likely that the proper drivers for your display hardware
are not installed.
Up-to-date drivers should be available from the website of your computer or GPU manufacturer.

Will go figure out how to send logs (DM / email?)

Woops! Wait - something has worked - ended up at this page, where I grabbed a driver from 2018 and I’m back in business (and Adobe apps still seem to function, which was going to be the other variable). Either Intel or Dell auto-updating me to the latest driver had sunk me.

I’m posting this message in order to say to anyone getting frustrated: remember to try going back in time for yesterday’s stuff.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.