Won't recognize a new folder of music unless it's at the root of the watched folder[Solved]

I just added a new folder of music on my NAS to the same folder I put everything else in. So it looks like

  • Music [the folder Roon is watching]
    • DSD
      • [a whole bunch of other recognized music]
      • Mozart - Piano Concerto
        •    DSF
          •       [approx 10 new DSF files]

Roon refuses to show the new files in the album list. However, as soon as I move the “Mozart” folder to the top-level “Music” folder, Roon immediately notices it correctly. If I move it back to the previous location, it disappears and Roon can’t find it anymore.

There’s nothing different about this from any of my other music. How can I help debug this?

Can you give us some more info about your system?

Also, what’s the full path of one of the missing files? Wondering if the length of the path has anything to do with this.

Yeah sorry about not including basic info.

Roon build 102
MacOSX 10.11.3
MacBookPro Late 2013
Music stored on WD NAS

The full path (with “Roon-Music” as the root) would be

/Volumes/Roon-Music/• DSD/Mozart - Piano Concertos for 2 & 3 Pianos (Lubimov, Brautigam) (2007) [SACD]/

When I try to “ls” that directory, I just get “ls: .: No such file or directory” so perhaps it could be a maximum path issue.


In fact this explains some other file i/o errors I was seeing copying things from my hard drive to the NAS today. Shortening some other folder names make files suddenly start copying correctly (previously error -36).

Good to know I’m close to the limit. Is this something specific to smb mounts? I’ve never hit MAXPATH issues in the past.

Hrm, I shortened the “Mozart - Piano…[SACD]” folder to just “Mozart” and it still doesn’t see the DSF files inside it. Other folder names are just as long if not longer, so I’m not sure what the issue is now.

The path is now “/Volumes/Roon-Music/• DSD/Mozart/DSF” and the file names are about the length of “01 - Concerto KV 365 (1779) I. Allegro.dsf”.

Mike, could it be an issue with the special characters like ‘dot’? Perhaps the file’s not being seen as a dsf because it thinks its a ‘. Allegro.dsf’ instead?

The files should be visible with an ls though. Had you cd’d into the directory when you did the ls?
Also, you know you have to add slashes for all those spaces too when doing terminal commands like ls and cd? At the command line level spaces are a bit annoying in Unix, and I grew up being told to avoid them. But even though this might affect your cd and ls commands, its unlikely to affect Roons watching abilities.

(apologies if you know unix well btw, am just trying to offer useful suggestions)

Yeah, everything was properly quoted, and I had cd’d into the directory when trying the ls. Once I shortened the names, the ls was working fine.

I’ll try the idea of the extra “.” in the filename, though I’m pretty sure I have other files named this way. Thanks for the suggestion.


When you’re moving files around, are you manually re-scanning on the Storage tab of Settings? Or is Roon just failing to pick up the changes automatically?

There are some known issues with NAS drives and real-time folder watching that we’re working on now, so I would be interested to know if things improve with a manual re-scan of the drive.

@mike, I’m forcing Roon to re-scan every time.

Note that when I moved the files to the top level of my NAS (the Roon-Music directory), Roon saw them immediately, which is why it seems that the filenames should be ok by themselves once the path is shorter. The fact that it’s not seeing them now is still odd.

Are all the folder permissions in the path set correctly. I’ve had issues in the past, not with Roon but just in general, with permissions on OSX and smb.

Checked folder permissions, everything looks ok (RWX on the enclosing folders and all the files). Good idea though. Individual file permissions are ok because if it’s at the top level, Roon reads all the files (and parses their filenames) properly.

If the path is really cut-and-paste as you have it, then I’d immediately suspect the “/• DSD/” in the pathname.
Special characters cause special problems : lose the “dot”. Spaces (blank fields) were also bad practice until not that long ago, especially when mixing operating systems…

Appreciate the suggestions, but the • doesn’t cause a problem. There are hundreds of albums in that folder. None have a problem.

Hey @Mike_Pinkerton – any luck here? Are you confident you’ve ruled out the maximum path issue?

Am I correct that you’re able to access these files via Finder, or are there also problems looking at the file directly?

Any chance it’s something like this?

I’m still stumped. I changed all the intermediate folder names to be short and it still is a problem, yet loads correct when at the root. Many other filenames in the same hierarchy that doesn’t work are much, much longer.

The error -36 was on other folders I was copying at the time, and may or may not be related.

I can access these files fine via Terminal and Finder. They play perfectly in Roon when at the root folder.

What more can I do to help debug this?

Sorry for the slow response here @Mike_Pinkerton – any idea what changed between this:

and this:

Just trying to make sure I understand what you’ve tried so far, so we can get this working.

I shortened the enclosing folder name down to “Mozart” and moved it to the top level Roon folder.

Ok, so the current path is:

/Volumes/Roon-Music/• DSD/Mozart/DSF/01 - Concerto KV 365 (1779) I. Allegro.dsf

And other files in the /• DSD/ folder are loading?

Sorry to make you run the gamut here, but how many levels down does a file need to be before Roon won’t see it?

Been trying to track this down, here’s what I’ve found:

  1. Yes, all other subfolders with files in the “• DSD/” folder are importing correctly.

  2. The path that works 100% of the time is “/Volumes/Roon-Music/Mozart/DSF/01 - Concerto KV 365 (1779) I. Allegro.dsf” (Mozart folder at the top level).

  3. Moving the DSF folder itself to the top level does not work. That is to say, “/Volumes/Roon-Music/DSF/01 - Concerto KV 365 (1779) I. Allegro.dsf” does not work.

  4. Moving the DSF folder down a level into the DSD folder does not work. That is, “/Volumes/Roon-Music/• DSD/DSF/01 - Concerto KV 365 (1779) I. Allegro.dsf” does not work.

It’s as if something in Roon has latched onto that specific path, and it refuses to recognize it anywhere else. Every time I move the folder, I force a rescan of the SMB mount from Roon.

I’m stumped. Any thoughts?