Won't Stream to Sonos System

Core Machine (Operating system/System info/Roon build number)

Windows 10 / i9 9900k, 32 GB Ram, 2080ti / Latest

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Full house network with an araknis router / switch. Roon is running on ethernet PC and all sonos amps / beams are running on ethernet as well.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos system which is detected by Roon, but when I go to play music (via either the airplay or sonos option) I get no sound or a message saying that roon has lost control of the audio device.

Description Of Issue

I can’t get audio to stream properly. No audio using airplay or sonos directly to any of the amps or beams. I get the message as described or no audio whatsoever. I also can’t find my core from the phone app if that helps. Roon detects all my devices on the network with no issue, including my A/V receiver as everything is hardwired.

Hi @Joe_Wishnia,

Are you playing local content or TIDAL/Qobuz? Does it matter which type of content you’re playing?

A few days ago this happened to all three of our Sonos endpoints too. The first time ever (in over 2 years of Roon use). The problem was resolved by refreshing the Sonos IP addresses after rebooting the router.

Just streaming. Local content crashed the app completely where I couldn’t even get it open.

Mine are on static IPs would that work on my end?

Hi @Joe_Wishnia,

Have you ever been able to get any audio to output through these Sonos zones?

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

No I haven’t gotten any audio whatosever. I will check my firewall settings, but didn’t see roon at the list at all the first time I looked.

Hi @Joe_Wishnia,

If you don’t see Roon added there, you can manually add Roon.exe and RAATServer.exe, you can post this in the Windows Explorer path: %localappdata%/Roon/Application