Work Part tags not correctly displaying works

Content you’re reporting an issue with

Having re-tagged an album using work/part, Roon now appropriately divides the works, but while each part is named correctly, the work itself is simply named with the Album title.
In the screen shot you can see both what Roon displays and how the track is tagged.
It should appear as Concerto No. 5 Op. 6 with the Part as 2. Adagio
Instead the work title appears (and for all works on the disc) as Concerti Grossi (12) Op 6

Have you made any edits to this content in Roon?

All I have done in Roon is to change the metadata option to prefer file for multipart works.

Is this content from local files, TIDAL, or Qobuz?

Local files

That would be a composition. You might try to go to the composition screen and see if you can edit the composition name there.

It’s a set of compositions, sure, but there are 12 of them in total, and 6 of the 12 are on the disc, and they teach have a different name. The name that is being used by Roon for each composition is the album name (a not identified album). I have tagged them all separately as works, with their appropriate name, according to the Roon best practice guide. Still not helping to get the right outcome…!

I have now tried to change the metadata settings to prefer file in both the album and the composition screens and it doesn’t help. The name cannot be edited from the composition screen, only the metadata options.

Now I see that the version of this appearing in the composition screen is a complete set of the 12 concerti from a different recording. The partial set from the recording I am wanting to fix does not appear in the composition screen at all. However the complete set from the other recording has each concerti listed as a part, and does not seem to list the individual movements.

what to do! I thought the work/part tags on a non-identified disc would prevent such cross pollination? lol

That is not the album title you are seeing but an alternative formatting of the 12 Corelli concerti that you do not want. Unfortunately, you are not going to find much consistency in the way in which roons metadata sources deal with these types of “portfolio” opus. Other famous examples include the Vivaldi four seasons and the Chopin 24 Preludes. Sometimes all the compositions in the opus are bundled together, sometimes they are separated out. It’s all a bit hit and miss.

If you want to separate the concerti then in general you need to go to to see the canonical forms for the individual concerti. So for the Corelli Concerto Grossi No. 1 it is:

Concerto Grosso in D major, Op. 6/1

This is what you need to use for the WORK tag. You will find the canonical form you need for the other 5 concerti on as well. So for example, the famous no. 8 is:

Concerto Grosso in G minor (“Christmas Concerto”), Op. 6/8

For an unidentified album like this, in general I find it is better to edit your own tags to comply with roon requirements. Sometimes there may be less work involved if you have multiple performances in your library as you can then often just “merge” compositions in the composition browser without directly editing your tags.


many thanks Tony!

Update: the real solution here is to not just use the work and part tags, but to use the work, section, part tags. With each Concerti as a section, it displays correctly. And as Tony indicated, to use the Allmusic forms. Thanks again!

Section tags will not be for everyone. If you like using shuffle and/or radio you may not want roon to treat the 12 concerti as a single 2 hour plus composition played end to end. You may prefer roon to queue up a single 10 minute concerto with other music, especially if you just have a spare half hour or so.

lol indeed. There are no end of complications. You would think a toggle switch in settings that allowed you to personalise what shuffle and radio choose (wholes or bits or bits of bits) would be the answer there. But no doubt there are complexities to operationalising that… thanks for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.