Wrong sample rate


#1

New to Roon. Using the asio driver for my motu pci audio interface, windows 7. Basically, roon can’t switch the sample rate, so depending on the initial rate, it either plays 2x or 0.5x speed. Been stuck at this for a few weeks, so can’t really play mqa files since manually changing the rate is a pain. I saw some old thread from 2015 describing the exact problem as being a driver problem with some roon workaround.

Anything I can do to work around this problem?


(Mr Fix It ) #3

Use the Roon DSP option to upsample all output to the max your dac can take or any value you are happy to listen at.

https://kb.roonlabs.com/DSP_Engine

Might not work as well for system output but worth a try


(John) #4

Hello @Zulu,

I am able to successfully change sample rates using ASIO devices we have in-house, it appears that there is something different about the Motu interface in regards to switching sample rates in ASIO.

Some research shows that this is not an uncommon problem with Motu PCI-E devices on Windows

I would recommend reaching out to Motu for guidance on the issue. In addition, the DSP Engine solution that @wizardofoz suggested may work very well for your purposes.

-John


#5

Thanks. I ended up upsampling. This also had the bonus of being able to use my external clock source, which is better than the internal. So worked out well overall.


(Mr Fix It ) #6

win win then


(system) closed #7

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.