XL NAA some dropouts on Pi 3

Feedback 947ff8d0e38f3aa7

I was using NAA on a Pi 4 without issue. Wanted to use the Allo USBridgeSig to test sound quality of the Allo device. Now I’m getting random dropouts. Before I spend too much time troubleshooting this, @spockfish can you please look at log and tell what’s wrong? Thank you.

Signalyst doesn’t supply Pi 3 images anymore. Maybe this is the reason?

It could depend on your HQP upsampling settings, afaik the Usbridge should be fine up to dsd256

I’m at 30% CPU HPQ machine and it works fine on a Pi 4.

Very strange that the USBridge Signature is falling over so easily.

It doesn’t mean anything, which is important is the dsd rate you’re upsampling to with the Usbridge .
Usbridge cannot do more than dsd256

I’m going to DSD256 or DSD256x48.

What if you upsample to dsd128? Do dropouts occur too?

I’ve not tested that :slight_smile:

OK, update… I tried the latest Diet Pi with same results (actually, maybe, just a slight better result). I tried the Allo GUI version of the Diet Pi Software and that is just silence with the random pop of music (so way worse).

Allo has a specific USB driver for the signature. However, the latest module from their ftp site is for an older version of the kernel than what is shipping on the latest DietPi. Its unclear if the normal DietPi is using this driver.

Its unclear if RoPieee is using this driver.

Geentoo Player is using the driver but that software won’t do anything without a key (I emailed them, waiting to hear back).

The USBridge Sig should do DSD256 but for some reason mine only almost does it. At the end of the day, if I can’t solve this, I’ll just go back to the Pi 4 for now and start shopping for a new streamer (or try one of the CM4 → CM3 adapter boards if I can find a CM4).

But, this is a mystery I’d like to solve as it should work.

it is. reluctantly I might add :wink:

1 Like

RAAT works. NAA does not.

I’ll go ask in the HQP section. Thanks for confirming spockfish. I assume you don’t see anything obvious in that feedback? For reference what NAA version are you using?


  • Working / Core → USBridge Sig → DAC
  • Not Working / Core → HQP → USBridge Sig → DAC

Working with RAAT:

Not working with NAA:

I’ve opened a thread under HQP for reference

This is working. Sadly, no more RoPieee on my USBridge Signature :frowning:

  RamSystem Mode 1
  Free memory: 149MB of total 964MB
  GentooPlayer   | 
  v7.00-119      | Raspberry Pi 3B/3B+ (aarch64)

 Architecture |     aarch64
 Temp         |     49'c : 120'f | Optimal.
 Governor     |     performance

RoPieee is 32-bit on the PI 3. That could already be the difference as it is probably getting out of steam with those sample rates :wink:

Can you send me the kernel config? Just curious.

Something like ‘cat /proc/config’ or ‘zcat /proc/config.gz’ should do the trick.