XLD Ripped Files in Skipped Files via MacBook Pro to NAS Storage

Roon Core Machine

Intel NUC 10th Edition 8GB RAM, 256 GB SSD running latest version of ROCK and Core

Networking Gear & Setup Details

Netgear 10/100 5-port mini-switch linking NUC directly to ISP’s Router and Netgear ReadyNAS Duo (4TB, 385GB free)

Connected Audio Devices

Various Chromecast Devices
Cambridge Audio StreamMagic 6 V2 via RPi4 running Dietpi
SMSL M6 via RPi4 running Dietpi

Number of Tracks in Library


Description of Issue

I regularly download files from a variety of internet sources and copy them to my NAS from my MacBook Pro (13-inch, 2020, Two Thunderbolt 3 ports) running Big Sur (11.4). Roon never fails to add these to my library.

Recently I started to use XLD to rip files from CD and all of these files end up in Skipped Files under I/O Failure. I can’t work out why.

What did I do to investigate? I looked at the files in the command line and saw that the permissions weren’t the same so I tried to change them assuming Roon couldn’t read the files. However, it worked for a couple of albums, but some are stubbornly refusing to become part of the library.

When doing a forced rescan I can see the number of imported files jump up to the number I expect if my files were successfully processed and then drop down again as if they are starting, but failing to be completely imported.

Any suggestions about what to do?

I’m not with Roon Support, but I use/have used a similar setup for ripping CDs. To diagnose your issue, first try to go Settings>Library>Skipped files and check what’s there. Roon may skip files because they are somehow unreadable, or because the file names do not conform with Roon’s name restrictions. More details here. By default, XLD uses the track title to make the ripped file name, but that may lead to forbidden characters in the file name. You can adjust that in XLD Preferences>File Naming. There’s more, but this is a start.

Thanks, I had already done that unfortunately and it helped a bit. I forgot to put the specific reason the files were in Skipped Files. I’ll update my original post to include that.

Hi @Johnny_Maelstrom, can you share one of the albums that won’t download with us? You can send a link in a PM here on the site and we’ll take a look.

Thanks. I’ve PM’d you.

Update — We continued this discussion in a PM. We couldn’t reproduce on our end and after moving around the files it couldn’t be reproduced by Ian either. We will continue via PM if issues return.

1 Like