Yet another problem with Roon Backup

Roon Core Machine


Networking Gear & Setup Details

iOS tablets connected thru WiFi
Main system connected thru USB
Headphones connected thru Ethernet

Connected Audio Devices

ROCK -->USB–>iFi iDSD Pro
Etherent–>Rpi->Topping D90

Number of Tracks in Library

about 20K

Description of Issue

Backup has been failing -

Yes, it’s true that my Dropbox is full (I must address that at some point), but the drive on ARRAKIS has 350GB of free space. Furthermore, if I force a Backup to that drive, it completes successfully. Here’s one I did just now.

It appears as though a switch is not being reset from finding the Dropbox being full to trying to backup to the ARRAKIS drive.

Before I address this bug by (temporarily) removing the Dropbox backup, does @support want to look at any logs?

You Nerd :nerd_face::nerd_face:

A homage to G.O.A.T. of sci-fi novels.

1 Like

Hey @xxx ,

Thanks for the report. I looked over your diagnostics and it looked like the backup failed due to an SMB error, not due to storage. I’d be interested to see if you have the same error if you try to connect to the share via IP address instead of Hostname. If you can try this, see what happens and then remove the Dropbox, I would be curious about the result, thanks!

Thanks for your quick reply.

If it’s an SMB error, wouldn’t it also fail if I force a Backup? As you can see from the above screen shot, a forced Backup always runs without a problem.

Would an SMB error manifest in the code thinking my drive is full or is that message a result of the code putting out the wrong error message?

Still, I will try tonite using an IP address.

@noris, It was an SMB problem. After I changed to an IP address everything worked. Dunno why the trouble all of a sudden, but I’m going to mark this solved and think about it later…

OTOH , there is a problem with the message. For yuks, I switched the times around so that the ARRAKIS backup kicked off before the DropBox backup. In that case, the proper message was displayed, i.e. a directory problem, not a full drive problem. So, either a switch is not being cleared or the message buffer is not being refreshed, or some combination of the two.

Is it a big deal? No and yes. In light of the more damning bugs then no, but if the proper message had been displayed I could have taken further steps before I bugged support.

Thanks for your time. Hope this bug gets communicated to the devs.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.