Zone Delay (Chord Mscaler + Bluesound)


Been a roon user for years, but honestly ready to give up. Cannot get zones to sync at all. My main source is:

Chris Hugo TT2 + Mscaler
Nucleus directing traffic

Trying to get it to sync in adjacent kitchen zone powered by a Powernode 2i.

Now, i’ve researched this a lot, i’ve tried prioritizing, zone delays, etc. Nothing works, and the echo is unbearable.

I’ve got tremendous network speed feeding the equipment so it doesn’t seem to be bandwidth issue.

I guess my hopes here is that someone has this combo and discovered an optimal setting.

Kind of tired of it being the topic of conversation when we have a group over or are just trying to enjoy a little listening.

Thanks to anyone here that can offer some help-

I suspect this is caused by inherent latency in the M Scaler, which can be up to 600ms. Have you tried using video mode when combining zones?

BTW, I don’t have the M Scaler, but have Chord kit, and was reading about the WTA filter.


Are you trying group the Zones as because different manufacturer’s kit probably won’t synchronise.
Mscaler video option might help but usually only resolves synchronisation of video to audio (lip sync).

1 Like

You can do some zone delay compensation in the device settings. This allow roon to compensate for the additional delay in the digital processing.

I do this for my digital monitors.

You will likely need to experiment to get it right.

It’s in Device settings / advanced / zone grouping delay


Thanks Greg, yes have tried this but with no luck. Appreciate the response

will try this as I haven’t yet- seems like it won’t work based on other responses/research

To function, the mscaler adds a delay as it needs X samples before it can complete its processing. To compensate for this delay you need to add delay on the other zones.
I beleve the mscaler delay is dependent on resolution or maybe it upsamples everything first? I don’t remember. But this is why you’re having issue and maybe why Chord reprts “up to 600ms”. I think all Chord DACs add some level of delay to run their filters but mscaler is significant. So, worse case you have the 600ms from the mscaller plus some delay in your TT and this may vary based on resolution. Or run mscaler in video mode for a more predictable delay (as another poster suggested).

You’ll need to bypass the mscaler (second input on tt?) or fiddle with the delay towards the 2i.

Good luck.