Zone object: 'is_pause_allowed' is false when Internet Radio is playing

When internet radio is playing, the ‘is_pause_allowed’ boolean within the Zone object is set to false. When something from the library is playing then ‘is_pause_allowed’ is set to true, as you would expect.

The ‘state’ within the object is correctly set to ‘playing’, so that’s what I’m using as a workaround.

{ zone_id: '',
  display_name: '',
  outputs: [Object],
  state: 'playing',               <-- Internet Radio is playing...
  is_next_allowed: false,
  is_previous_allowed: false,
  is_pause_allowed: false,        <-- ...But pause is not allowed ??
  is_play_allowed: false,
  is_seek_allowed: false,
  settings: { loop: 'disabled', shuffle: false, auto_radio: false },
  now_playing: { }

Requires this a fix at the Core side?

I just noticed that when internet radio is playing there is a stop button shown on the Roon remote, but when something from the library is playing then a pause button is shown. This, kind of, explains why ‘is_pause_allowed’ is not set for internet radio, but what is missing then is a ‘is_stop_allowed’ flag.

Am I right that there is a gap?

I believe when playing there’s never a condition when stop is not allowed, hence no need for an indicator.

IF state: ‘playing’ AND is_pause_allowed: false
THEN ok to stop.

IF state: ‘playing’ AND is_pause_allowed: true
THEN ok to stop or pause.

One for @Brian to confirm.

1 Like

Thanks @Carl, that makes sense.

1 Like