Zones sometimes disappear

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
+1 for this.
I have had the exact same issues as described for a long time and need a solution.

Hi @Andreas_Andersson,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Thanks!

Hi @dylan, sorry for such a late response…

What I was referring to by “+1” in this topic was that I also experience the same issue, and we have already tried to solve it once ( Roon stops playing music )

That one was closed a long time ago, problem still exist though. And browsing the community I can see that I am not alone in this. Having a Mac Mini seems to give other people the same issues I have: Roon just stops playing music and also seems to lose connection to the Zone that was playing.

Yesterday I tried the following:
Installed Roopiee on a Raspberry Pi4. The Pi is connected directly via usb to my Meridian AC200 preamp. My core, Mac Mini, hold all the music on an internal SSD and connects to the Rpi via Wifi.

With this setup I was hoping to get rid of my problem since the optical out is no longer used on the Mac Mini and MacOS should therefore not interfere with the sound output.
But I still experience the same issues.

Not sure if there is anything wrong with my Mac but since I am not alone with this issue it seems like replacing the Mac might not be the solution.

Do your team have any ideas on how to solve these MacOS issues?

Hello @Andreas_Andersson, can you elaborate on your network setup for me, including models and other information you have? Also, have you tried another device as a core temporarily to see if your suspicion is correct?

Hi @nuwriy, completely missed that you asked me a question here, sorry for that.

You can read up on my setup here Roon stops playing music

The only difference now from then, is that I have replaced my Apple router with a Netgear Orbi Mesh system.

I have also tried to use a Raspberry Pi4 as a bridge (with Ropieee).

My issues are still there though, music plays for a some time and then suddenly it stops. Roon displays "Select Source (or is it no source found? well something like that anyway) instead of the progress bar at the bottom of my screen.

I have not been able to test with a different core. That would most definitely solve my problem but as I’ve said before, it feels like I am not alone in having issues with MacOS, and there never seems to be a solution. Could be that MacOS is just not good enough for Roon, not much to do about that but switching to another OS.
Still have a feeling though that there may be some setting one can change (in Roon or MacOS) to prevent this from happening…

1 Like

Hello @Andreas_Andersson, we have a good number of Mac users operating successfully, but all systems have issues similar to what you’re describing from time to time. I’d definitely recommend trying a different core to see what happens, as well as testing with only wired connections to see if this produces a different result. If you are able to test using a mobile hotspot or different network, that would also help us determine the issue.

@nuwriy Hi again, I have still not been able to try out with another core, but I did find this browsing around the forum. Roon vs. Audirvana
The user @Muse states that Roon is “useless” on a MacMini Late 2012 with SSD (music stops every 25 seconds).
I mean, that sounds exactly like what I have…

1 Like

I confirm it. It’s useless on my Mac Mini late 2012 (8go / 512 SSD) and I really can’t figure why since it works perfectly on the same network (wifi routeur and Synology Nas) with another machine (IMac). It’s annoying since can’t let the IMac on 24/24 (the power consumption is not the same).

Hi @nuwriy,
I have not been able to run my core on a different computer, but I have started analyzing log files.

Have a look at this:

########################################
12/14 12:23:54 Critical: [easyhttp] [35] Post https://swim.roonlabs.net/1/session/begin web exception without response: : System.Net.WebException: Error getting response stream (ReadDoneAsync2): ReceiveFailure
at System.Net.WebResponseStream.InitReadAsync (System.Threading.CancellationToken cancellationToken) [0x000f3] in :0
at System.Net.WebOperation.Run () [0x001d9] in :0
at System.Net.WebCompletionSource1[T].WaitForCompletion () [0x00094] in <f34012a0712d47c3928ecd2def984fcd>:0 at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000f8] in <f34012a0712d47c3928ecd2def984fcd>:0 at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00020] in <f34012a0712d47c3928ecd2def984fcd>:0 at System.Threading.Tasks.TaskFactory1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func2[T,TResult] endFunction, System.Action1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in :0
— End of stack trace from previous location where exception was thrown —

at Sooloos.EasyHttp.QueryAsync (Sooloos.EasyHttp+HttpMethod method, Sooloos.EasyHttp+Params p, System.Threading.CancellationToken canceltoken) [0x006d9] in <8a7d431c803e4df5b37ea46adac11a0f>:0
12/14 12:23:54 Critical: [mlradio] [4] failed to init swim: System.Exception: /session/begin failed: 999
at Sooloos.Broker.Music.Radio.SwimProxy.Begin (System.String profile_id, System.String user_id, System.String broker_id, System.Collections.Generic.IList`1[T] collections, Base.JDictionary seed, System.Int32 n_items, System.Int32 n_preplay, System.Boolean verbose) [0x001fd] in <3deaa7333e174f27bbd18500ac7eed87>:0
at Sooloos.Broker.Music.Radio.MLRadioSession.Init () [0x007e1] in <3deaa7333e174f27bbd18500ac7eed87>:0
12/14 12:23:54 Info: Alert: Roon: swim_offline_unexpected_error
12/14 12:23:54 Info: Alert: Roon: swim_offline_unexpected_error
12/14 12:23:54 Trace: [dbperf] flush 0 bytes, 0 ops in 1 ms (cumulative 0 bytes, 0 ops in 3196 ms)
12/14 12:23:54 Info: [radio] [4] Set familiarity to 0.5
12/14 12:23:55 Info: ComputeSwimType(LimitToSeed=False, PerformerIds.Count=0, ComposerIds.Count=0)
12/14 12:23:55 Trace: [zone MusicMini] Loaded Queue=4230 Tracks Swim=Active AutoSwim=True Loop=Disabled Shuffle=False
12/14 12:23:55 Trace: [MusicMini] [Lossless, 16/44 ALAC => 16/44] [100% buf] [PAUSED @ 0:56/3:57] Youngstown - Bruce Springsteen
12/14 12:23:57 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
12/14 12:23:57 Trace: [push] retrying connection in 8007ms
12/14 12:23:57 Info: [transport/zonedisplay] Zone display registered: Chromecast Ultra
12/14 12:24:07 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
12/14 12:24:07 Trace: [push] connecting to 34.74.254.52:9200
12/14 12:24:07 Trace: [push] connected
12/14 12:24:08 Info: [stats] 5726mb Virtual, 556mb Physical, 192mb Managed, 78 Threads, FDs

###################################

This is a case where the music just stopped. The zone I am playing from is called MusicMini (which is my Mac Mini that is running the core and is directly connected to my preamp with an optical cable)
I do not fully understand the logs but it seems like the issue is related to the “swim” functionality (old Sooloos stuff still lying around??)

Hello @Andreas_Andersson, the trace you posted was related to an issue we had yesterday which you can learn more about here.

Hi @nuwriy,
ok that’s both great and unfortunate. Thought I had found something that could explain the drop outs I experience.

What about this one then? Roon is now saying that I have too many Drop Outs. I am playing directly from my Core so there should be no “network issues” involved.

12/16 11:35:40 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:6339,“status”:“Dropout”}

12/16 11:35:49 Trace: [MusicMini] [Lossless, 16/44 ALAC => 16/44] [98% buf] [PLAYING @ 0:52/5:00] Spirit in the Night - Bruce Springsteen

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Warn: [MusicMini] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:24255,“status”:“Dropout”}

12/16 11:35:49 Warn: [raat/tcpaudiosource] send failed: The socket has been shut down

12/16 11:35:49 Warn: [raat/tcpaudiosource] disconnecting + retrying

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“samples”:22050,“status”:“Dropout”}

12/16 11:35:49 Trace: [Built-in Output] [raatclient] GOT [7] {“status”:“Ended”}

12/16 11:35:49 Trace: [MusicMini] [zoneplayer/raat] too many dropouts. stopping stream

12/16 11:35:49 Debug: [raat/tcpaudiosource] disconnecting

12/16 11:35:49 Warn: [MusicMini] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream

12/16 11:35:49 Trace: [MusicMini] [zoneplayer/raat] too many dropouts. stopping stream

12/16 11:35:49 Warn: [MusicMini] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream

12/16 11:35:49 Trace: [MusicMini] [zoneplayer/raat] too many dropouts. stopping stream

12/16 11:35:49 Warn: [raat_ll/client] [Built-in Output] error writing to connection: System.NullReferenceException: Object reference not set to an instance of an object

at Sooloos.Audio.Raat.Client._BeginWrite () [0x00053] in <3e0551b6366c4f068566be0bba33860a>:0

@nuwriy ping

Have you had any time to look into the latest log yet?

One other thing I have noticed while fault tracing is that when Roon stops due to the “drop outs”, it also seems to disconnect all units connected to Roon.
Example:
Was playing to my iPhone (local media stored on my Core), drop out occurred, and then, according to the logs, my MacBook Pro was also disconnected (as was my iPhone).

Do Roon automatically disconnect from all units when it detects an error?

@nuwriy

New updates:
Have now tried to run on another core (this time an old MacBook Pro rom 2009, Core 2 Duo processer). That one should not be up to the task of running Roon but it actually works without any apparent hiccups. It is running on wifi only.

My old core (the Mac Mini) is now set up to run as a remote instead of core. And it works. No dropouts so far (have been playing for 1h now without drop outs, previously I could only play for a couple of minutes). And I could play simultaneously (different tracks) to 3 different zones!

So… my Mac Mini cannot act as core but it can act as a remote running from a far less powerful core.
Most of my music is however stored on the Mac Mini SSD, meaning I cannot access that now, right?

I have a few albums on the MacBook Pro, and I have enabled Tidal so that I have more music to listen to.

Can you explain why the Mini can act as Remote but not as Core? It is not running any heavy tasks (no DSP, no streaming to several zones, etc). Issues with my SSD?
I have run diagnostics on the SSD but MacOS did not find any issues.

Ideas?

I cannot have the MacBook Pro as Core for long