Zoorloo Ztella with Roopieee


Is anyone using the Ztella DAC with Ropieee? I am thinking about getting it as a back up and wondering what experiences people are having with it when using Ropieee.

Hi, I am using ropieexl and ztella zorloo usb-c mqa dac, works great. sometimes (after rebooting I think) I have to disconnect and reconnect the dac though before it’s recognized. But other than that no problems.

Have you tried it on the regular Ropieee or do you recommend upgrading to XL?

I haven’t tried the non XL version. But I don’t see any reason why it wouldn’t work with ropieee as well as it is the same system. XL just has support for a screen and more bolted on:

next to Roon you can use DLNA, Airplay® and Spotify® technology to stream audio.

ropieee just supports roon and nothing else.

And the screen :wink:

nice, did not know that, just googled it :smiley:

btw, do you have any idea why the dac might disappear after a reboot by any chance?
when working:
384.967452] usb 1-1.2: new high-speed USB device number 7 using xhci_hcd
[ 385.173617] usb 1-1.2: New USB device found, idVendor=2454, idProduct=1292, bcdDevice= 0.01
[ 385.173644] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 385.173665] usb 1-1.2: Product: Zorloo Ztella USB Audio
[ 385.173684] usb 1-1.2: Manufacturer: Zorloo
[ 385.173700] usb 1-1.2: SerialNumber: 20191209
[ 385.188342] input: Zorloo Zorloo Ztella USB Audio as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/00
[ 385.257685] hid-generic 0003:2454:1292.0001: input,hidraw0: USB HID v1.00 Device [Zorloo Zorloo Ztella USB Audio] o
n usb-0000:01:00.0-1.2/input3
[ 385.260946] hid-generic 0003:2454:1292.0002: hiddev96,hidraw1: USB HID v1.00 Device [Zorloo Zorloo Ztella USB Audio
] on usb-0000:01:00.0-1.2/input4
[ 385.428171] usbcore: registered new interface driver snd-usb-audio
[root@ropieeexl ~]# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 2454:1292
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@ropieeexl ~]#

after some small detective work it seems to be using the snd_usb_audio module. is this built as a module, or built into the kernel? There seems to be a problem recognizing the dac during boot ( usb 1-1.2: device descriptor read/8, error -71 <-- dmesg output from booting)

It seems to be similar to the problem I am having with the Beam 2. It appears for a second as a device on Roon and while it’s “enabling” it the DAC disappears. It’s almost like something is timing out.

Hi @Magnus_Tuominen,

i’ve pushed a kernel update to the beta channel. The Raspberry Pi guys found something that might be related to this issue.

Could you try out? Changing to the beta channel can be done from the ‘advanced’ tab.



I just tried it and got the same results. I sent you feedback: c78aee095495c91d

this is definitely not the same problem as Magnus has.

On system level it seems fine, but I see that the RoonBridge software mentions a time out and closes the connection. I also see that you’re on wifi (I totally looked this over), so I suggest you first test the unit with a cable connected to rule that one out.


Yeah I’m afraid the device isn’t behaving nicely.

snd_usb_audio is a module, but I’m not convinced that makes a difference: upon reading the descriptor it should load the module. If that fails it won’t load the module, but if the module would be built in I would still expect the device to fail.

However, this we can test very quickly. Are you in for this? Then I build a kernel where the module is built in and you can test it.

Let me know.



Is this for my issue or Magnus ? I can do a test for my situation. What should I do?

The new kernel test is for @Magnus_Tuominen.

The test with cable instead of wifi is for you.


I wired it directly to the modem and the same thing occurs.

Good morning, I’ll give it a try later today when I get off work.
edit: updating, no change:
Windows Terminal

3.757847] usb 1-1.2: new high-speed USB device number 6 using xhci_hcd
[ 3.789474] usb 1-1.2: device descriptor read/all, error -71
[ 3.789731] usb 1-1-port2: unable to enumerate USB device

Hi @Magnus_Tuominen,

I’ve pushed a kernel update to the beta channel with the USB audio driver baked in.
Let me know if this makes a difference.


no difference, this is new though: attempt power cycle.

1.947415] systemd[1]: Set hostname to <ropieeexl>.

[ 1.978052] usb 1-1.2: device descriptor read/64, error -71
[ 2.197793] usb 1-1.2: new high-speed USB device number 4 using xhci_hcd
[ 2.298030] usb 1-1.2: device descriptor read/64, error -71
[ 2.377480] random: systemd: uninitialized urandom read (16 bytes read)
[ 2.377906] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[ 2.378360] random: systemd: uninitialized urandom read (16 bytes read)
[ 2.378657] systemd[1]: Listening on udev Kernel Socket.
[ 2.378895] random: systemd: uninitialized urandom read (16 bytes read)
[ 2.378940] systemd[1]: Reached target Remote File Systems.
[ 2.379192] systemd[1]: Reached target Swap.
[ 2.394162] systemd[1]: Listening on Process Core Dump Socket.
[ 2.396979] systemd[1]: Created slice User and Session Slice.
[ 2.397640] systemd[1]: Listening on Journal Socket (/dev/log).
[ 2.518406] usb 1-1.2: device descriptor read/64, error -71
[ 2.587022] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 2.638876] usb 1-1-port2: attempt power cycle

Yes I think that’s related to the latest patch.

For some the reason the Ztella doesn’t ‘behave’ properly.

Just to be sure: have you tried the other ports on the Pi as well?

Oh. And another thing… Did you try another power supply unit? Just to be sure?