“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

The diagnostic code from my core.

This looks like a configuration problem in your network for ARC, not the temporary issue on the Roon side that was the cause of this thread, i.e.:

Most likely, you have UPnP enabled on the router, and you have a conflicting manual port forwarding rule configured on the router. Fixing the router configuration (either disable UPnP on the router or delete the manual rule) may fix this. Else, it will be best if you open a new topic for this error in #support:port-forwarding-help


“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED XXX.XXX.XXX.XXX:55002, response code: undefined, body: undefined”},

This usually means that something is not quite setup right. Some things to try:

Check to see if UPnP is fully enabled in your router
Try to manually open the port in your router configuration
Make sure the IP/Port matches

If the above does not help, please answer the following questions:

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Thank you. I‘ll check this. But I‘m wondering cause I didn‘t change anything on the router.
And before it run well, besides the general problem 2 weeks ago. The other reason why I don’t think, thats the configuration of my system is, that my dad has the same problems since two days. He has his own system on a different place.

OK, thanks, good information. However, ECONNREFUSED and the rest of your error message is a quite typical error that has come up in many posts and was usually a configuration issue, at least as far as I have seen.

Your dad has the exact same error message?

In any case, it would be good to check the router settings for UPnP and manual rules, if only to rule it out as a possible cause.

(The issue in the other thread affected all or at least a very large number of people because the Roonlabs server was broken. Currently, we don’t have large numbers of people reporting connectivity problems)

  1. German Telekom
  2. AVM Fritzbox 7590
  3. One Netgear Switch
  4. Nothing

Thanks. Not a problematic configuration. Do you know your way around the Fritzbox settings and can you check UPnP and manual rules?

@Flex_Westermaier More questions:

  • Are you using Deutsche Telekom for the phone as well?
  • Do you have the option to check if ARC works from a different external network? E.g., the wifi at your corner cafe or something like this.

Asking because I have DT as well on the phone and ARC did not work for one night and day recently, then continued as normal. This was during the recent large-scale cell network outage in Germany (which didn’t much affect DT). A port scan from my phone to the Core suddenly revealed the port as closed, and only when the phone was in the DT network. So maybe not impossible that DT made some changes in their network that may be lingering for you.

But how can it be a coniguration issue, when it worked very well before?

I contacted my dad. Since yesterday it worked fine again. So he has no error message. For him it was also like the general issue. First it didn´t worked. Then it worked again. He did nothing to solve it.

I´ll check the router in the evening again, but I´m not sure what to change there.

Actually yesterday I did another reset of the core. Since then my error message is gone and the core says the system runs properly. It´s ready and I can securely access the core. I also reinstalled the Arc App. After login in the arc app finds the core immediately. Then it starts with the synchronisation and after some time I got the message that it takes longer then normal.

Before I did this the Arc App worked but played no song, I always got the message with the poor conection,…

For my mobile I use O2 - Telefonica.
The ARC doesn´t work in external network neither with 5G on the go.

The workaround with reseting the core and reinstalling the app I also did at the general cause two weeks ago, with the same results.

Thanks for your help! I really apreciate it.

I meant not in the phone network, but with the phone logged into a different network that is not your own LAN. Such as the wifi in a coffee house or whatever

Oh, so it fixed itself by a reboot and reinstall now? Odd, but great. Enjoy

Yes, I did understand you. It doesn´t work in my own network, neither in the network at work, neither with mobile network.

Isn´t it a signal that it doesn´t work in my network, that the port permissions in the router aren´t the reason for my problems?

No, unfortunately it´s not fixed. I just said, that the same things happen after restart and reinstall like to weeks ago.

When I read the other themes in this forum, I have the feeling that I´m not the only one who has this problems at the moment. Do you really think it´s a problem of the configuration of my router?

Indeed it is. However, you never stated clearly before that this is the case that it is not working from a non-cell phone network either. If it didn’t work in the cell but did work in other networks, then it would be a different issue. That’s why I asked.

Work is inconclusive, however, because work networks tend to block many things. Corner cafe, a friend, or neighbor, or similar (anything non-corporate) would be a better test.

By the way, I sense that you are getting annoyed by my questions. Let me know if I should stop trying to help you. If I do try, I need to ask questions.

If you read the other posts more closely, you will see that many people have issues, but they are all in their configuration one way or another and not because Roon servers are not working. The general issue from 2 weeks ago, when Roon servers were not working, manifested itself in a completely different way than yours does now - there was no error message at all in the Roon ARC settings, it said “ready” and it looked like it should be working, but it did not.

I don’t know what your problem is exactly. I would have told you if I knew. We are trying to figure it out together, if you want to. I also have other things to do if your prefer


I didn´t want to sound unthankful. As I wrote before I really appreciate your help. I don´t get annoyed of your questions.

The thing is I´m not a IT specialist and I tell you, how the problem feels for me. And I tell the things from my point of understanding.

In the beginning of arc I couldn´t access from mobile network. I used the instructions in this community configurated my router and then it worked very well. I just can´t understand, with my knowledge, why the router suddenly is origin of the problem I have now.

But I also understand that I should be patient. Arc is new and there can be problems in the beginning.

I really don´t wanted to be rude and I´m not annoyed.

Thanks :slight_smile: I am really trying not to waste your time. If you look at the Activity in my profile, under “Resolved” you will see my posts that were marked as solutions, and there are quite a few for ARC issues. I was forced to familiarize myself because I had big issues myself (caused by Vodafone mostly) and had to figure it out as well.

Sometimes it’s just not so straightforward, I don’t know your setup and have no access, so we need to pool our resources. And I am not promising anything except my best efforts, but eventually we might need other people’s help or have to wait for official support, but that can take days. So maybe better to try and be quicker, and save Roon support resources in the process :slight_smile:

I was being a bit unstructured so far, so let me summarize where we are, so that I have a reference for myself and anyone else who wants to chime in, in the interest of continuing efficiently. Let me know if anything I listed is wrong or missing, please.

The issue

  • ARC not working. Shows message “poor connection”. Neither in own LAN, nor via cell network, nor work wifi.
  • After resetting Core and reinstalling ARC, Roon app ARC settings show “ready”. ARC finds Core immediately, syncs, but then says “taking longer than normal”
  • At some point (when exactly?) it stops working. Then the Roon ARC settings show

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

  • EHOSTUNREACH certainly is precisely Error Host Unreachable. Your router_external_ip is null (i.e., none)


  • ARC worked before
  • Nothing changed as far as you are aware
  • You experienced a similar looking issue 2 weeks ago. After resetting the Core and reinstalling the app, it worked again. This coincided with the general Roon cloud server outage and its solution, but we are not 100% sure how and if this was related, and what was the original cause.
  • (Your dad with a separate Roon at a different location also had a problem 2 days ago but it resolved itself. Cause unknown and very unlikely to find enough details, so let’s ignore for now, but noting that currently it’s not Roon cloud servers causing an issue for him)

The networking environment

  • Phone’s cell network is O2 (Telefonica)
  • Landline Internet is German Telekom. (They typically don’t have special issues with external IPv4 addresses)
  • AVM Fritzbox 7590
  • No VPN or unusual security
  • (A Netgear switch. Presumably unmanaged and not an issue)

Previously suggested checks

  • Make sure that the Fritzbox software is up to date. It’s very likely that it is, but it’s a cheap check.
  • Is UPnP enabled?
    – If yes, make sure that it really is and the router isn’t confused. Disable it, reboot the router, and enable it again.
    – Does it work now?
  • Are manual port forwarding rules enabled?
    – There should be either UPnP allowed for your Core or a manual rule for ARC.
    – If UPnP is enabled and allowed for the Core (on the Fritzbox this is a per-computer setting, at least on mine), disable any manual rule.
    – Does it work now?
  • Disable UPnP and set up a manual rule instead.
    – Ensure that you set up the rule for the TCP protocol and use the port number that the Roon ARC settings are telling you. (50002 according to the error message)
    – Usually it is recommended to use a static IP address on the Core if using a manual port forwarding rule. However, on the Fritzbox this should not be necessary. It should automatically use the correct IP if you select your Core computer as the target for the port forwarding rule.
    – Does it work now?
  • Connect the phone to a different network, like wifi at neighbor, friend, coffee shop, etc.
    – However, you can probably skip that as long as the error is shown in Roon, it is nearly guaranteed that it will not work. (It does not even work on your LAN, anyway)
    – You confirmed that it does not work in your workplace’s LAN (but work networks often block many things)

Is the description correct and did you already go through the suggested steps? Let us know if you need help with any step specifically.

1 Like

@Flex_Westermaier A new update was released, try this as well in addition to the stuff in the above post. Who knows, you might get lucky.

One more thing: There are certainly cases where the ARC app starts showing “Poor connection” (even on home wifi) and then “Can’t connect to core” and “Core seen x days ago”. It seems that in most such cases this helps:

  • Click the Reset button in the ARC app’s settings.
  • Go to the ARC settings in the Roon app and click Reset
    However, affected people usually seem to have “Ready” in the Roon ARC settings in the remote, not an error message like you. So maybe it’s not the same issue. (Maybe you are experiencing this issue as well, but it’s probably separate from your error)
1 Like