ARC is simply unusable for me

UPnP isn’t “bad” but there are a lot of very poor implementations in routers. You can, probably, disable UPnP on your router and set-up port forwarding manually in that router. UPnP is just a way to let services, like Roon Core, to request port forwarding at the router. Doing it manually doesn’t change what is configured on the router it’s just, well, a manual way of doing it. But, in this case, it won’t “timeout” or “go away” or get “cleaned up” or whatever poor implementation your router is doing to clear the forward requested by Roon.


Sorry for your poor experience with ARC. Hopefully you can figure out a solution.

I’m here to say I am also a Plex user and use Plex Amp for listening to my music remotely. Both work very well for me but I’ve been using ARC more and more. I still use Plex Amp because of the download conversion feature.

As a network IT guy, sometimes it’s a struggle trying to figure out what’s causing an issue. Everyone’s network and hardware are different and no easy answer. Good luck. :four_leaf_clover:


I have Roon ARC running with UPnP turned off on both my routers.

It was a bit of a pain setting Roon ARC up to get it working on my main router. As my ISP’s modem/router only gets used to connect my ASUS router to it through an Ethernet connection.


These are the forwarding rules I’ve set in my routers. The Ziggo one is my ISP’s router, the ASUS router handles all the network traffic.

The listed IP address on the Ziggo screenshot is the address the router has assigned to the ASUS router since they are connected to each other.

On the ASUS the IP address used is the address my Roon Core has. And Roon uses port 55000 here, so I have set that port number up in both routers. You don’t need to set a source IP address.

Now it works flawlessly here so far. My Roon Core connects through 5g WiFi to the ASUS router. And I have been listening at work to my music for hours at a time without issues through Roon ARC.


I disagree. Pretty soon, we’ll be told it has to do with a problem on your LAN and sent on wild goose chases, all while all the other network functions in roon work correctly. This will be similar to how roonlabs has handled the the small but ever-present cadre of users experiencing the “metadata improver halting” and “unable to catalog new music” bugs which have been consistently reported for over two years now.


I’m still waiting for this feature in ARC… and the ability to download individual tracks instead of entire albums.

I’m having (and have reported) similar issues. I just can’t rely on it working right now.

If I wanted to use Qobuz as a mobile alternative until this stabilises what is the easiest way to get my offline collection mirrored in Qobuz? Export a CSV from Roon and upload it to something like Soundiiz?

Reliability a real issue here. Went on a 10 day road trip for business and was finally looking forward to having a use case for ARC. Between Android phone, Android DAP, and iPad, two never could connect (‘Poor Connection - Retry’ the entire time) and one lasted about a day and a half before it too was useless.

Couple with that the absence of my bookmarks, clunky implementation of tags, lack of ability to browse Qobuz and Tidal - in other words, missing a true ‘Roon on the go’ experience - plus the lack of a desktop or web app, and this thing is DOA for anything I might want to use it for. Hoping iterative updates will get it closer to useable for me and others in the same boat. Cheers to those for whom it is working.


yup, works a treat

1 Like

As a temporary fix, you might try a script on your server to restart Roon every night. I set my Mac Roon server to restart at ~4 am, and that seems to have avoided a lot of problems people have had with long-running instances.

Restart is like teeth brushing for me, I have no problems but I still have scheduled Router, Mac mini core to restart 2 times in a day.

Here ARC is working like a charm on iPone 14 Pro in combination with AirPod Pro’s #2 eg:

  • in my car or rental car (abroad for work) in combination with my 5G plan through my provider
  • at the office through the company WiFi guest network
  • when being outside for a casual walk or sports or being active at the gym - both 5G or WiFi
  • and above all while flying in offline mode - just downloaded around 250 albums to fore mentioned iPhone.

Setup on day one was a breeze - just some minor change of settings at internet provider supplied hardware (portforwarding rules).

@home using an Intel NUC8i3BEH running ROCK in combination with a Synology NAS on which I store my “own” music / albums.

Streaming provider is QOBUZ.

So far no issues at all …… and so happy with ARC’ performance and convenience that I let go of my DAP + IEM’s which were always with me while traveling.

Just being able to travel light is acceptable since I do have access to my “own” music.

Ergo, really happy with ARC.

1 Like

I’ve given up trying to get Roon ARC to work and I work with computers for a living. I’m not wasting any more of my time trying to get it to work. I’ll wait until Roon sort out the bugs and release a product that works for more users.

Every other piece of software that requires port forwarding has absolutely no problems with my router and modem. Set the port rule in the router and away you go. Apart from Roon ARC.


Sorry for you bad experience. For me it was the first time to have a look at port forwarding, did set up and worked ever since. And it is the cheap modem from my isp. Had once to change the ip adress for the Mac mini Roon Core when I did introduce a Ethernet to USB C in the setup.

Good answer

This is a very clear post explaining what you have to do in a very common scenario where you have an ISP supplied modem running in Bridge mode and your own router (i.e. Asus, Netgear, etc). Roon support should explain the setup with this configuration as you have. I have an Arris Group T4482A ISP supplied modem and a Netgear Nighthawk AX8 RAX70 router.

Well, I just downloaded the latest Roon (I was a couple of versions behind) and tried my setup again and now finally Roon ARC on my main PC is telling me “your Roon Core was automatically configured and has been confirmed to be securely accessible by Roon ARC”. I also do the port forwarding manually and turn off UPnP as I’ve found the implementation to be flakey in the past with other apps.

I’m glad I waited rather than going through all the hoops Roon support wanted me to go through. I’ll go for a walk in the park later and try Roon ARC from my iPhone.

1 Like

Try it now. Turn off wifi, let your phone connect to the cell network, and try ARC. If you are in the park and it doesn’t work you’re just in the park. If it doesn’t from home you can at least do a little troubleshooting like making sure your core is still up and happy.

Yep doing so now. Hopefully it works so I can make even more use of the 90GB/month phone data plan that I have.

Edit: it works.

When plex finalize to scan all my files ARC will be on 2.0

And I should need a new SSD for the metadata of plex

You’re welcome. Only thing I’d like to add is that I didn’t have to set my ISP’s router into bridge mode. I can’t even do it myself as I got a warning that it could only be done remotely.

The reason why I’m letting my ASUS router handle all the traffic is that I’ve discovered that my ISP’s router has a tendency to drop its wi-fi connection for several seconds every now and then. Disrupting everything connected to it. The wi-fi of my own ASUS router is flawless.


I had a nightmare with Soundiiz when I switched from Apple Music to Qobuz. Wrong songs transferred, partial albums, only about half of my music transferred…and so on. I had to go through every song and every album and compare the old service to the new service to make sure it was correct, it took me weeks. Never again!