ARC Port forwarding issue (ASUS router)

Hi @Philip_Gibson
were you able to solve the problem in the meantime?
If not, but everything else works fine with Roon Remote, you could try this:

  1. Do not change anything on the BT Hub and leave everything as it used to be.
  2. Disable router mode in the Asus router and set it to access point mode.

That might solve the problem as you won’t have double NAT anymore.
You would then have to make all the settings manually in the BT HUB. Can the Hub use UPnP?
I would try that first.

If that doesn’t work, disable UPnP again and enable port forwarding if the hub allows for it.
Then manually set up everything for port forwarding there.

Wish you that it works.
However, if not and you want to use ARC, you should consider purchasing another router that can be set to bridge mode.

Important Update

I also live in Australia. I tried everything with the Asus router after going through multiple threads regarding ARC issue, none worked

As @Ben_Archibald1 suggested I rang the ISP, they changed from CGNAT to NOn CGNAt satic IP and that fixed the issue.

Portforwarding works, Roon ARC works :slight_smile:

I also live in Australia and had Aussie Broadband as my service provider, the only way I could get my RT-AC88U working with ARC was to to either pay for a Static IP, which I firstly did, then I read that you can opt out of CG-NAT, so I then did that and ARC worked and I don’t need to pay for a Static IP.

Same here! Please share the solution if found.

Hi Balázs! Please share your settings if possible, struggling here for the second day. Or if you have some spear time contact me on 70/ 678 ötven nulla öt.
Thank in advance!

Please have a look

And here you can test whether port forwarding works.
If this application here can’t see it, ARC can’t see it either.

Hmmm…I dowloaded ARC and I can download files and play music (only on the phone of course) but Roon still tells me it cannot connect ARC. Is this because I am on my own wi-fi network? I’m going out tomorrow and will see if I can remote get in. Is it odd that the ARC works even though Roon says it can’t connect?

This is the root problem.

  1. The modem in front of your router is also doing NAT or
  2. Your provider may be doing CGNAT

The best solution for 1 is to see if your provider can put their modem in bridge mode.

The best solution for 2 is to see if your provider can give you a public facing IP address, usually at an extra monthly charge.

Another option for 1 is to disable DHCP and NAT on your router and let your internet provider’s router do that. You then have to get the port forwarding working on their router. Or put your router into access point mode only and then again get your provider’s router port forwarding working.

Tried everything in the Troubleshooting post, still get this error:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“113.XXXXXXX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.XXXXXXXX”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}

Adding my voice to the CGNAT users who can’t use ARC. I’ve contacted my supplier in the UK (Community Fibre). They have told me they only give public IP’s to business customers (£150pm minimum). I’m waiting for them to contact me with an offer!

I understand there are services which can be used to get a public ip via VPN. At the moment I’m looking at those options. If anyone in the UK has this kind of setup (preferably with a unifi USG3!) I would be really interested to hear ho wit works for them.

A statement from Roon on the subject:

1 Like

Anyone wanting to get around CGNAT might try Tailscape implementation

I was having exactly the same issue. It turns out it wasn’t the router’s settings, but the firewall on my QNAP. I added an exception to allow my specified Roon port (5500*) and all is working well now (actually even though I had an error in the Roon Arc config, the mobile app seemed to be communicating fine).
I hope this helps some of you!

1 Like

Thanks for this post, it helped me to solve my arc setup issues.
I had a virgin media hub acting in router mode, with an asus zen wifi connected to it, and my roon is then connected to the asus via some switch boxes.
UPnP was disabled on the virgin media hub.
Setting up a port forwarding rule on the Asus router did not initially work.
But, as suggested by Axel_Lesch, setting up a port forwarding rule on the virgin media hub to forward to the asus router did the job.


Hi @balazs_kiss,

It appears you’ve been given quite a few things to try. Have you had a chance to do so? What is your current status?


Thanks for following up, @Wes, and also to all who have contributed suggestions. I’ve been tied up with other things so am still where I was – ie, ARC is not working. I did try to resolve things but that was a while ago now. The error message Roon is throwing is:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“x.151.x.81”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

If based on that you can advise me what I may need to do, that would be absolutely fantastic.

Still not working overe here, ASUS RT-AC88U.
Roon core on Synology DS918+ NAS

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

I ended up resorting to the support forum and have managed to get Roon ARC working. I’ve summarised all the key settings (or, at least, the ones that seemed to be key to me) in this thread. I hope you might find it helpful.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.