ARC Port forwarding issue (ASUS router)

Thanks, @Axel_Lesch. I’ve just had a chat with my ISP, BT, and they’ve said that they provide Public IP address to all their residential customers (of whom I am one).

WRT the two routers, both the BT Hub and the Asus ZenWiFi have DHCP servers enabled. Should I disable the DHCP server on the BT Hub (all the wifi is dealt with via the ZenWifi)?


Here’s a guide how to set it up in bridge mode:

1 Like

Thanks yet again, @Axel_Lesch. Unfortunately, I have a BT Home Hub 5. It looks like it’s not possible to put it into bridge mode.

Too bad, mate!

If you’re feeling brave you can remove the BT home hub completely.

I’ve got BT FTTP and it uses PPPoE so I don’t use the hub and just have the ethernet plugged directly into my router.

The PPPoE for all BT home connections are:

Password BT

I am using Zenwifi AX, I have the same problem that Roon ARC is not able to connect to the Core. I have tried all the tips mentioned above, did I miss any :

  1. NAT Type change to Fullcone,
  2. Manual input the port forwarding with both external port and internal port put 55002, use protocol both and TCP

Something strange has happened. Must be the result of me changing various settings. Now when I try to assign Roon’s user defined IP address, I get a message saying “The host does not belong to any recognized LAN.”

Meanwhile, the error message now reads:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Any ideas?

Are you possibly able to restore from memory your previous settings on both devices?
I always take a screenshot of the router configuration before making any major changes.
It’s difficult to say anything helpful from a distance as we can’t know what you changed and how the settings for both devices now work together.
Did you backup your Asus router so that you can at least restore the Asus to previous settings?
If you have changed something in the DHCP settings on one or both routers, this may be the cause.

I have put my modem/router to bridge mode, which solved the issue for me.

His router can’t be set into bridge mode

I have the exact same error message on my 4G-AC68U router. Hoping for someone to “decode” it

Just joining in with other ASUS router users. Have the same issues as reported elsewhere.

Google your ISP and see if they use CGNAT. If they do - ROON ARC wont work.
I live in Australia - most ISP use CGNAT - but if you call them - they can take you OFF it. Or you can pay small amount to have non CGNAT IPV4.
I had all the same issues above and tried all solutions with Asus Router. ONLY removal of CGNAT fixed it.

Also ASUS RT-AC68U router here with the same error. Tried everything but no joy. :frowning:

My ISP is not using CGNAT.

My Asus is working fine with manual config (I’m running the asuswrt-merlin f/w on mine but the principal is the same for standard firmware)

I don’t think that Roon is able to auto configure the Asus using UPnP or NAT PMP

I’ve set my NAT to full cone as this is better (in most cases) than symmetric

Then I created a basic port forward – like this:

Now go to GRC | ShieldsUP! — Internet Vulnerability Profiling  

Enter 50000 (or whatever you chose in roon) in the box and click “user specified custom port probe”

It should say “failed” with a message that the port is closed - this actually means the port is available to the internet but the test wasn’t able to handshake/talk to roon.


If the test passes and says “stealth” your port forwarding isn’t working


NOTE you want this test to fail as it is testing your firewall is closed – a fail indicates that your port forward is working

Interestingly, I don’t have Port Forwarding enabled on my DSL-AC68U and ARC connected automatically like a charm. However, I did check that NAT and UPnP were enabled before upgrading.

If you have UPnP enabled is secure mode disabled?


UPnP is automatic port forwarding that is why. You use one or the other.

1 Like

I don’t think these issues are ASUS router specific. I had the same error message as mentioned above at first. Tried all the suggested changes which didn’t help. In my case the problem was the firewall of my NAS. I’m running my Core on my Synology and had to change the port forwarding in the Synology firewall as well as in my Asus router. Now it works fine. So it looks like these issues are related to multiple firewalls in your network or double NAT.

Hi @Philip_Gibson
were you able to solve the problem in the meantime?
If not, but everything else works fine with Roon Remote, you could try this:

  1. Do not change anything on the BT Hub and leave everything as it used to be.
  2. Disable router mode in the Asus router and set it to access point mode.

That might solve the problem as you won’t have double NAT anymore.
You would then have to make all the settings manually in the BT HUB. Can the Hub use UPnP?
I would try that first.

If that doesn’t work, disable UPnP again and enable port forwarding if the hub allows for it.
Then manually set up everything for port forwarding there.

Wish you that it works.
However, if not and you want to use ARC, you should consider purchasing another router that can be set to bridge mode.