B1159 Delay getting Tivo or Wiki information

On upgrading to 1159, I"m getting a 5 sec delay when I go into an Album page or Artists page before the Tivo or Wiki information is loaded. It displayes 3 greyed out blank placeholder lines and then the information fills in in about 5 seconds.

This is with a ROCK Core or a Windows Core to a Windows Client. There is no increase in speed in going back into an album that I just left.

I noticed this with the ROCK core. Verified that the Windows Core on the previous version worked fine. Updated the Windows Core and got the same slowness. Although, the delay seems to be a sec or two faster.

On Android phone app, I don’t seem to have the delay, but, you never land on a page with Info, you have to switch to it. So, the delay of physically clicking maybe giving the app time to populate(?)

Noticed this too. It’s surely the loading time for the content from Wikipedia. Takes approx. the same time as loading the same Wikipedia page in the browser. Though I have Tivo default and it makes no difference, but it must be loading Wiki anyway because it can switch instantly without loading time.

For me it’s about 2 seconds, 300 down internet and wired ROCK. Can imagine it might be annoying with slower internet downlink.

Local caching for Wikipedia may be difficult because Wiki pages tend to change all the time, so would have to refetch anyway

I have a 1 GB downlink. And the delay exists even if I turn off Wiki and just use the original Tivo data.

If it’s not the loading time, I don’t know why the time differs so much at all. My machine is reasonable but not crazy fast, 8th gen i7 from 2018 or so. If the difference is in fact the content loading, then I don’t know why your internet is so slow :slight_smile:

Anyway, loading the same page in the browser takes the same time for me, and Roon obviously must download at least part of the page, so that time can’t be zero and can’t probably be very much faster than the browser


Not slow at all.

I know what 1 Gbps is :slight_smile: Maybe you have latency. Fact is that some content must be loaded. Like I said, if the delay is the loading time, the only reason I can see for the different between 2 and 5 seconds is that it loads slower for you for whatever reason. If it’s not the loading time, I don’t understand why it takes less than 50% of time for me

How long does it take for you to load the same page in the browser?

pretty instantaneous.

I have an old i5 Windows NUC running the 1149 build and it is instantaneous against the 1159 server.

Yep, co-installed 1159 client on the same PC and 1159 has the delay, 1149 client does not.

Noticed that too. I think there must be more elegant way to sort this thing out.
Loading time is ok, but we need to avoid the flickering on the screen, as we see now.

I hope, Roon Team will look into this. Other than that - Wikipedia info is the great addition! Whole new world of information to dive in. :star_struck:

Hm OK then something seems off

But 1149 is not loading anything from Wikipedia, so it’s different

Same here: a couple of seconds and the three darker lines.

I don’t mind waiting for downloaded content, though in my case I’m sticking with Tivo rather than Wikipedia as the default, but the bars are an inelegant addition. I had assumed that it was related to running a custom theme, but posts here would suggest otherwise.

Others from the Roon team may chip in, but the loading performance is all down to server-side caching. With a relatively small number of users at the moment and, I’m guessing, occasional cache clearouts, it’s going to be luck of the draw as to whether you hit something that has been cached or you hit something which hasn’t and therefore needs to be retrieved and processed.

We’re well aware of the performance/latency requirements here.

2 Likes

I cleaned my cache and reset roon and it still happens on things that “should be cached”. I’ll delete the app and reinstall and see if it helps.

Edit: Didn’t help. But it goes away when going back to 1149.

Note: I apparently didn’t search for delay, and posted about black bars before loading… now that I’m thinking about i guess they’d be white on the light theme. Anyways… linked a vid, things I’ve accessed don’t seem to cache. …and I can’t even seem to quote my own post correctly, it’s blank bars not black bars. Lol :rofl:

I don’t think it’s a cache thing, if I turn off ALL editorial sources I still get blank bars and a delay. The bars disappear but why are they showing in the first place when sources are disabled?

Joel was talking about server-side caching, not your local one. (I don’t know if there is a local one, but as I explained further up, I doubt a local one would work very well because it would have to re-fetch every time the Wiki page changed, which is probably often for busier pages, so little would be won)

This one is a head scratcher though, agreed:

Same with me here: 3 black lines and a short wait. Not as much as 5 sec. but defintely worse than before …