Best practice for SMB mounts on Yosemite as it relates to Roon

When I used a NAS day-to-day in my setup, I found that I needed to be pretty careful not to let Finder mount or re-mount the NAS–it sometimes prefers AFP and messes things up. If in doubt, unmount it from finder, then type Command-K and re-mount it using the smb:// URL.

This is geeky and technical, but one way to be sure is to open up the “Terminal” app and run the “mount” command:

BAD (_afpovertcp)

$ mount
...
//;AUTH=No%20User%20Authent@drobo._afpovertcp._tcp.local/Public on /Volumes/Public (afpfs, nodev, nosuid, mounted by brian)
...

GOOD (smbfs)

$ mount
...
//GUEST:@drobo/Public on /Volumes/Public (smbfs, nodev, nosuid, noowners, mounted by brian)
...

This is an annoying problem–few apps do real-time filesystem watching, so for most situations no-one notices how buggy AFP is. Apple has basically abandoned it, which leaves us in a bad situation.

SMBv2 is a better choice nearly 100% of the time. Much quicker, more reliable, and better supported on all platforms. If my NAS supported disabling AFP, I’d have done it years ago. Unfortunately, it doesn’t have the settting :frowning:

As far as Roon is concerned, this is a temporary situation. We are doing two things to smooth over this rough point in the near future:

  • In the next build, Roon is going to actively refuse to watch AFP mounts and inform you that something’s wrong in the storage settings window–this is better than the horrifying albums-disappearing-one-by-one behavior, and will catch situations where the device was automatically re-mounted incorrectly by Finder and pro-actively disable the storage to prevent damage to your Roon library.
  • In the near term, we’re going to replace the Roon “watch a network folder” implementation with something that both uses the Apple infrastructure and forces SMB by mounting the NAS in a private location managed by Roon. Once this is done, there will be no remaining advantage to mounting the directory on the Mac side and then watch their NAS as a directory.
1 Like

@brian - Thank you this is very helpful. For now I have turned off AFP on my NAS, and am using the network folders for storage using the SMB//x.x.x.x/music syntax.

One other question, I have my Roon folder “disabled” as I assume Roon will watch the two network folders I have specified for my music, is this correct?

Thanks.

Barr

Yes, that’s correct.

Hi Brian
The reason why Finder mounts NAS’s as AFP rather than SMB is that if Finder sees any Network device with Time Machine functionality, it will mount that Drive using AFP when the user clicks on the Drive in the Finder sidebar

And as we all know, just about every NAS these days has a Time Machine feature built-in…hence why the mount tends to default to AFP

So, the user would need to ensure that the NAS isn’t mounted [by ensuring that ensuring no “up-arrow” is next to that NAS drive]…and then select Go…Connect to Server from the Menubar…input SMS://x.x.x.x/ and follows the onscreen instructions

For longer term use, connecting to the NAS at Log-in [using the above procedure] is the best way to go IMHO

1 Like

I’m weeks late to this discussion. I am using a MBP from spring 2008 running believe it or not 10.10.4. My constant frustration is keeping the SMB connection stable to my Synology 214play. All devices are using Ethernet connections. Turning off afp in the NAS leads to the device disappearing off the network as far as the Mac is concerned. So afp is left on. I can have a stable connection for a few hours and then Roon seizes up and hangs leading to me having to force quit. On restarting the application I am seeing the network share error 68. Eventually it reconnects though it takes me deleting the smb path in Roon and re-entering it again. This is a major pain using the Mac and Roon together.

@robtodd - review this post to ensure you have set Windows File Service to use SMB3 on your Synology NAS. It made a big different for me.

Setup of Synology NAS for Mac users

I setup Roon Core to use network path ( via SMB ) to my Synology NAS and it resolves any playback issues I had.

Thank you for this. I will give this a go and see what happens.

Have you left afp on as well being the default in the NAS control panel?
.

I actually turned off AFP. I am able to mount the NAS correctly on any Mac with AFP turned off. So beyond leveraging SMB for Room, it works fine for day to day Mac use.

Well this is frustrating. With afp turned off neither my MBP (2008) or iMac (only 2 years old) can see or connect to the NAS. Roon eventually displays the error 68 message. Going through the Finder to get smb connected is slow with my log in details asked for twice with at least 5 minutes inbetween the requests, before an error connecting to NAS message is displayed. There is apparently something gong on behind the scenes here but I’m damned if I know what. The annoying thing is it will connect sporadically and Roon is then scanning and importing like a bullet however this is the exception.

@robtodd have you tried using cifs instead of smb or afp?

Russ

@robtodd So something like this does not work for you?

CIFS is quite old - supported by Windows 95 etc. We really should be shooting for SMB 3.0 or later

:smile:

@rik Agreed but in the event of problems it is a good test as it tends to work with anything.

Russ

Tried it this afternoon using a MacBook Air which connected immediately wirelessly. Tried it with my MBP by ethernet and after 5 minutes it connected holding a stable connection for about three hours then it fell and won’t reconnect leading to the network share 68 error in Roon. Using my iMac by ethernet or wirelessly I had no success at all.

Yes for a while and then no. I’m hugely frustrated.

Daft question. You are referring to turning off afp in the NAS?

@robtodd - yes I have AFP off in NAS and Windows File Services on and in advanced options SMB3 enabled.

I mount the NAS using the Connect command. If I need an Automount I then in turn set it to mount on login via SMB.

Doesn’t work for me, I have to keep afp turned on. This may be as simple as what I have plugged, by ethernet, into what on my network. Funnily enough over the last day my MBP has started connecting readily using smb in Roon. It’s still flakey via the Finder but even that eventually connects. My iMac however will not connect.

Hi @robtodd – sorry you’re still having some issues here. I’m surprised you’re having issues running SMB3 on that NAS. Have you talked with Synology at all?

Also, can you let me know what versions of OSX you’re running, what kind of router (or other networking hardware) you’re using. Also, what version of Roon do you have installed?

Let me know the answers to the above, and we’ll figure out what’s going on. Thanks, and sorry for all the trouble!

Mike,
I have not talked with Synology.
OSX on my MBP is 10.10.4 (beta)
On the iMac it’s 10.10.3
My router is a Sagemcon F@ST2504n which has an Apple Airport Time Capsule hooked up to it by ethernet. My NAS and MBP are connected to the Airport Time Capsule. The iMac which is in another room is connected to a TP-LINK PA411KIT AV500 500 Mbps Powerline Adapter.
I am running the latest version of Roon version 1.0 (build 29) stable.
The situation as I reply is the iMac after about 5/10 minutes found the NAS through the Finder using smb.
The MBP through the finder is idling away after 15 minutes with no luck. Soon reports host as unreachable.
Yesterday after the same merry dance the MBP could not access the NAS through the Finder but Roon after 5 minutes or so with a host of error messages, 68, password incorrect and unreachable, suddenly picked everything up and was connected, the Finder then of course sidled up and connected instantly. I was able to duplicate this instant connection this morning from a cold start with the NAS and MBP before leaving for work. The iMac whilst slower yesterday eventually did see the NAS via Finder using smb. I ran Roon on the iMac and connected the MBP as a remote with zero problems. I then closed Roon down on the iMac and used the MBP solely. The connection was then rock solid. At the end of the evening the MBP closed down with no problems. The iMac however did not want to let the smb connection to the NAS go and I had to carry out a forced shutdown. I have smb automount for the NAS on the MBP. The machine is currently requesting my password and once entered cycling through and failing to connect. Soon is reporting incorrect user name and password incorrectly.
Frustrated is an understatement.
I will not be surprised if it all magically connects now.