Can’t connect ROON ARC with my BT Smarthub 3

No issues here whatsoever.

Make sure you go to advanced settings, enable UPnP and then go to port forwarding and select your IP address for your core/rock.

I have tried that using the IP address of my NAS which is where my ROON core is. Can you say what details you entered in to the port fields?

You need to do the same on your Synology. Login to the DSM and add port forwarding.

I saw a post about an hour ago saying the same thing and that’s how he fixed it.

Found it;

I hope that works/help.

Hi everyone,

Please note the solutions reported by other users for BT Smart Hub 2 and BT Smart Hub.

By all indications, British Telecom does implement carrier-grade NAT widely outside of their retail packages due to an IPv4 ISP shortage. Not all users are behind the carrier-grade NAT layer, however, as we’ve encountered during testing. Independent solutions will vary widely depending on additional routers used, but most BT Smart Hub 1-3 users can resolve issues by trying the following steps:

  1. Toggling UPnP in the BT Smart Hub (1-3) web administration. Enable it if it’s not enabled. If it’s already enabled, please disable and reenable it for due diligence.

  2. Setting a manual port forwarding rule. The BT Smarthub series didn’t play well with automatic configuration during testing in a modem/router combo standalone setup. Some users resolved this by setting a manual port forwarding configuration using the port listed in the ARC tab.

  3. If the above steps don’t resolve your issue, the tech support team will be standing by to assist you. We’ll break your issue into a dedicated topic thread, where more of the Roon team and savvy users can see your networking details up-front.

Thank you for your patience, and we’ll hopefully resolve your issues shortly.

1 Like


Please can you give example of how I set port forwarding rule?

I need External port start end, Internal port start end, protocol (UDP TCP TCP/UDP). Tried the disable / re enable but no effect.

1 Like

These are my settings.

Think I have fixed it.

created rule, found core device and selected entered the port number displayed Roon ARC tab, 5xxxx in all 4 fields and selected TCP / UDP protocol


1 Like

Arc uses TCP, so you can just use that. :+1:t2:

Glad to hear it has worked for you. I have tried exactly what you have done but no joy. 4 hours I’ve spent trying to get this working tonight. Beginning to feel like a beta tester for Roon.

Update: I have turned off the firewall in my QNAP and it is now working. I just need to work out how to let ROON through the firewall now.

I got ARC working with my BT homehub. The only thing that worked was to manually add a port forwarding rule. It would appear to UPNP does work with my router as there are ports successfully setup automatically by Acronis Update agent

this worked for me in Hampshire. Thanks for the post!

1 Like

Most welcome! :grinning::+1:t2:

Hi @Formula, hope you or someone else can help me out , thanks.

I have a Smart Hub 2 although I assume the same fix should apply, however I can’t get the port forwarding to work. I am using the Hub Manager on my PC but it’s not allowing me to put the letter x after the 5500 in the external and internal port boxes, it just reverts back to 5500 automatically. Have you any idea how to get the x accepted?
Probably wont make any difference, but is your screenshot of Hub Manager on your phone as opposed to a PC? I did attempt to try port forwarding using the MY BT app on my phone, but I couldn’t see where to do that, unless its done on a different app?

There should be no ‘x’. Unless you’re referring to ‘x’ as your number to which you have used.

But, if we go back and use the default values, so we can see that it works.

I would access the hub through your browser: (it might be different on older hubs)
The login details are on the back of the hub.

Login and go to port forwarding.

On your Roon app, check what the port number is. In our case the default value is ‘55000’. Example:

Once you’re in port forwarding. Find your core machine and select it from the list. Add the ‘55000’ to the port box as per my screen shot and press the add button and then click save to save the settings.

1 Like

Nice one @Formula. I was taking it too literally and thought it needed an x.
The weird thing is I just entered the ip address manually when I had the failed attempt at port forwarding earlier, but selecting the core machine from the list seemed to be what was required to make it work. No matter, it’s all good so thank you so much!

1 Like

Tried this on my smart hub 2 still no joy

Make sure you save the changes. The software is a bit ropey. Unless it says changes saved, it hasn’t saved them.

Next thing to try is turning off the firewall in the machine that has your core. That worked for me, but of course gives you another issue like how to get through the firewall. I am still trying to solve this one.

You might need to restart all devices including the hub.

I have same issue although I can get ARC to work if I turn off Antivirus. Not a permanent solution as zi need antivirus turned on.