Control4 Nucleus HDMI Binding


I am a Control4 dealer attempting to connect a Roon Nucleus for a customer for the first time and I need a little @support. My client uses the HDMI connection from the Nucleus connected to an AVR in his home theater to listen to music in the theater. When I loaded the Control4 drivers into his project, I don’t see a HDMI output that I can bind to the proper input on his AVR. My output choices from the Roon Zone driver are limited to Optical, Coax, Stereo, and Speaker.

I have not connected the driver to his system yet - I am preprogramming the controller in my shop before going to install it for the client. Does that matter?


Hi @andrewo311,

Welcome to the forum! Could you please share a few screenshots of what you’re seeing in the Roon module vs what you expect to see in other modules for the HDMI binding?

Thanks Noris!

My client has a single Roon Nucleus server. I installed the Roon Server and Roon Zone drivers and connected them together.

Here’s what I see for bindings under the Connections panel in Composer Pro for the Roon Zone:

There’s no way for me to connect the Roon’s HDMI port to the client’s AV Processor because there’s no binding for the HDMI port.

Here’s an example of another device that does have the HDMI port (this is a BluRay player):

We don’t have any ability in Composer to alter what ports are available to us… that’s something coded in the driver.

At the moment I can’t program Control4 to match the customer’s install, because I can’t connect (bind in C4 speak) the HDMI port from the Roon to the HDMI input on his processor.

The only possibly unusual thing about this is that the controller/drivers haven’t connected to the Roon yet - as I said in my initial post I’m setting this up on my workbench before installing on site, and I don’t have a Roon here to connect to. I’m pretty sure exposing a new connection is not something your driver could update on the fly, but I’m not a driver developer…

Thanks for any help you can give!

Hi @andrewo311,

Thanks for sharing those screenshots, it is much appreciated! I believe I understand this issue now and we have a development ticket regarding this behavior, I don’t believe it’s due to you working on the local workbench.

I see here that we have a beta driver available which might help, would you be interested in trying the beta driver out to see if it resolves this issue? I will follow up via private message with more details, thanks!

Thanks for the response @noris!

I got your PM and downloaded the new driver. Unfortunately the connections look exactly the same - there is still no HDMI output exposed in the connections panel for the Roon Zone driver.

I did double check that it’s the new beta driver I am testing and indeed, the version number is incremented by one.

I’d be happy to perform any further testing or answer any questions you have to help resolve this. FYI, I am scheduled to install with the client early next week.


Hi @andrewo311,

Sorry to hear that the beta version of our driver hasn’t resolved this issue for you.

As I mentioned, having the HDMI output is something that we’re working on, but we need to schedule some more dev resources towards this, and I’m afraid it won’t be possible to complete a new beta by next week when for you plan to visit your client.

Instead, I’m thinking of other possible solutions that we can come up with here. In a similar thread the user mentioned that they were able to set up a “Virtual Splitter” of sorts in Control4 for a Triad AV matrix. Would this by any chance be applicable for your setup?

I was attempting to get more information on the virtual splitter the other user implemented, but I haven’t heard back. I did some research into virtual splitters on Control4 and I found this one, can you please see if it applies in your case?

Or another thought, is there any way to do a if-then statement in Control4? As in if the client clicks on the Roon module button on a touchpanel, then to have the AVR switch to a separate HDMI source which is only connected to the Nucleus?

An If/Then programming to switch to the correct input on the processor would be a bad idea ™. Control4 doesn’t like it when you try to get around connections that way and it leaves the room in a potentially broken state.

I do have access to what’s, in effect, a “Swiss army knife” driver that can be inserted between two pieces of equipment. It exposes just about one of every kind of input and output and lets you convert from one to another. I’ll give that a shot next week when I’m installing the system.

Feedback, for what it’s worth, for your product owners/scrum masters… you might as well quit saying that you support Control4 if you don’t have a driver that exposes the actual physical interfaces on your box. 10 out of 10 C4 programmers would call this driver “broken.” :frowning:

Hi @andrewo311,

Thanks for the feedback here. I do agree that there are still improvements to be made to the Control4 module, and we have active development tickets regarding this issue.

Do let me know if the Swiss Army Knife driver works and if it does, I would appreciate some more details on how to install it (if it’s a public driver) in case there are others with similar issues while we work further on the module.

Sorry for the delay in getting back @noris. Yes, the driver worked, and my client is happily listening to and controlling their Roon via Control4.

The driver I used was made by a company called Houselogix and it was the “Universal Control4 Adapter Driver.” It was free, however Houselogix were acquired by another company and I don’t know where you can get the driver any more. I was lucky to have a copy on my computer already. If anyone else runs across this and has a copy of this driver, they should be good to go.

Unfortunately, I have no idea where someone who doesn’t already have it can get a copy. I don’t feel comfortable distributing other people’s work, even if the company doesn’t exist any more.

Good luck Rooners!

1 Like

Thank you for providing the additional info @andrewo311 and glad to hear that the Control4 module is working as expected with the Control4 Universal Adapter driver! If you have any further issues with Roon or the module, please do let us know!