DSD Upsampling In Roon DSP - Opinions?

I had exactly the same experience with my PS Audio Directstream DAC. The sound was more relax and had improved imaging but the loss of rhytm & pace combined with less precise bass definition led me to turn it off.
This is until yesterday when I found that turning off the option “Parallelize Sigma-Delta Modulator” brings back the rhytm & pace while keeping the benifits on imaging and instruments separation.
I read somewhere that this option is not supposed to impact the sound quality but it definitely did in my system … now DSD upsampling is back and that’s what gave me the best results so far.

I am experimenting with upsampling with my Directstream DAC. Trying both HQPlayer and Roon native. Could you possibly post your settings?



Good filter to start. @Mohammad_Anwar

Here are the settings,

DSD upsampling 2

FYI, my Directstream DAC is connected to the server via Bridge II. (The convolution filters were obtained from homeaudiofidelity.com)


Thank you! I will give these a try.



Thank you! I will try these out.



Can I ask you what you’re using for your Roon Core/Server? My loaded 2014 Mac Mini struggles with DSD 64 (not upsampled) and convolution filters. Without the convolution filters everything is fine but I noticed that you’re using convolution so I thought I’d ask. Thanks.

Why you dont have enabled Parallellize sigma-delta-modulator?

The server is a custom built PC using an ASUS mini-itx H110T motherboard with Roon ROCK OS. CPU is an Intel i5-7500, system SSD is M.2 NMVe Samsung EVO 970 (250GB) and it has 16 GB of RAM. The network card is a JCat Netcard Femto. In general, the processing speed is around 3 to 4x when Parallellization sigma-delta-modulator is “off” and around 7 to 8x when it is “on”.

It might be specific to server/DAC setup but please refer to previous post (#21) for explanations. A friend of mine who has a very similar setup came to the same conclusion that, for an unknown reason, disabling “Parallellize sigma-delta-modulator” brings back the lost rhytm & pace while keeping the benifits on imaging and instruments separation of DSD upsampling.

This is interesting. It’s not supposed to impact the SQ if you firmly believe “bits are bits” and nothing else from the source can affect the sound.

Though not an accepted practice here, I’ve read people experimented with processor affinity in other forums.

If you turn that option off you use one less CPU core, causing the power draw by CPU to be less. There would also be less context switches. There may also be a difference with the EMI RFI emitted by the CPU. How that could have made a difference in the sound from the speakers is anyone’s guess. Or people may just dismiss your finding for a variety of reasons.

If possible, I’d suggest you to try USB connection and see if it makes a difference. You can also try DSD128 this way.

1 Like

I agree with the “edge” being taken off on suboptimal media. I seem to go through phases on upsampling. Sometimes it sounds really good, and other times it doesn’t. It is so cool to be able to have the choice! Right now I am upsampling PCM to DSD128 via USB to Oppo UDP-205, but I have been mostly not upsampling with the occasional upsampling to PCM 24/192 via RAAT.

I usually only upsample to DSD when I am sitting in the sweet spot and really focusing.

1 Like

Thanks for getting back to me. Your success with your setup confused me a little because my Mac Mini has a 3.0GHz i7 inside, also with 16 GB of RAM and a 256GB SSD and it struggles to get going with DSD64 files. Then it occurred to me that you said you were upsampling to DSD, not playing actual DSD files so for the heck of it I decided to give that a try. My Mini sails through upsampling to 128DSD along with convolution just like your server does. There just must be something about real DSD files that are dogging it down compared to upsampled ones. No idea what that might be though.

Disable “Native DSD Processing”.

Tried it. About all I can say is my intel NUC got warmer :slight_smile:

That takes care of the problem but doesn’t that just convert my DSD files to PCM? I’d like to find a system that can play the DSD files (along with convolution filters) as DSD, not converted to PCM. I’m a little surprised that an i7 processor isn’t up to it.

Are you using the option DSD upsampling or the custom option? I use the custom option with upsampling of the PCMs to DSD64 and leave the DSD formats to the default option. This way I can leave the “Native DSD processing” enabled and play DSD files (up to DSD256). Roon automatically downsample the DSD file to DSD64 which is the max for my PS Audio Bridge II.
I noticed that selecting DSD upsampling instead of custom uses more resources and in this case it is just at the limit to play DSD128 (speed 1x) and DSD256 is not working.
Hope this helps.

No, disabling Native DSD Processing is not implying an output as PCM (which is dependent on other settings as well - you can still force the output to become DSD again). It’s about how the DSP works internally for DSD music.

I’m not. That option is not for your use case with convolution.

Try HQPlayer and youre not surprised that i99999 in 2028 will not handle all the filters :shushing_face:


Would you mind explaining why the native DSD processing is not for use with convolution ? I am using an Intel i5-7500 and the convolution filters seem to work fine with native DSD processing enabled. Thanks.