Fixed IP needed to run ARC?

Hi,

A static IP is not needed, but you need an IPv4 public IP address on your internet router.

2 Likes

post a screenshot of your asus port forward entry.

Thanks Chris, it is here:

What does it show in Roon?:

Morten, on your ASUS router port forwarding rule, I have configured as TCP/UDP (“Both” in the dropdown box), and can you confirm that the Internal IP Address you show listed is your Roon Core PC’s IP address? Everything else looks good.

Arc only uses TCP it’s a security risk to open more than you need.

I don’t think it is working

More screen shots

This is showing a stacked router (two routers in series) in your network. What is your ASUS router connected to, something from your ISP?

I think it is called a fiber modem, it receives the fiber cable from a junction box somewhere, from the fiber modem at normal network cable goes to my router, my ISP does not supply a router—that’s why I chose them :blush:

Thanks, what is the brand of the fiber modem and who is your ISP? For example, CenturyLink/Lumen provides a “fiber modem” but it is a full gateway and router. This type of device may be what you have from your ISP.

Yep that’s being blocked by your ISP

Whats the WAN IP address in the router?

It is WAN IP: **deleted

I think it said Nokia on the box it arrived in, but there are no IP address to log into it
I have attached a photo

100.x.x.x is a CGNAT IP address, looks like you are out of luck :frowning:

See if the ISP can turn off CGNAT or give you a static public IP address

1 Like

That looks like a fiber modem on the right connected to an ONT on the left. Who is your ISP? The reason is that if your ASUS router is the first Ethernet connection coming out of the modem using the white Ethernet cable, then your ISP may be using what is called CGNAT in their network, and a port forwarding option may be not be an option.

Thanks Chris.

Thanks Robert and Chris, I will contact them tomorrow and aske about the CGNAT, it is possible to get a static IP, but the charge for it…

And Robert you are right, the output of the right is going to the input of my Asus router, the ISP is called Bolignet, but the use gear from TDC (Biggest supplier in Denmark for internet)

some will disable cgnat so you get a dynamic ipv4 address so try that route first.

If you can’t change the CGNAT this solution might work for you.

https://community.roonlabs.com/t/tailscale-implementation-with-arc-to-circumnavigate-isp-cgnat/215356

If you can get them to switch you from CGNAT, you don’t need a Static IP4 address, a Dynamic IP address will work fine, but as well as the port forward rule, you will need to set up Dynamic DNS (DDNS), and Asus have this built into the router, it is easy to configure, reliable and free. You can of course use any DDNS service if you prefer. I have Asus RT-5300 running Merlin firmware, it works fine.

1 Like