[How To] RoonServer on QNAP NAS (Lubuntu VM)

Time for an update. Since the release of 1.2 I have migrated my setup from a Windows 10 VM to Lubuntu 15.10 also on a VM (1 CPU core, 2GB RAM allocated).

The install is much more lightweight and results in a much lower CPU overhead on the NAS. The result is that menus are now snappier in operation from my Remotes and interestingly the stutter that I had at the Tidal streams has now disappeared. I’m not sure if this is down to 1.2 or the efficiency and better I/O of Lubuntu on the NAS.

I did spend an afternoon trying to figure out how to get RoonServer running on LXC and Docker images on Ubuntu 14.04 via Container Station. Unfortunately I’m a novice with LXC/Docker and I ran into various NAT/Bridge networking or Ubuntu image problems that has so far prevented me from succeeding there.

I also haven’t tried SSHing directly into the QNAP to see if the installer would work natively on the QNAP OS. I’d be surprised if it did, but I’ll let someone braver than me test that out first.

Hi, trying to install Roon on my Qnap NAS. I have installed Windows 7 as the VM. however not certain how to connect the sound card /dac . Any help is appreciated. Thanks

Sorry, I have no experience of using the QNAP as a Core.

Looking at my network monitor and it seems like 1.2 handles Tidal streaming much more like local streaming, i.e. server output is a steady ~180KB/s for lossless. In previous versions, Roon would try to cache the whole track in one big lump at the start of the session, then each track at some point before the last one finished.

So we both wait for someone who is brave enough to try an installation directly on the QNAP’s core OS.

Maybe one of the roon folks has a QNAP too and tries it. I would certainly be a good beta tester. :wink:

Currently my Windows 10 with roon core 1.2 works great in the VM. But the direct Linux installation would be more elegant. Maybe I’ll try it on a rainy Sunday.

Go for it, there’s nothing to lose and plenty to gain.

I now have it installed on a no GUI Lubuntu minimal install VM, so performance is probably about as close as you can get to a native .qkpg install.

File transfer I/O is way way faster than the Windows VM.

Have a read of Just installed Roon 1.2 on a Synology DS716+ NAS

Let’s keep this topic on QNAP, there are others topics for Synology installs.

Seems like my first problem has arrived. Been away for a couple of days. Get back, fire up Roon on my Mac and I get a message to tell me that I am only allowed 1 authorisation to manage my library. I can see the Ubuntu server so I click the button that says Oops I meant to run a a remote, I am asked to choose a library so I click on the Ubuntu library and I get the same message about authorisations. Same thing happens if I run Roon from my Android phone. So I am guessing something is wrong with the server, but I have no idea how to fix it. Any suggestions please?


Thanks Andy,

I fixed it. I de authorised the server and it seemed to kick back into life after that, all working now thanks


I managed to get an Ubuntu 16.0 Roon Server up and running yesterday with good results. But, i am very eager to tro and install natively on the QNAP OS. Someone tried that yet? I have a TS-470 Pro with built in HDMI and audio so should be reasonably capable.

RoonServer natively on QNAP is working. And I will share the qpkg for an easy installation very soon.


This was released natively:

I have just migrated my VM over to @crieke’s package. Looks to be working beautifully. Library rescanning after moving from networked to local watched folder :thumbsup:

1 Like

I do have to report one downside which is specific to my use case. Running RoonServer in a VM meant I could run LMS in parallel to it - because the VM had a different IP address to the physical QNAP NAS.

I no longer have that available to me, so I’m seeing if I can get by with my Boom and SBR attached solely to mysqueezebox.com