How to use Roon ARC on another network

I set up ARC and it works fine on my network. I was at a restaurant tonight and tried to connect ARC. When I attempted to play a song I got some cryptic note that set ARC was unsuccessful. I got home again and I can play ARC on my network. Not sure why it would not work using another wifi connection; I thought that was the point.

Commercial WiFi isn’t guaranteed to behave like your own home WiFi there are often security constraints on what it will allow. If you could remember the message it may help understand what was happening.
Obviously this doesn’t apply to all commercial WiFi but it can happen.

1 Like

OK, never mind. I may not have understood the question.

However, you should have been able to connect to your core using cellular data if the WIFI did not work for some reason.

I assume that the purpose of roon arc is to play my music anywhere I am. But my first outing trying to do this did not work. I will try another location with a different wi fi setup. I did not know cellular should work but it did not kick in either. So right now I do not think it works like they say it should.

Yes, that’s the purpose of ARC. When you’re on your home wi-fi, you’re still on your network, not remote. Are you saying you turned off wi-fi and it didn’t work?

(Sorry for the edits, it’s late…)

Ignore this post.

Roon ARC works perfectly if it’s set up properly. The install of Roon 2.0 automatically configures some people’s routers, but not all. The rest of us have to do manual port forwarding to get Roon ARC to work away from home.

ARC will appear to work normally on your home network even when port forwarding is not set up because the port forwarding isn’t needed. So it does suggest that more needs to be done on your home setup to get beyond it.

Yes, you have to open the proper port on your router to allow your phone to talk to your core from the outside world.

It works when I do not need port forwarding. I will have to see how to do that on my Asus router. I try not to mess with the router settings too much. Does Roon ARC automatically configure Asus routers? Probably not since ARC does not work outside my network.

For Roon to configure ports automatically, you need to turn on UPnP in the router. That is however a bigger security concern than just opening a port, so you should try port forwarding first.

1 Like

I turned on port forward, UPNP and port triggering on my asus router. I get the error that roon arc was unable to access my roon core. Most of these router terms are Greek to me but I thought that was what was required for ARC.

Search on this site for “port forwarding asus router” and I think you will find several threads that might help. IDK.

Hi @Gary_Cardinale,

Please accept my apologies on behalf of the team that it’s taken some time to respond. Three quick questions to equip us to troubleshoot:

  • What is the make and model of your Asus router?
  • Do you have an additional modem in your setup from your internet service provider?
  • Also, who is your service provider?

Additionally, if you open regular Roon and navigate to Settings → ARC, are there any diagnostics displayed in the port forwarding information section?

The team is standing by to assist. There are additionally several Asus router solutions recently posted on Community, but it will help us to narrow things down once we know the model unit in your setup. In some cases, you might need to contact your internet service provider directly, as there are some carrier-grade settings that can block port forwarding.

I have an Asus RT-AX88u router with Merlin firmware. I have a Cable modem-model Arris SB8200. Spectrum is my service provider. I changed one setting and it says it is working. I need to try it out. But if you can confirm the correct settings that would be helpful, since I am on travel from the USA to Israel next week and would like to see if this works from my hotels. Thanks. Gary

1 Like

On your phone, turn off WIFI and make sure cellular is turned on. If it works, you’re good to go. If not, something is still not right. Make sure you turn WIFI back on so you don’t use cellular data at home.

1 Like

Hi @Gary_Cardinale,

In the vast majority of cases, if the Roon → Settings → ARC page says that port forwarding is successfully configured, then it will work without issue on a 5G network with overall reliable connection conditions.

If you received the green light but for some reason still can’t either 1) connect to your Core or 2) sync to your library, then please let us know. We may be able to assist while you’re still traveling if you’ve encountered an error.