HOWTO: Guide For Setting Up Roon Server and Roon Bridge on Arch Linux x86_64

Hi Evan, thanks for your instructions (it’s a pity that I found this only after installing Archlinux by myself) but I have some questions left. Right now I’m running Roon on a Macbook Pro and playing music via Raspberry IQaudIO. (very soon I will get the KiiAudio three but thats another cup of tea) The storage for the audio-files are a Synology (DS 1010+). That works very well, but i wish to separate the core and the remote. That’s why I bought a NUC (i7 with 16 GB of RAM and 500 GB M.2 SSD) The last two days I’ve spent installing Archlinux (I only have very, very limited skills in this case). At the moment RoonServer is running headless and I control the NUC with ssh-shell from my Macbook as root.
Now my questions: How to go further? I know, that I have to uninstall Roonserver from my Macintosh first. Probably I have to install after that the Roon Remote to control the Core (but I’ve got a iPhone too and maybe the new App will do the job) But how can I transfer the Database (about 5 GB) to the RoonServer-installation on Archlinux? And how can I point the fresh installed RoonServer to my Music Library on the Synology? With the Macbook I’m mounting the volume manually (because the NAS is not running 24/7). Is there a way to mount Volumes automatically with Archlinux when they are available? Sorry for my English and Greetings from Germany.

I’ve not looked into mounting devices as soon as they’re available so I can’t answer that part other than to say that if you do some research into setting up options in FSTAB there are parameters that will attemp mounting the NAS only if its present on the network.

Getting your database from your MAC onto the Arch machine can be done by setting up a NFS share on the Arch box or by using scp to copy them across. Syntax is along the lines of scp /pathtoroondata root@ipofarchbox:/pathtocopyto. I’d use scp. I’d also install mc on the arch box so you have a file manager to make your life easier when moving files etc.

You’d need to stop RoonServer on Arch before copying the files across: systemctl stop roonserver

Thanx for your assistance. I moved at the weekend successfully the RonnServer to my ArchLinux installation and after rescanning the library everything works fine so far. Nevertheless there are still some problems (I’ve got a bunch of duplicate albums (about 2000 out of 10.000) and some playback issues (Transport: Failed to load media) from time to time, but I think, thats not connected with the Linux-installation.

Did you delete the initial watched folder setup when you’d copied the database across? If not that’d be the cause of duplicates.

Thank you for helping - this problem is solved already. ((Duplicate tracks after moving roon database[fixed])

Configure the boot sequence
Now you have a decision to make…use a bootloader or bypass it. Bypassing makes for a faster boot and is great if your EUFI BIOS can boot an OS directly.

Evan, I have a Nuc5i7. One of its quarks is it likes to boot from the HDD even though the OS is on the SSD. With this being the case, should I configure with bootloader or not?

Thanks

1 Like

I’m not an expert on EUFI boot systems, but from the experience I’ve had with it my understanding is that whether or not you must use a bootloader is entirely dependent on the Nuc5i7 BIOS’s ability/inability to boot an OS directly without a bootloader.

When adding a bootloader all you’re doing is writing an entry in the UEFI BIOS pointing to the bootloader. Similarly, when booting without a bootloader you’re pointing the UEFI BIOS directly to the OS.

My entry level Celeron NUCs boot Arch directly.

Evan,

gummiboot is dead! has become systemd. What to do?

Also, do these get loaded into root@archiso ssh?

I haven’t had time to look into it at present, but it looks like a much simplified install of the bootloader - have a look at the guidance here:

https://wiki.archlinux.org/index.php/Systemd-boot#EFI_boot

[quote=“Canyoncruz, post:9, topic:9513”]
Also, do these get loaded into root@archiso ssh?
[/quote]Not sure what you’re asking here?

At the point I am ready to load the bootloader, i am in the above directory. Should I be?

type pwd and let me know what it returns

Hello Evan,

So i got the ting working! and the nuc5i7 quark where it only wantd to boot from the HHD is fixed. All is loaded into the SSD. A couple more questions:

  1. I was looking in the wikis for automatic login since this will be headless and will be a PITA to plug it in to a keyboard etc to type in the login. What do you suggest. I want to have the option to turn off and turn on like an appliance.
  2. For the HHD, how do I format it? I am using GParted. Also, I will be using an auto-loading CD ripper with BPoweramp in a windows system. what is the best way to ultimately get the info into a linux formatted HHD?

Thank you so much for this tutorial. Took days off implementing for a newbie like me.

CC

You don’t need to login, Roon will load automatically on startup.

Are you booting from a flash drive or the SSD?

Boot the machine, login and type lsblk and paste in here what it returns

sda Disk
sdb Disk
sdb1 Part/boot
sdb2 part /

Booting from SSD

Please paste it as returned - should look something like this:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 2.7T 0 disk /srv/btrfs1 sdb 8:16 0 2.7T 0 disk /srv/btrfs2 sdc 8:32 0 2.7T 0 disk /srv/btrfs3 sdd 8:48 0 2.7T 0 disk /srv/btrfs4 sde 8:64 0 2.7T 0 disk /srv/btrfs5 sdf 8:80 0 2.7T 0 disk └─sdf1 8:81 0 2.7T 0 part /mnt/parity1 sdg 8:96 0 2.7T 0 disk └─sdg1 8:97 0 2.7T 0 part /mnt/parity2 sdh 8:112 0 28G 0 disk ├─sdh1 8:113 0 512M 0 part └─sdh2 8:114 0 27.5G 0 part sdi 8:128 0 55.9G 0 disk └─sdi1 8:129 0 55.9G 0 part /srv/ssd sdj 8:144 1 14.7G 0 disk ├─sdj1 8:145 1 512M 0 part /boot └─sdj2 8:146 1 14.2G 0 part /

shit! how do I do that?

I only have two disks and ones unformated. it is pretty simple

there is a line above the hard drives that says:

Ok, seeing as you’re clearly booting from /dev/sdb I’ll assume the other drive /dev/sda is empty and unformatted. Please make sure this is the case otherwise you’re going to blow your install or lose data by doing what follows below:

first partition it using gdisk - if you’re running Linux without a GUI (as you should be if you’ve followed the install instructions) you cannot use gparted.

so basically from the terminal run:

gdisk /dev/sda

once in hit x for extra functionality and then z to zap the drive. Follow the prompts answering Y for all. gdisk will quit and return you to the command line. Hit the up arrow on the keyboard which will reinsert

gdisk /dev/sda in the terminal window and press enter to run gdisk again. This time press n for new partition table and follow the prompts - you can pretty much press enter and accept each default as presented. When it’s done you’ll be back at the gdisk main menu. Enter W to write changes and quit gdisk. When back at the command line type the following:

mkfs.ext4 /dev/sda1[/code]The drive will be formatted and you'll be returned to the command prompt.  Finally type the following to maximise available storage capacity to store data:[code]tune2fs -m 0 /dev/sda1

That’s it.

Done and thank you again. And to answer my first question: yes Roon boots up. I loaded Bluestacks into my other computer to let me run the remote app and sure enough, it sees Roon (my current ipad too old, need to get a new one).

Thank you once again Evan!

Hi, Ifirst installed Roonserver on my windows PC and everything worked fine. Then i installed Manjaro on a second partition, which works. Then i downloaded Roonserver from the AUR packetsource, which worked but then it doesn’t appear in Manjaro. Do i have to deinstall it from windows first or what do I do wrong?

What do you mean by “ it does not appear in manjaro “?

The Linux packages (server or bridge) are non-GUI. You need separate controller device (phone, tablet, windows device) to operate the server.