In spite of all my efforts, ARC error message persists

@Philip_Gibson, I moved your post to the Port Forwarding section. You have a double-NAT configuration issue (two routers in your network), so the options are either:

  • Enable UPnP on both routers


  • Create a port forwarding rule on the BT Home Hub that points to your ZenWiFi router, and then create an identical port forwarding rule on your ZenWiFi that points to your Roon Core.

You mention that you did not enable UPnP simultaneously on both your BT Home Hub and the ZenWiFi. Is there a reason why you did not try this?

I am a US user, so don’t know the specifics on the BT configuration options, but in the Home Hub screenshot you posted, what are the options under “Protocol”? Can this be set for TCP or TCP and UDP only?

Your ASUS port forwarding rule looks good, although I made mine from 55000-55002 as Roon sometimes uses 55000 and sometimes 55002.

Thanks for responding to my cry for help, @Robert_F.

So, on the BT Hub I’ve configured port forwarding to cover 55000–55002, as you suggested.

On the Asus I’ve configured port forwarding to cover UDP as well as TCP/IP. I couldn’t specify a range.

I still get the same error message.

I then disabled port forwarding on both routers and enabling UPnP on both. This resulted in the following error message:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Does this mean anything to you or others? And based on it, can you suggest anything else I should try?

There are still two subnets in use, a and the default ASUS subnet 192.168.50.yyy.

Is your BT port forwarding rule pointing to the address used by the ASUS router, and the ASUS port forwarding rule pointing to your Roon Core computer (either by name or IP address in the 192.168.50.yyy range)? Can you take a screenshot of the ASUS port forwarding configuration page?

So, the BT hub DHCP range is set to– The Asus router DHCP range is set to–

The way I’ve configured port forwarding is that on both devices it points to Roon, ie

If I understand you correctly, you’re saying that this is correct for the Asus, but that the BT hub should point to the Asus.

I’ve used a Mac app called LanScan to identify the IP address of the Asus. It is When I enter that into the BT hub port forwarding configuration, it returns the following message: Invalid entry!

So, I’m stuck again. Can you give me another pointer, please?

BTW, it’s late here now in London, so I’m about to head for bed and won’t be able to return to this issue until tomorrow, earliest.

Thanks for your help and patience, @Robert_F, in the meanwhile.

That is correct, but the Invalid Entry comment concerns me. I am based in the US so we can try again Sunday.

The BT Hub should point to the Asus, and the Asus, your core. For example… > BT hub < > > Asus < > > Roon core

Use port 55000 or whatever is shown in Settings > Roon ARC throughout.

Thanks, @Martin_Webster. So, there’s an ethernet connection between the BT Hub and the Asus ZenWiFi. Using LanScan, I can see the latter’s MAC address is f0-2f-74-90-53-f0. When I configure port forwarding on the BT Hub, the dropdown device menu gives me the option to choose udhcp-1-24-1-f0-2f-74-90-53-f0. In the light of what you said, I’ve chosen that option.

I’ve kept the ZenWifi port forwarding configuration as it was (see above).

Unfortunately, Roon ARC is still returning the same error message. So, have I misunderstood your instructions or is there something else I need to do?

Connect a laptop device directly to the Home Hub using Ethernet. Only the laptop and the Asus Zen Wi-Fi should be connected.

Using a web browser, open thee Home Hub admin interface, and do the following:

  1. Setup IP address reservation for the Asus Zen; I can’t find a guide, but I’m certain this is possible.
  2. Set port forwarding to the Asus Zen (see How do I set up port forwarding on my BT Hub? | BT Help, and use the Add New Game or Application option)

Next, remove the laptop from the network cable, restart the network, including the Asus.

Once the network is up, connect the laptop to the Asus using Ethernet or Wi-Fi, and open the Asus admin page. Setup UPnP or manually setup port forwarding to your Roon core. This should already be set up, but check that the IP of the core matches that in port forwarding. Likewise, make sure the same port is used throughout.

Thanks for the follow-up suggestions, @Martin_Webster. I was out all day yesterday and am about to go out again today.

I’ve just been having a poke around the BT Hub settings. This is what I found.

Before I go any further (I’m terrified of taking my whole network down and then struggling to get it back up and running!), please could you confirm that I should click the Yes under Always use this IP address and then apply that setting.

As to port forwarding to the Asus, I think that’s already done:

Or do you see a misconfiguration/misunderstanding here?

At the moment, I could do all that from my Mac Studio. It is on the same ethernet network as the BT Hub/Asus router. Do I really need to find a laptop and connect it via ethernet directly to the hub?

Sorry for so many questions but I’m really a bit out of my depth with this kind of network configuration. As I said, thank you!

Hi @Philip_Gibson,

I see you use a port trigger instead of port forwarding in the Asus router. Is this on purpose? I’m not sure if this causes the problem but I use the ‘normal’ port forwarding in my Asus router and that works fine combined with the forwarding in the modem of my ISP.

I use the modem/router of my ISP only to connect my Asus. Therefore I setup a DMZ in the ISP modem to route all the traffic to the Asus. It then bypasses the firewall/NAT in the ISP modem.

Be sure the MAC address and IP address ( match your Asus. Then click Yes for always use this address.

This shows the service/application definition. You will need to make sure a rule is setup for the Asus IP address.

This doesn’t seem right to me. Are you using the BT Hub Wi-Fi? Each router should use a different subnet, i.e., range of addresses where at least one of the first three numbers differ. Only the Asus should connect to the BT Hub.

Success!!! Thank you, @Joost_Hoogland and @Martin_Webster for all your help and advice.

What finally did the trick was to enable DMZ on my BT Hub 5. The BT Hub has two ethernet connections: one direct to my smart TV, the other to the Asus ZenWiFi AX, which has DMZ disabled.

So, one (hopefully) final question: does enabling DMZ on the BT Hub expose me to any security risks? If so, do you have a workaround I could implement instead of enabling DMZ on the BT Hub?

Thanks again.


Good to hear!
As far as I know a DMZ is always used for one IP-address (in your case it should be the Asus router) and the other port still passes through the firewall and is protected.

Fantastic news!

So long as the Asus is the only device connected to the DMZ port, and this has its firewall enabled, you’ll be fine. Ideally, move the smart TV to a port on the Asus, and turn off Wi-Fi on the Home Hub, i.e., nothing but the Asus can use the Home Hub. For all intents, this is working as a modem in pass-through mode (something I have to do with my Sky router, so I may use my preferred router.)

1 Like

Hi @Philip_Gibson,

I’m glad to hear you’re up and running with port forwarding. Thank you for your patience, and @Geoff_Coupe, @Martin_Webster, @Joost_Hoogland, thank you as usual for providing such timely assistance.

Configuring the Home Hub 5 in a “rigged Bridge mode” by placing a second router in the DMZ is a standard workaround for dodgy NAT layers or filtering imposed by ISP gateways. This workaround is perfectly safe unless you still have devices connecting to the internet via the Home Hub directly.

To reiterate, best practice here is to place anything reaching the internet behind the security layer of the Asus. Ideally, the only internet-accessible device connected to the Home Hub 5 would the Asus router. You’d have then eliminated the router portion of the Home Hub 5, permitting the Asus to function as a single-router setup with all your devices downstream. The quote below sums it up best:

I’d connect the Smart TV to the Asus, to avoid any risk.

Please let me know if you have any questions.


Thanks, @Connor. I’ve now plugged my smart TV into a switch behind the Asus instead of directly into the BT Home Hub. All seems to be working fine now so no further questions.

1 Like

A post was split to a new topic: ARC Port Forwarding Steps: BT Home Hub 5 with Asus ZenWiFi AX

Hi @Philip_Gibson,

I’m going to recategorize your solution above to our “resources” page, where it will gain greater visibility for new ARC users.

Thank you again for sharing the fruits of your troubleshooting with the community; it’s a graceful and generous signoff considering the experience was, I’m sure, less than pleasant. We appreciate your help.

This topic was automatically closed after 16 hours. New replies are no longer allowed.