Installing ROON on QNAP NAS

Is there a way to install Roon on a QNAP NAS and run it from there. The NAS is connected via ethernet cable to the dac. Thanks

Hi Sanjiv,
People have experimented with installing RoonServer on QNAP NAS. I’m on my phone atm so can’t easily link. If you search QNAP RoonServer you will find the thread.

1 Like

Thanks, I am to get to the stage of installing VM and Windows 7 on the NAS and Roon Server.
I can then see Roon on the Ipad, however my DAC is not seen connected to the NAS drive. Only way I can play the music is via AirPlay. AirPlay however truncates my high res music. Not certain how to fix that

Hi Sanjiv,
Later in that thread you’ll see reference to post 1.2 installation of Linux RoonServer. It’s no longer necessary to run a Windows virtual machine.

There are plans for NAS versions, but I’m not confident about the information. I’ll drop a flag for @mike to tell us more. At the moment I think it’s fair to say that various brave souls are experimenting. Some people may choose to join them (but it can be a frustrating journey). Others might prefer to wait until the trail is well signposted.

1 Like

Hi Sanjiv,

Running a full Roon with GUI user interface on a QNAP will be an issue as the QNAP VM does not support the display synchronisation that the Roon GUI requires. However, some on here have install RoonServer (with is Roon but without the GUI interface).

Once installed it is controlled by RoomRemote (which provides the GUI interface) on devices such as PC, Mac, iPad, iPad, Android. Check the Roon Knowledge Base for supported devices.

Have a read of [How To] RoonServer on QNAP NAS in which Mark describes installing both a Windows VM and direct Linux.

Hi Carl,

actually linked thread describes only running Roon in the VM on the Qnap.

I have tried to do manual install on my Qnap, however ended up with issue Roon not able to resolve anything from DNS (or /etc/hosts) - apparently some library incompatibility?

Please find the debug log here: Installation of RoonServer on a QNAP NAS?

I would love to have this resolved as running Roon Server (core) on my Qnap is my much much preffered setup :slight_smile:
Many thanks!

At the very least, unless you make some sym links to an alternative location for the Roon database, you won’t be able to install it natively on the QNAP. The DOM image that runs from an on chip flash isn’t big enough.

Then there are some slighly quirky things that QNAP does with root that Roon potentially will not like.

Thanks Mark, however this is not problem with location of Roon (it uses CWD when ROON_DATAROOT is not specified) .

Also my understanding is that this is issue of DNS resolving libraries (mono vs libc on qnap i guess) and thus not related to disk in any way.

Few more details though:
Roon is extracted in /share/MD0_DATA/Web/Roon/RoonServer folder, while i have created /share/MD0_DATA/Web/Roon/RoonServer/lib folder and copied few missing 64bit libraries from Ubuntu-14.04.4:

drwxr-xr-x 2 admin administ 4096 Apr 19 11:53 32/
lrwxrwxrwx 1 admin administ 20 Apr 19 09:50 ->*
-rwxr-xr-x 1 admin administ 149120 Apr 19 07:19*
lrwxrwxrwx 1 admin administ 20 Apr 19 11:49 ->*
lrwxrwxrwx 1 admin administ 18 Apr 19 09:50 ->
-rw-r–r-- 1 admin administ 982640 Apr 19 00:41
-rwxr-xr-x 1 admin administ 1840928 Apr 19 07:05*
lrwxrwxrwx 1 admin administ 12 Apr 19 07:06 ->*
-rw-r–r-- 1 admin administ 14664 Apr 18 23:53
lrwxrwxrwx 1 admin administ 10 Apr 18 23:56 ->
-rw-r–r-- 1 admin administ 14664 Apr 18 23:53
-rw-r–r-- 1 admin administ 90160 Apr 19 00:03
-rw-r–r-- 1 admin administ 1071552 Apr 18 23:53
lrwxrwxrwx 1 admin administ 9 Apr 18 23:56 ->
-rw-r–r-- 1 admin administ 1071552 Apr 18 23:53
-rwxr-xr-x 1 admin administ 141574 Apr 19 07:16*
lrwxrwxrwx 1 admin administ 18 Apr 19 09:51 ->*
-rw-r–r-- 1 admin administ 31792 Apr 18 23:53
lrwxrwxrwx 1 admin administ 10 Apr 18 23:56 ->
-rw-r–r-- 1 admin administ 31792 Apr 18 23:53

Also I’m using following env variables in each bash script used to start roon:
export LD_LIBRARY_PATH="/share/MD0_DATA/Web/Roon/RoonServer/lib"
export ROON_DATAROOT="/share/MD0_DATA/Web/Roon/RoonServer"

In scirpts LD_LIBRARY_PATH has been already defined i’m just adding my folder to the definition.

List of scripts i’ve modified with those env. variables:

Is there a package for Qnap ? or did anyone succeed installing it? (not via VM)

I was able to get it running in docker container however it did not work properly - I was getting DNS resolution errors which looked like some library incompatibility (not a nw issue).
Due to that issue I was not even able to connect to it with Roon client on iPad/MacBook :frowning:
I have qnap TS869PRO

The other way to do it would be through Linux Station.

Hello, I have just purchased a new Qnap server (TVS-882) that will be used only for music. It is connected via ethernet cable to a PS Audio Perfectwave DAC MK II with a Bridge II. I intend on moving my 5.6TB of music to the WD Red HDDs (4 X 6TB). The Roon database and Roon server will reside on the SSDs (I have two 500GB SSDs) as per setup instructions.

I am wondering if Roon requires cache acceleration? Instructions for setup (Chris Rieke) makes no mention of this. If so, how much space should be allocated?

Also, I do not want to migrate the Roon music library. I want to start from scratch and have Roon rebuild a new music library. Is there something I need to know before I start. It’s been some time since the initial setup and I don’t remember if there was a password for activating the software. Is there anything else I should be aware.

There is no requirement for cache acceleration. There is a recommendation to have the Roon database on a dedicated ssd.

I cannot give any recommendations regarding cache acceleration, because I have not tested it and it would not be very representative with my small library.

But I don’t think ssd acceleration for your music files will be a huge improvement. It could speed up the time between pressing the play button in Roon and the point when you actually hear the music in your speakers.

As I already said, I have not tried it but I am open for other thoughts on this. :slight_smile:

Prior to Chris’ dedicated QNAP app, I used cache acceleration in conjunction with a LInux VM to run Roon on my NAS.

When the app came out I reconfigured my SSD to host the Roon dB instead, and that’s faster than the config I used before.

Hi, just downloaded the app for Qnap.

Struggling to link the music files on the Qnap to Roon. I get message in storage

/share/Music (adding that as local folder, this is where my music files are on SSD)

Driving containing this media is not avilable or the folder has been deleted

Please help


Is the ssd installed internally or via usb?

Hi, fixed it by putting it on the SSD. Thanks

Next issue now is that it is not playing DSD files, seem to convert them into 24/88. Please advise


I have no DSD capable hardware in my setup. I have been told that DSD works on Synology, but I can’t say this for sure for QNAP, yet.
Can you post a screenshot of the Roon settings of your DSD capable hardware?

I have Roon Server on my QNAP, and it plays DSD files to a RaspberryPi RAAT endpoint just fine. (DAC S.M.S.L M8 connected via USB)
Check your settings in Audio Setup and post them here for further investigation?

Sorry Mikael,
I was inaccurate in my reply. DSD playback over network should work.
I am still unsure about DSD playback when a USB and DSD capable DAC is connected directly to the QNAP core. This needs to be supported by the QNAPs linux kernel.

Maybe you can test this by connecting your M8 directly to the USB port of your QNAP and check if DSD playback works?