Intel NUC 10th gen - what to expect?

No worries on the site link. I’d actually checked that out out and found that it’s still out of stock (which they don’t make clear until after you enter your payment info) but, given their reputation — yeah, probably pass on them in any case. :slight_smile:

And thanks for the thought about picking one up. I’ll play a bit of wait and see for now. Hopefully stocks are replenished and prices come down a bit.

Just received my 10th gen. Let’s see if this works. fingers crossed

Not working so far. After updating to the most recent bios - BIOS Update [FNCML357] and installing the ROCK image on to a USB. While holding down F10 the NUC sees the usb drive but when I hit enter the screen flashes then back to “pick which drive to use”.


I cannot change UEFI Boot to Legacy Boot - Both boxes are grayed out in the bios.

Might this help:

How is you 10th Gen install coming along? Which NUC did you purchase?

Thanks Rugby. This article did not help. I am still unable to switch from UEFI to Legacy. Both items tick boxes are grayed out in the Bios.

Still not working. In the BIOS the UEFI and Legacy tick boxes are grayed out. UEFI is currently ticked and we need it to be legacy in order to receive the Linux iso or whatever linux calls an iso.

Current running the Win 10 version and I guess everything is good.


Are they still grayed out when a bootable usb drive (eg rock) is connected?

Yes, both tick boxes are grayed out - with and without the USB physically in the NUC.

I have seen computer systems that will not let you change to legacy boot if the existing boot drive is UEFI. In order to get around this, you would need to delete all boot records from the drive using a third party tool. Unfortunately, there is no way to know whether this would allow you to move to Legacy boot until you try it, and this would render the existing drive unusable unless you reloaded with Windows.

Ryko, Any progress on you BIOS & UEFI issue with your NUC10?

I just ended up installing Windows and going that route.

Linux is perfectly capable of booting with UEFI enabled. I’d have tried clearing the CMOS. Then again, if the ROCK ISO doesn’t support UEFI not not a lot you can do about that.

So I ended up finding a NUC8i5BEH at a “normal” price & pulled the trigger. Got it all set up last night & have been enjoying it since.

Thanks for all of the advice! I’ll keep an eye on this thread in case I want to upgrade some day & assign my NUC8i5 to other duties. :wink:

1 Like

Has there been any updates on NUC on Gen 10? I just grabbed one today as I have to put my Mac mini into other service and didn’t want to stretch to a Nucleus right now. Anyway before unbox this Gen 10 NUC NUC10i7BEH has it worked for anyone with ROCK? Thanks

I have the NUC8I7BEH, 16gb ram, 250gb m.2 and 1 TB Sata drive. Works fine for me. But I don’t think it a 10th Gen. Doesn’t NUC8 signify 8th Gen. Not sure on that.

1 Like

Yes I screwed up on the part number :man_facepalming: I have the NUC10i7FNH

I am investigating a NUC including a prebuilt fanless case one.
Can someone please explain to me the story with Legacy BIOS? The ROON article indicates that later devices run new BIOS and this is not supported.

I run MAC’s here. Do I need a Windows PC or external monitor and keyboard to set the NUC up?

Evidently some of the NUCs have bios that only support UEFI. You need Legacy support for ROCK.

A previous poster says his NUC10 is only UEFI and consequently he was unable to load ROCK, though Intel’s NUC10 Bios Glossary says both Legacy and UEFI are supported.