IQAudio RC4 on PiAMP+ or PiDAC+ does not show up in Roon

Perhaps @Gordon_Garrity might have some suggestions here, since it’s his software. What version of the RPi are you using, and is it wired or wireless?

I’m running RC4 at the moment, and it seems to be fine. I did have problems with Roon not seeing my RPi2 when it was running RC2, but that issue went away with RC3 and RC4…

Hi,

Sorry I should have added more detail.

Running Windows 10 on PC with Roon 1.2 and both Pi’s that I use are wired to router. Both show on the network no problem and I can SSH into them both to confirm they are connected to my network.

I’ve messaged Gordon to see if he has any ideas.

Try changing the Pi’s hostname through raspy-config and reboot.

I had the same symptoms while trying out RC4 - this appeared to fix things. Probably coincidental, but it won’t hurt to try.

thanks but no joy with that either, the search continues lol

Two more things to check:

  1. Are you sure there’s no firewall blocking the RAAT discovery process? You may want to disable the Windows firewall altogether during testing.

  2. You may want to try installing Roon Bridge on your own, as opposed to using the RoonReady image from IQ Audio.

tried both those methods too, firewall disabled no difference and it won’t install bridge via the method shown on here as it’s an Arm6 Pi and it requires Arm7, so maybe both my Pi’s are too old to run Roon ?

Like I say Roon sees MoOde when I have it on my PI, but that is just via Airplay so no benefit there.

I won’t be upgrading my Pi’s as adding that to the cost of Roon and needing to buy a new NAS to run Roon ( to save running a gaming PC all hours that Roon currently resides on), along with Tidal sub makes Roon FAR too expensive for what it does, I can do ‘most’ of the same for next to nothing, I just wanted to try it and see IF it was all worth the expense, at the moment with it being unable to run on either of my Pi’s I’m just giving up on it.

Thanks anyway for your help.

Yup – that would be the case: you’ll need an ARM7 Pi (2 or 3) for running Roon Bridge or IQ Audio’s RoonReady implementation.

Of course you are free to make your own evaluation of the value Roon offers. Let’s just say that for me, for the level of enjoyment Roon brings to the table, there’s no comparison to Moode (or any other software around, free or paid).

I have the same issue post 154 upgrade. This may be co-incidence/may be not.

Prior to 154 my RP3/Amp+ endpoint was visible to Roon (and playing music in the kitchen zone). It hasn’t been since.

I noticed that I did not have an Ethernet connection from the RP3 to my 5 port switch; unplugged/re-inserted - no joy; new Ethernet cable - no joy; new RP3 bought - no joy; still no life on the Ethernet port.

I’ve run out of time today as my next step is to replace the RC4 image with a new download on a new card.

We may have the same issue.

Can you advise if your RPx has Ethernet connectivity as I’m obviously never going to see it as an endpoint until I can fathom out why I’m not getting a basic hw network.

Just re-read. Yes you do have network :thinking:

[Solved] Image must have been corrupted.

1 Like

I’m back where I started

I’ve lost the RP/Dig+ again. This time nothing has changed in my environment (for weeks).

I went to play some music in the ‘kitchen zone’ and …!!!

Ethernet ok this time.

A bit lost.

Any progress on identifying the problem?

I think my issue was due to the Pi’s I own being older arm 6 versions so they won’t Roon, I’ve cancelled the trial for Roon and Tidal as I’m not prepared to invest any more time and money in replacing my hardware.

Hifiberry have released an updated version (1.04) of their RoonReady image – you may want to try this:

http://downloads.hifiberry.com/images/roon.zip

Also – when you say ‘Ethernet ok this time’ – does your Pi have an IP-address and can you ping it?

I’ve been running Roon Bridge on two Pi’s for months now, without the smallest hiccup. For the last few weeks I’ve been using Hifiberry’s images – also without any problems.

Richard, have you tried rebooting the RPi? I have very occasionally needed to do that in order to get it seen again in Roon; it seems to fall off its perch every now and then… (this is for the IQaudIO Pi-Dac+ with RC4)

Hi Geoff, I’ve pulled the plug a few times to no avail. I’m now trying to find the username & password to login and reboot kindly. For clarity it’s a RP3/iQAudio DigAmp+ with RC4

The RC4 build has the standard username & password (pi / raspberry).

Geoff, thanks for info.
I did a port scan and the ssh service wasn’t running.
Reverted to writing RC4 image again
All working plus I can login via ssh.
I’ve no idea why it keeps ‘falling over’ however.
Thanks
Richard

Is it possible that your SD card or your power supply is on the margin, and causing corruption of the running software? Seems odd that ssh wasn’t available.

Stupid question time !!
Do I need to be running Roon Server on a separate PC to use a Pi IQ audio DAC+ combo or should Roon on a tablet just “see” the networked DAC+ ???
Many Thanks.