Is my ST the culprit?

I’ve had a problem for quite a while now. Roon just stops. Usually at the end of a song. And then nothing. I look at my library and everything after the first page or so does not load (no matter what remote am looking at and that goes for library from my NSA and streaming services). This goes for all endpoints in my system. The system stays this way for sometimes a few minutes, sometimes 30. Then all of a sudden it starts again.
What I have done: I replaced my Apple Airport with an Eero (no change) I took the Cisco switch out and replaced it with a Trendsnet unmanaged switch (no change). I’ve rebooted Roon and Sonic Orbiter (2.7 here). Updating the last few versions of Roon has made no change.
I have a Cisco cable modem with plenty of speed that is hardwired to the Eeros. I have had no data problems with any other device when this happens.
I’ve tried everything I know to try…does anyone have any ideas?

Have you tried ethernet from your router to your Roon core?

To bypass a switch? No…how would I get sound to an endpoint in that scenario?

Eliminate any and all WIFI from your internet/router to your Roon core. Music will travel back from your Roon core to router on the same ethernet. Then, to your endpoints by ethernet or WIFI.

I don’t use any wifi…its all ethernet…hard wired

1 Like

Sounds like maybe this should be looked at by @support.

Isn’t that a mesh network?

Can be…I only use one and its hardwired to my network. It provides wi-fi for everything else.

How is your Roon core device connected to your router?

Through a Trendsnet switch via ethernet Cat6

1 Like

Well, my first suggestion is that when this happens next, either see if you can ping the IP of the ST, or, use Fing to see if the ST is still on the network. Fing will also display IPs so you can see if something weird is going on during this time.

I have in the past and its all still connected and on the network just where it should be.

1 Like

I have the same issue happening here:

I am totally new to Roon but very deep down the days & days of troubleshooting. Where is your music stored? I am trying a test run today of loading a few albums on a USB drive and letting it play. So far, it ran 4 hours straight uninterrupted. I disable my NAS drive completely for this test.

You should open up a separate support ticket here:

Also reach out to SGC. SGC will do a remote Teamviewer session to your PC to see what’s happening with the ST

You can download teamviewer for PC here.

Or you can download teamviewer for MAC here

The User ID is a 9 or 10 digit number on the first screen of the teamviewer program. It’s labeled “Your ID” ; the password is underneath it. SGC will ask you for both so they can login

Here’s how to upgrade sonicTransporter from version 2.7 to 2.8. Read it carefully, it’s a multi step process. Supposedly fixes many issues with Roon

This procedure can take quite a while if your internet is slow. Do not reboot or power off your unit until the upgrade is complete.

Go to and click manage next to the sonicTransporter you want to upgrade. Then go to apps -> Software Manager . Click the Update button and wait for it to complete. Then reboot your sonicTransporter.

Once this is complete you are ready to start the upgrade to 2.8.

You need to manually enter the upgrade URL


So if your sonicTransporter IP address is then enter into your browser.

Once you enter this URL the upgrade will start. It can take quite a long time. Wait for it to finish!

Once it’s finished reboot and run the 2.8 upgrade again.


Again once you enter this URL the upgrade will start. It can take quite a long time. Wait for it to finish. Onec it’s done reboot again and you are done.

I did get there upgrade done…I missed a bunch of steps. I store music on a NAS. But my problem affects both stored music and streamed music. Roon won’t let me select or play anything.

I assume you have tried a few of the basics

  1. Disable all streaming services in Roon
  2. Disable all folder locations in Roon. Do you have any setup?
  3. remove SMB path in Sonictransporter. The path to your NAS should be setup in Roon
  4. Add a few albums to an Exfat formatted USB drive and mount the USB in Sonictransporter. Then in Roon under storage, Sonic transporter, drill down to the USB folder and point it to the new folder you have your music stored in on the USB Drive. Click “Add”
  5. Clear Roon server cache and restart Roon server in sonictransporter
  6. turn off all filters and upsampling.
  7. Connect everything via ethernet directly to your router, transporter, endpoint, NAS
  8. Unistall and reinstall Roon. This won’t delete your playlists and database
  9. Do a complete fresh install of Roon, this will delete everything:
    Accessing the Roon Database on your sonicTransporter

Long and short, try to get one thing running seamlessly first. Then add in other pieces after you have it stabilized for at least a full 24 hours straight

Also, have you tried to clean your library?

Thanks for all that but honestly…if that’s what I have to go thru to make it work…
I applaud your dedication. Some of those things I can’t do (my router only has one ethernet out)
and some of them are crazy to me…I have no idea how to uninstall Roon. I mean thats why I bought a Sonictransporter in the first place. And if I have to turn off streaming services to make Roon work…then whats the point?

I totally understand. The point to turn off services was to just experiment to see if the problem went away. How about just trying to clean the library first, have you done that? Has the Sonictansporter ever worked properly? How old is it? Is it the latest Gen3?

I think it’s a gen 2 and yes it worked fine for a long time. Thats the odd thing…I can’t think of anything that changed on my end that made it stop working 100% of the time. Thats why I’m guessing its software related. But I’m no expert.