Missing local files with special characters


I have just noticed that a significant number of Flac files that are stored on my ROCK local storage do not appear in the library, even after a re-scan.

It seems as though the problem occurs for tracks where special characters appear in the path to the file. So, all of my Björk albums are visible in the overall Albums view, but when I try to play a track from one, it says “playback was interrupted as a track failed to load”.

I can see the Flac file when browsing the ROCK storage from my Mac. I have tested a number of tracks/albums and it does seem to only affect those with special characters in the path.

If I Focus on albums on my internal storage, only those without special characters appear.

Is this a known issue or should I flag @support.

The path and filenames worked fine when my core was on my Mac, but it seems as though Rock struggles with special characters…

Thanks in advance,


Edit: OK, it seems I am not alone

1 Like

I had a similar problem. You will probably have to rename these files, no special characters, and put the correct names in tags.

Thanks for feedback.

Am I best renaming the files directly on my ROCK via SMB, or renaming them on my Mac, deleting them from the ROCK, then copying the renamed files over to ROCK via SMB?

There are a significant number of files that need renaming. Are there any risks in renaming a bunch of files on ROCK while Roon Server is running? Should I stop the Roon Server while the files are being renamed, (I will use a piece of software called “A Better Finder Rename” which automates the renaming of files/folders… a little worried that Roon might go a bit nuts if loads of files are renamed too quickly).

Thanks for any thoughts…

You can stop the roon server or disable the storage folder in which you are making changes to the settings. It doesn’t matter how you change these names. It is important that roon sees the newly corrected filenames. Do not correct the names while the roon is active.
You can correct them on the roock or delete the old ones and copy the new corrected. Then you have to delete this storage folder in the settings beforehand and add it again with the corrected files later.

Great, thanks again… that seems to have worked :+1:t2:

This is strange - reading this thread I thought to look at my Björk albums. On my ROCK server Björk’s name has the special character in both folder and file names, yet her albums play ok here…


Are you sure you are playing the album from the internal storage (I.e. ripped or purchased) rather than a version from Qobuz/Tidal/Upnp/NAS???

Having removed all diacritic characters from the file and folder names on my Rock internal storage, they have played just fine.

Definitely local, ripped from my own CDs, as you can see from the waveform display:-


I think the issue arises when copying such files from a Mac to ROCK, rather than Windows to ROCK. As I understand things, they treat Unicode characters slightly differently… when copying files from a Mac to ROCK, a “special character” becomes two characters long (or something).

There is a topic on this forum which mentions this.

One of her Albums (Gling-Glo), which I have ripped, has an extraordinary array of special characters in the filenames! If you have that album and it plays OK, then it is clearly a Mac specific issue…

1 Like

Ah ok - sorry. I didn’t pick up on the Mac thing - although we use iPhones and iPads, we’re strictly Windows on our laptops and the main PC. I don’t have a copy of Gling-Glo locally so I can’t check that, but it seems likely it would be ok here.


It was your screenshot which prompted me to recall the article/forum post about the fact that MacOS and Windows treat Unicode characters differently, so you helped solve the mystery! I will see if I can find the link, (it may be in the knowledgebase somewhere).

Edit: here is the link

1 Like

In my case it was sufficient to only change (remove/replace) the accented characters in the folder names. Accented filenames played well once the folder name did not have any accent. (ROCK on a NUC, ALAC files migrated from a HFS+ HDD to a ExFAT HDD)

Hmmm… interesting, I am not sure I tested that approach. I guess the end result is that Roon does it’s stuff and the track names are correctly found/shown when using the app, see below. If I get a chance I may test that approach, just to satisfy any OCD urges!

Same problem afflicts Nucleus, of course, but in my case, it won’t play files with accented characters, even if contained in folders without accented characters.

Changing the folder names results in Roon seeing all of these as new albums, no? And how would you go about finding every folder and file name with any affected special character (it’s not just umlauts)?

Roon doesn’t seem to have responded to this issue, which leaves me considering moving back to Mac for my Roon Core. Seems to me there should be a warning that neither ROCK nor Nucleus is functional for those migrating files from a MAC. I’d not have bought a Nucleus, had I known.

Hi Fred,

There is a great piece of software called “A Better Finder Rename” by Publicspace. It can do the replacement of diacritic characters in a single operation on folders (and subfolders). Highly recommended. It has a great many “music file” related functions that Roonies would love.

I used it to repair the file/folder names on my NUC running Rock.

In my limited testing, it seemed that as long as the folder names are free from diacritics then all is well, but this may not be universally true.

Roon itself will display the correct info and track names because, well, that is what it is supposed to do. I wouldn’t say it was a major issue to be honest.

I stopped the Roon server on my NUC, did the renaming, then restarted the Roon server and Roon didn’t skip a beat, correctly recognising the files and not duplicating anything.

As always, make sure you have working backups of DB and music files before you do anything!

Thanks for the suggestion, but doesn’t renaming folders result in Roon seeing all of the music in those folders as newly imported, deleting all the associated Roon metadata (original add date, playcounts, etc)?

I don’t think it matters. Roon focuses on files, tags not folders and their names. Can read information from parentheses and braces during import.
Do a test and change one or several folder names and check.

I did a test, and Roon sees the albums as newly added, no metadata preserved.

I suppose the severity of this issue depends on how much time you may have invested in tweaking tags etc… myself, I am perfectly happy with the meta data Roon uses by default and have no real interest in play counts. However, if you have invested time in curating your metadata, I can see this being hugely annoying.

I was just satisfied that it didn’t duplicate entries.

Maybe there is a workflow that might better preserve the metadata when renaming folders and files?