Native DSD support for Topping D30 DAC

Thanks @spockfish and @brian

I’ve sent an email to the manufacturer and ask them if the DAC does support Native DSD in Linux OS.

Are you able to run some commands on Linux? Then we know with a few minutes.

Unfortunately I don’t have Linux OS installed only Windows. Is there’s way to access the info via the manufacturer’s driver(XMOS driver) when connected to Windows?


Do you have a RoPieee running?

Nope, just ROCK to the DAC

ok then that’s a no go.

Is there any way you can detail what to do as a general case? I have a DAC capable of DSD direct into Windows drivers and I think a patch is possible.

Hi @spockfish

The manufacturer did reply about Topping D30 that can support native DSD with ASIO windows driver.

I can borrow a Raspberry Pi 2 and loaded with RoPieee next week.

Yeah, this was already what I predicted.

“it works with ASIO on Windows”.

Poke me when you have access and we’ll have a look. But considering the response I wouldn’t keep your hopes up.

1 Like

Thanks @spockfish and @brian

After updating ROCK to build 159, now my Topping D30 supports Native DSD streaming. Thank you!

Don’t seem to find anything regarding on this update?

1 Like

Hi @spockfish and @brian

I noticed that when I playback native DSD, the music seems to playback faster (pitch) compared to DoP. The strange thing is when I switch to DoP and play then switch back to native, the problem goes away. However everytime when I power on and playback the same thing happens (default setting ‘Native’)

Does anyone experience (who own Topping DACs) this sort of behaviour? I’ve a Spring DAC and I don’t exhibit this strange behaviour.

How did you manage ? With my Topping D30 connected it only sees ASIO4ALL or the XMOS USB driver and don’t have the option for Native on them. Should I uninstall asio4all maybe or even Xmos driver?

After uninstalling the asio4all and Xmos drivers now I can see D30 in System Output but it says WASAPI under it and still don’t have the native option for playback.

hi, my Topping D30 don’t play Native DSD on my QNAP … is there anyway to solve this? I use some others software that yes do very well. Can you help me please?

DOP is just a container though, it does not re-sample (or otherwise modify) the DSD content in any way. If you are hearing a difference it’s a bug in the playback system (doesn’t resolve your issue I know but what you described is extremely odd).

This is an issue with the OS QNAP uses. It needs to be patched for specific DACs or USB chipsets.

DSD64 it’s ok but DSD128 can’t play more than 30 seconds aprox, only happens on Roon :frowning:

some tip for that please?

You can approach QNAP and see if they want to do that. But they are most likely to decline until these patches are on very stable long term support Linux distros. The alternative is a Pi 3 (or 4) based Roon Bridge. Ropieee is my OS of choice and that will give you the full capability in native DSD.

1 Like