Oppo 105-Raspberry Pi hifiberry ,3B - 192k no optical sound

Using Pi, optical out to Oppo 105D Dac
Oppo decided to not support 192k optical.
But they do Support 192k USB.
How do I get the Raspberry Pi, 3B to send signal or the USB port? I plugged in a USB cable between Pi and Oppo, changed input to USB… and no sound.

I have installed the HiFiBerry, with image for. HifiBerry.

I am assuming that image turns off the USB IN preference for coax/ optical outputs.

Another question…
If you could choose


Which transport do you prefer for 192k/24.

Thanks in advance for any help! Or thoughts.

Hi Jeff,

After you had connected the Oppo via USB, did you go into Roon’s Setting --> Audio Devices and enable / name this new USB zone? Once that is done, you can select the zone to play music to.

If you’ve not already done so, do have a read of the [Roon Knowledge Base] (https://kb.roonlabs.com/) it the first port of call for this type of “how to questions” it’s good for new and experience users alike.

Have fun exploring.

1 Like
  1. I did and do look first into the knowledge base before asking. But thank you for the reminder.

  2. In the HiFiBerry settings there is no USB options. Maybe if the Raspberry PI didn’t have this board the option would be available, but it is not on mine.

Lets see if anyone else has a way to enable the USB Zone feature you describe.

Note, if my device has such an option in the first place, odds are good I would have found it. But that’s why I asked for help.


I would like to know how to use HDMI for multichannel with the Oppo.

1 Like

I have not tried hdmi output on the Pi3 to oppo 105.
It might just work and I can drop trying USB.

Otherwise I am not much help I am afraid.

My guess is that you have installed the Hifiberry Roon image without a Hifiberry HAT product (AMP, DAC+, DIGI+), none of which are intended for USB out put to a DAC. I think to use a Raspberry PI like a microRendu, you would need to install a Linux or equivalent OS, Roon Bridge, and set up drivers to your DAC. I am planning to try a DIGI+ Pro next month, and this info comes from my research. Good luck.

1 Like

Actually I do have the DIGI+ PRO, installed. I was hoping/assuming that it would be pushing

All the time… So I could just jump from one to the other.
Someone else posted "Set USB as a seperate source, but I am not finding that on the Roon Remote.

Anyway… I am probably going to give up…

I installed Raspbian Jessie Lite on my Pi3. I added a Hifiberry DIGI+ PRO hat for the toslink output. Both toslink and USB feed my dac.

The /boot/config.txt is configured to leave the Pi’s onboard audio enabled. Here are the last lines in file:

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# enable Hifiberry Digi+ (loads snd-bcm2835)

By setting “dtparam=audio=on”, the Pi’s onboard audio remains enabled. So there’s output from the DIGI+, USB, the Pi’s headphone jack (uselessly noisy, but ok for testing) and I presume HDMI. The following devices on my Pi show up in Roon’s “Audio” settings page:

I haven’t enabled the HDMI device “bcm2835 ALSA IEC958/HDMI” because I don’t have any HDMI device in my stereo to connect to. I expect if you change your config.txt to turn on the onboard audio, connect your Oppo via HDMI, and then enable the HDMI audio output in roon, it will work. If you can’t get it to work, I’ll connect the Pi to my Oppo+TV and figure out how to make it work.


  • Eric
1 Like

I am only getting a single hifiberry option in roon. Not 2 or 3 or 4.

Also how to edit or change anything. It seems the username and password are locked.

What images/os/boot are you using?

Taking your questions/comments in reverse:

Raspbian Jesse Lite. I followed the instructions in this post except that I didn’t disable the on-board audio devices as instructed in the section on “Configuring your HAT”.

For Raspian Jesse Lite, the username is “pi”, password is “raspberry”. If you installed a different OS, check for instructions on the site where you got it. Or google for it. The instruction post explains how to get a terminal window and shell so you can log into the Pi and edit the config file and do other things. I changed the password for example, and changed the hostname to “metalpi” since this Pi has a metal case.

The other sound output devices besides the hifiberry that you see in the screenshot (2 and 3 and 4) are there because of the “dtparam=audio=on” line in the /boot/config.txt file. Since you haven’t been able to shell in and edit your config file yet, the on-board audio device setting is probably turned off.

To be clear, these are not hifiberry options or devices: they are on-board and USB audio devices on the Pi itself. The screenshot shows the on-board analog audio out (headphones), on-board HDMI out, and an entry for every USB dac that you plug in. A dac should identify itself with some distinct name to the USB driver. That’s where the “Benchmark 1.0” in bold in the middle column comes from. It was retrieved by Roon from the audio subsystem on the Pi which got it from the USB handshake with the dac.

Once you get logged in, edit the config file and reboot. Make sure you plug your Oppo into a USB port before looking for it in Roon. You might have to plug it in before booting the Pi, I dunno. If the USB driver doesn’t see it, the OS can’t see it, then Roon won’t know that it’s there.


  • Eric
1 Like

+1 the recommendation above. You have to replace the HifiBerry image installed on your Raspberry Pi. Raspbian or DietPi are the best options.

Your Raspberry Pi will continue to work just fine afterwards with all of HifiBerry’s boards.


1 Like

Thanks guys… I figured something in the hifiberry image was the culprit… seems people hate the usb output from the pi anyway… Wonder if it’s worth the work since i am getting a new AVAHIFI DAC. Frank Vanalstine, brain child. So it can do the optical.


I have three Schiit DACs connected to Raspberry Pi’s via USB. The only issue I’ve had is with one slightly longer (+6ft) cable run, in which case I bought a cheap AmazonBasics powered USB hub to sit between the Pi and the DAC.


1 Like

What Pi builds are you using.
I was hoping I could enable/disable usb on my Pi but it seems the roon/Hifiberry digi+ build is locked down.

Hi, Jeff.

Not sure if you’re asking Adam or me. I’m using the Raspbian Jesse Lite image.


  • Eric
1 Like

I’m running DietPi on all of my RPi’s. Build 153, or whatever the latest is.

I’m not too sure you’d be able to disable the USB chip completely on an RPi, even with a distribution like DietPi: If I’m not mistaken it shares duty with the Ethernet interface.


1 Like

I have a similar set up: Raspberry Pi, Hifiberri Pro, and Oppo 105D.

I first connected my Raspberry Pi output to my Oppo 105D via USB cable but I felt that the sound was lacking. Since I also have a HiFiBerry Pro hat installed, I connected a Toslink (optical) cable from the HifiBerry to the Oppo and it sounds fantastic. I now use Roon to manage my music and the Oppo 105D as a DAC to play it.

Note: It took me a while to figure out that the optical input connection the Oppo 105D can only handle 96/24 (as opposed to the USB input that can do higher, perhaps 192/24). When I switched from USB to optical no sound came from the Oppo. The problem was that I had to make an adjustment in Roon to make the output resolution of the HifiBerry compatible with the limitation of the optical input of the Oppo. Here is what I did: in Roon went to Settings, then Audio, selected the HifiBerry “Device Setup”, then “Playback”, and set “Max Sample Rate” to “up to 96khz” and “Max Bits Per Sample” to “24”. If you don’t make those resolution changes in Roon, then HifiBerry could be sending a higher resolution than the Oppo can. I was sending 192/24 to the Oppo via optical and that is why I got no sound. I suspect that a similar process should work when using a digital coaxial cable between the Hifiberry and the Oppo.

1 Like