Pi-DAC+; WiFi image?

(Andrew Cox) #1

Very exciting to see the IQAudio Roon Ready products about to roll out. Development of a bootable image broadens the appeal of the boards beyond hobbyists and into the consumer device market.

There are also good reports from people using WiFi dongles with the boards configured on Linux distros.

I was wondering, @Gordon_Garrity, is it feasible to include a WiFi option in a bootable image ? Even by including a particular dongle ?

It would be great to have an inexpensive option for non-hobbyists to plug and play a Roon WiFi endpoint (just add speakers).

(Geoff Coupe) #2

Yes, please, I second the request. My official Raspberry Pi WiFi dongle awaits.

(Gordon Garrity) #3

We’ll do a WiFi version but no date yet.

3 Likes
#4

[quote=“andybob, post:1, topic:8306”]There are also good reports from people using WiFi dongles with the boards configured on Linux distros.[/quote]I’ve had great results using a Panda Wireless PAU06 300Mbps N USB Adapter to create a wireless server for my folks using a Microserver running Ubuntu Server hooked up via USB to a NuPrime IDA-8.

Great signal and trouble free networking … should work with any current Linux install.

(Rene Bouwmeester) #5

Adding WiFi would either necessitate opening up the image for login so it can be configured, or adding some webbased config option. I can imagine either will take a while, since the image is still in Release Candidate status.

BTW: a friend of mine has great succes with his PiDacs (one on NAA, one one PiCorePlayer). An Airport Express (starting from the N-generation) makes a fine wireless bridge to the Pi’s ethernet connector.

2 Likes
(Andrew Cox) #6

Raspberry Pi 3 looks to have inbuilt Wi-Fi.

What's the difference? RAAT vs AirPlay
#7

Would be fantastic to have this so I can have them all over the house!

(Rene Bouwmeester) #8

Received one of @Gordon_Garrity’s PiDAC+'s (with the very nice case) last week. Bought it mainly for toying around, but it sounds way too sweet for that: it has replaced the iDSD nano / HQP combo in my headphone setup. Well done, sir.

In installed it on a Pi 3, which is – to my surprise – behaving very nicely on WiFi. Just install it the usual way and you’ll be fine.

Added bonus for me is that I can easily adjust left/right volume settings with amixer, compensating for a slight lack of hearing in my right ear. Using headphones, this is rather important to me.

Just look at the adorable couple…

(Geoff Coupe) #9

Rene, I assume (for WiFi) that you have used Roon’s Roon Bridge software installed on a standard distro, rather than Gordon’s Roon Ready image (RC3 on his web site)?

(Rene Bouwmeester) #10

That’s affirmative, sir. :slight_smile:

And working quite well – as it should.

(Gordon Garrity) #11

With RC4 you should be able to use WiFi. Linux login now uses the standard Pi username / password combo.

(Joachim F) #12

Switched to RC4 and enabled WiFi today. Result?

Sweet sounding roon ready endpoint that plays 192/24 res files over WiFi. This will be my new bedside headphone source/amp. Squeezebox and Apogee miniDAC to be retired.

Can think of a few more places to put endpoints and active speakers now with WiFi as possibility. Thanks for sharing usrname and pw.

1 Like
(david weightman) #13

I have tried enabling wifi on both RC3v and RC4 following Renes instructions from elsewhere on this site ( editing the supplicant file )…seems to have taken but wont show up as a Roon endpoint when I disconnect the ethernet cable…as a Raspberry ultra newbie its hard to work out what is going on ( or not) from the Command line screen…any thoughts? Sounds great via the ethernet connection but thats not as convenient for an endpoint

(Joachim F) #14

My pi did not pickup a WiFi IP adress by just pulling the ethernet cable. Had to powercycle the pi for it to connect through WiFi to my network.

As soon as it was connected to my router Roon would also see it as an endpoint.

Can you see your pi connected to your router?

(david weightman) #15

Cant see the pi connected to the router…have powercycled the pi after disconnecting the ethernet cable…

the first shot shows the enquiry response, the second shows the pi screen after rebooting

(Joachim F) #16

New to the linux world myself so any advice from me should be considered as “good guess”.

From the screen shot it looks like your pi is not connecting with WiFi. What I did was to copy/paste the text from Rene’s instructions and only altered the network name and pw. That way I was sure to get it right. :slight_smile:

(david weightman) #17

I have done it a number of times now with the same result, even starting with a re-imaged SD card…I have a sneaky suspicion that the Linux instructions for confirming files etc are what have gone wrong…I must admit that Linux makes Windows look user friendly but a s child of six can master it, I will keep plugging away ( or enlist a six year old ) Thanks for the encouragement that the instructions work, just down to operator error!!

#18

I had a similar problem with a Hifiberry setup and these instructions solved it.

It may not be the same for iqaudio though.

(Joachim F) #19

That’s the instructions I followed. Second posting, section for enabling WiFi, copy/paste text. This did the trick on my pi.

Big thanks to @RBM for supplying instructions.