Port forwarding with fixed IP do not work

Roon Core Machine

Rock on NUC

Networking Gear & Setup Details

Asus RT-AC68U

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
    Asus RT-AC68U
  3. Do you have any additional network hardware, like additional routers or managed switches?
    No, only fiber modem
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

NA only relevant for ARC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Hi, I have procured a fixed IP address to get ARC to work, but I somehow cannot get it to work.

The error message I receive:

The port forwarding in Router:

I hope someone can help?
Br. Morten

Double check with your provider that you do have a public IP address and not a CGNAT address.

1 Like

Hi @Morten_Poulsen,

Thank you for your post and I’m sorry to hear that ARC autoconfiguration hasn’t worked in your case.

First off, please see @Rugby’s post above. You’ll want to verify that you have a dedicated external IP address for your account.

The diagnostic message visible in your screenshot is a miscellaneous UPnP error. Unfortunately, it doesn’t give us a precise indication of what’s wrong with your network. On a positive note, the port test is quite sensitive to multiple NAT scenarios that might suggest an ongoing issue with your provider, and there’s not necessarily an indication of that here, either.

A few things you can try in the meantime:

  1. Toggle UPnP on/off in your router settings
  2. Verify your Asus firmware is up to date in the router. Sometimes, outdated firmware will trigger the router to disable UPnP processes for security precautions.
  3. This third fix is less intuitive but has solved many related UPnP problems for users with your router. In the Asus router web GUI, navigate to the LAN IPTV settings, and make sure IGMP Proxy and multicast forwarding are enabled.

We’ll keep an eye out for your response.

1 Like

Thanks both of you, I have a fixed IP address, apparently an external that points on internal.

The IPTV was set correct:

I have also included this, the IP stated here always change, and is different form the one I have procured.

Hmm, I really don’t know how to progress, any insights?

Br Morten

In that case, please see the suggestion above about clarifying with your provider whether or not your account is still subject to carrier-grade network address translation (CG-NAT).

They claim I have a public address, they have provided it to me…
Br. Morten

They may have sent you the address but did you verify that it works?

You could go to your router settings and set up a manual port forwarding rule. In the rule, use the Roon Core IP and the Port 55002 that Roon shows you in the settings page under the ARC error. (And the rule will let you choose TCP or UDP. Use TCP)

Then go to a website like Port Scanner - Scan Network Ports - WhatIsMyIP.com® and enter the external IP that your ISP sent you, along with the port 55002. Then the result should be

Thanks, it is closed, I will contact my ISP

Br. Morten

Closed or blocked?

Closed probably indicates it can be reached though it responds that the port is closed. I wonder if your port forwarding rule works.

If it were blocked, it would point more to an ISP issue. Though could be the router as well - I had a cheap ISP router and it showed the port as blocked until I installed my own better router.

In any case, this probably is the area to focus on

It is working, need to do more settings in Router, thanks for your help… it is so nice in the Car :slight_smile:


Congrats, enjoy!


Great to hear @Morten_Poulsen, please don’t hesitate to reach out in a new thread if anything comes up.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.