Raspberry Pi3 NAA static issues

Hi guys…sorry for reviving an old thread but I was hoping to get some help. I have a Pi3 with Stretch running. I got the NAA to be recognized by HQP. However, all I get is static from the Digi+. HQP works just fine when I output music from the local usb port on my Lubuntu machine.

Any help would be greatly appreciated.

The Digi+ outputs s/pdif at up to 192kHz/24 bit but doesn’t convert the input in any way. What type of output is HQP sending the Pi ?

Thank you for the reply. I am just outputting PCM at 24/176. I’ve tried also 24/44.1 and 24/88.2 with the same results.

I’d suggest trying some other sampling rates and bit depths to see if anything changes.

Have you installed Roon Bridge on the Pi also ?

If Roon Bridge works OK then that could rule out an issue within the Pi or Digi+. Instructions here but you will have a head start with a working Stretch.

I have not tried Roon Bridge. However, i know the Digi+ works fine because I was just using it as a renderer on my network in conjunction with RuneAudio and Minimserver.

I just tried with changing bits, sample rates, buffers. Still same result. Could it be that the NAA is not compatible with Pi3?

I have verified with a friend that there seems to be issues with the Pi3. He got the same static output. Has anyone else got the NAA to work on a Pi3?

I thought we might make a new thread to try and resolve this. Let’s leave a flag for @jussi_laako to see if he can replicate the problem. I haven’t got a Pi3 myself, but I think Rene has (@RBM) and he may be able to assist also.

With the help of a friend I think we got this sorted out but I am not entirely sure what we did! I’ve been trying to get the NAA to work on a Pi3 started with Jessie Lite, then upgrading to Stretch before installing the NAA. My friend instead used the full installation of Jessie before upgrading to Stretch. The following lines were also added to the file config.txt:


We then installed libstdc++6 and NAA version 3.1.1-27

I am going to try and recreate what we did to make sure this works or we just somehow got lucky.

1 Like

I stopped using HQ Player altogether, but I believe I tested my Pi3 (no DAC) / plain Stretch / NAA a few weeks ago without issues (wired only).

But anyway – good you’ve got it running. You may want to make a backup image of the install you have now. :slight_smile:

Thank you for the reply. I have stopped using the NAA for now as I think the music sounds better from the USB of my PC. I am working with a developer who is making a new SPDIF output hat for the Pi3 that may sound better than the Digi+. Once I get this new prototype hat I will try the NAA again.

Curious…are you now using Roon to play music since you stopped using HQP?

Pi 2 Design, I guess? I’ll get one for sure once they’re finished. I pledged for their crazy tube HAT. :slight_smile:

As for as HQP goes: I used it primarily for my headphone setup, upsampling to DSD256 and feeding an iDSD nano. After a few months of listening, I have decided for now that – all things considered – DSD may not be for me (I like the texture and smoothness, but found it a little lifeless overall). Apart from that, I found the NAA setup a bit fidgety and I don’t especially like running a GUI on my server just for HQP.

All in all, it may be the hardware, it may be me – but for now I’m happy running Roon Bridge on all my endpoints and doing my headphone listening on a Pi & IQAudio DAC. That is – until that tube thing arrives. :slight_smile:

Thats right! I got a preview board a few weeks back and it is a lot better than the Digi+. Based on what I heard I am very optimistic.

The Pi2 Design tube thing looks awesome! I was thinking of picking one up just because it looks cool!

Ok, I know this is an old thread, but the topic is exactly what I have a question with…

I have a few rasp pi 3’s just sitting around and I because I have a difficult time leaving well enough alone I figured I’d try putting a image of NAA from the hqplayer site on an sd card and see how it works compared to my current dietpi naa setup.

The rasp pi 3 naa boots, hqplayer sees a mytek dac connection via naa and allows me to sent a steam to it. but when I play audio i hear the audio and a bunch of static. I’ve tried multiple rasp pi 3’s and they all react the same.

Is there something wrong with the naa image for rasp pi 3?

No, the RasPi3 hardware (and all models before RasPi4) have a problem. They have Ethernet interface on the same USB bus as the type-A USB connectors. Result is that at especially higher sampling rates there are lost USB packets (125 µs long) causing for example small pops in the sound, like dust particles on vinyl.

RasPi3 works fine with DAC hats/boards like HifiBerry though through it’s I2S interface and that’s why the image is provided.

Hmmm, I understand the design flaw in the earlier pi, I’m not talking a pop or click here and there, it’s a constant static noise.

it’s strange that I have no problems with dietpi 7 and naa on the same pi.

Outcome of lost USB packets depends on the particular DAC and whether you are running in PCM or DSD mode.

64-bit OS of NAA / HQPlayer OS images can also make some difference to the more commonly used 32-bit OS on RasPi hardware.

There are have been some attempts on work-around hacks to make the hardware behave. But generally I’m just dropping support for hardware older than RasPi4.

Raspberry hardware is so cheap that it is not really worth paying attention to support the old faulty hardware generations.

Would I be able to boot from an SD card that has your naa image on it if I use on of these mini pc’s?

Maybe, theoretically it should work. But sometimes people have got issues with those made by small unknown brands. Maybe due to BIOS bugs or similar. So YMMV.

1 Like