ROCK Dual Ethernet - Primary Port Not Exposed [RESOLVED]

I just tried this setting and it works fine. Thanks for the tip.

As always, let your own ears decide if there’s any sonic value in trying this approach. My personal philosophy in audio (and much else in life) is the K.I.S.S. approach - simplicity. So much of audio is a bandaid, adding devices to fix problems, created by bad design or technologies.

I suspect he is referring to the OS supplied comm functions.

A bit of an explanation as to why it doesn’t apply here would probably be helpful.

You are a good advocate for a sensible DIY approach that focuses on audio and not slight of hand. Continue to enlighten.


Hey, that’s great. How did you setup your network settings in your music server? Did you match the ip to the 2nd ethernet port of ROCK? How about other settings like gateway?

I was able to set my music server to static ip but Roon still cannot see it using Danny’s proposed setup.


I first set up the second ethernet port on the server on which Rock is located to the setting described (using the web page). I then changed the network settings on my RaspberryPi, which has the DietPi distribution, using also those same settings (fixed ip address…). Plugged an l’an cable from the second ethernet port of the server to the ethernet port of the Pi and it works. Only issue now is you can no longer access the player (RaspberryPi)…
Hope that helps,

Edit: both the IP on the server and player are fixed, but they need to be different

1 Like

I’ll get fix out for optional gateway and dns out this week.


just pushed out release of ROCK with this fix… check Settings -> About in roon to update.

Bummer I’m at work. Can’t wait to try this tonight. Thanks for the quick fix!

@danny Will it allow the non-Intel port (USB Ethernet Adapter) to connect to the router?

That already worked fine, but it is highly discouraged, as you will be limited to the performance of your USB2 ethernet adapter (which is quite bad).

That USB2 adapter would perform fine for a single stream to your audio renderer, but you wouldn’t want this degraded performance to talk to your NAS, or for updates, or anything else…

1 Like

ROCK rocks. This is awesomeness. :+1:

This is working flawless now. Great feature! The new update made it idiot proof. I can no longer bring the network down.

No worries. The $15 USB3 gigabit ethernet adapter worked great and I didn’t experience any speed issues when the adapter is connected to the router. Lots of bandwidth there.

I’m answering my question here. Yes, it does! Best of both worlds. The clean Intel ethernet port that is free of USB translation goes direct to the music renderer. Simplicity at its best. Wonderful!

1 Like

This is good information and a handy adapter :grinning:

Tried this, must’ve done something wrong. Now I can’t access Web UI. Any recommendations before I try reinstalling ROCK?

without screenshots, i don’t know what went wrong… next time, take screenshots of the web gui before hitting save :slight_smile:

before you reinstall, the console should give you the ip address of your ROCK to access the web ui. what does it say? (take a photo of it with your phone)

Try to remove the USB Ethernet adapter and reboot ROCK. You may be able to recover your network without re-installing ROCK again.

Will try this when I get home. Thanks!

I decided to give this “bridged” setup a try before selling my sMS-200. The last few days I’ve been testing NUC/ROCK connected direct to SOtM tx-USBultra (on loan) via USB. This combo, with tx-USBultra feeding my 2Qute using Curious USB short links has given me the most euphoric music delivery since I started my Home-Fi adventure. Before this I had the NUC/ROCK (Synology NAS before that) further upstream behind routers and switches, with sMS-200 feeding the 2Qute directly…and then for a short time with the tx-USBultra between the two. I want to try going back to the sMS-200 between the NUC/ROCK and tx-USBultra before making final decision. But, I suspect (based on what I’ve been hearing the last few days) that the sMS-200 will be going up for sale shortly and the tx-USBultra will find a permanent place between the NUC and 2Qute. The NUC/ROCK (soon powered by a sBooster LPS), tx-USBultra, 2Qute (both currently powered by W4S PS-1) separated by a few short inches of Curious cabling, sounds simply stunning. I did test for a few minutes connecting the NUC directly to the 2Qute, but it sounded so lifeless and dull after hearing the tx-USBultra. In
my opinion, the tx-USBultra is the difference maker.

This is no longer called a “bridged” setup. It’s more “subnet” setup…

So you will be using NUC as a Server and Bridge (music renderer) and getting rid of sMS-200? I went the other way around by replacing the sMS-200 with sMS-200Ultra plus a clock modded switch to avoid further load on the NUC. Interesting to see what the difference will be.

Yes, getting rid of the sMS-200 altogether is my current strategy. NUC direct to DAC via USB was blah. It sounded better with sMS-200 feeding tx-USBultra. But NUC to tx-USBultra to 2Qute is a revelation. My guess is that there will be nothing gained by having the sMS-200 in the mix. The added benefit of NUC to tx-USBultra is that I can feed 2Qute and Mojo using it’s two USB outputs and not have to deal with networking headaches associated with the “subnet” setup. I just select which DAC via Roon remote and play. The sMS-200 feeding the tx-USBultra would not allow me to select which DAC to drive. It always gave priority to the 2Qute in eunhasu web UI. The only thing I have to deal with now is the fan noise on the NUC :confused:

@danny Here’s screenshot. I can’t access using