ROCK on Hyper-V

Hi, is this possible? I would like to run Roon Core on a vm instead of installing on host server. I tried to create a vm and have the vm book off the .img (after I renamed it to .iso) file, but Hyper-V does not boot. I get an error asking me to insert bootable media. Any ideas? Thank you!

I gave it a light hearted attempt yesterday as well. I got some other weird error.

I also tried converting the USB drive to a vhdx file and booted the vm using this file. The error I get is “Missing Operating System”

This is strange because a NUC can boot off the USB drive.

Anyone have success?

@hammer did you create a bootable usb drive using Etcher?

How did you create the .vhdx file?

There’s an application which converts disks to vhdx called Disk2Vhd from MS.

I made some progress, to this point:


But I cannot manage to send keyboard input (eg, ‘1’) to the VM. (I tried putting ‘1’ into the clipboard of the Win10 Pro x64 desktop and pasting the clipboard in the VM screen, but no good.)

What I did so far:

  1. Downloaded the ROCK image as a .gz file.
  2. Used Etcher to flash a USB 3.0 thumb drive from the .gz file. Unplugged the thumb drive.
  3. On a different system (just paranoia, I guess) plugged in the thumb drive. I ignored a prompt to format the resulting disk. I now had 2 drives (as seen in Windows Explorer), H:\ and I:\ .
  4. Downloaded Disk2Vhd and ran that against H:\ and I:\ . I got a single .vhd file as output.
  5. Create a new (generation 1) VM, attached the just-created .vhd file to the VM.
  6. Booted the VM.
  7. The ROCK installation said it couldn’t find a harddisk to install to.
  8. Killed the VM. Added a harddisk (to IDE controller 1, via a brand-new .vhdx; the boot was happening from the .vhd created above and attached to controller 0).
  9. Booted the VM again. That is where I am now, unable to supply a keystroke.

Probably ROCK lacks the “integration services” that would allow a VM to capture input from a virtual keyboard. I know that in earlier Windows as VMs, Windows integration services had to be run before those VMs could get keystrokes.

I was also playing with this. I ran into the same issue with not being able to send keyboard input to the VM. My solution was to use VirtualBox to build a VM, then I converted the drive to .vhd. I can boot the VM, but cannot get RoonOS to recognize the virtual network card: image

@danny any chance of including the Hyper-V drivers that are supposed to be part of the Linux Kernel (i’m not a Linux guy, but saw this)

I know I could build a Linux or Windows VM and manage the full roon server there, but the lightweight and appliance like nature of ROCK is really appealing!

Anyone else get this to work?

I was hoping that the latest roonos build (227) with support for NUC 10 may have also resolved this, but I still cannot get it to recognize the network adapter.

What is the network adaptor and can it be found on any NUC from gen 5 onwards?

@phunge – the emulated network card on your Hyper-V is not supported by ROCK.

ROCK is possible as a free offering to Roon users because it acts as support reduction mechanism for our company. We do this by supporting a few well tested configurations, and not extending support to more configurations.

This is not a configuration we support, so unfortunately, unless you can tweak it to work, there is not much we can offer you here. Additionally, if you do get it working, be aware that we may break it or any other “MOCK” setup in the future because we can not test all configurations besides the officially sanctioned devices.

Understood, thanks for the explanation danny. Though I try to virtualize as much as I can, I can still run ROCK on bare metal.

I haven’t tried ROCK on a VM but I was successful in running roonserver virtualized. I am asking in this thread if there’s further interest in me producing instructions for it.

you need attach a physical usb keyboard, and usb pass through it to VM, then it will work.

FWIW I had roon running perfectly in eXSI, I installed OpenMediaVault as a VM, assigned plenty of HD for it and created a file system as per OMV. I then installed roon as per the roon linux install instructions, directly to OMV via SSH, sha bam, a fully functional roon server and storage for as much music as you could eat.

It ran flawlessly.