rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

Thank you. Is it possible to connect two USB DACs or is only one Roon Bridge supported per Pi 4?
Have a great weekend.

I never tried but I use thee Roon Bridge software and would expect that it is supported by Roon. Just try :smile:
There is no need for a licence to run Roon Bridge :smile:

I have two USB DACs connected to my RooExtend Pi that runs my Surface Dial. Both show up in Roon, no issues. The Pi is hardwired to the network, if you run wireless, your experience may vary…

2 Likes

@DrCWO one point I clarification I did not see in the set up instructions is whether I can remove the SD Card after the RooExtend and Surface Dial are up and running and functional? Does the Pi 4 need the SD card to run the programing or does the Pi 4 install the programming on internal RAM from the SD Card? Thank you

@Henry_Svendblad Thank you! I have hard wired and will try this as well.

The SD-Card has to stay in the Raspberry Pi.

A post was split to a new topic: FS: Surface Dial and Pi W setup

Hi DrCWO,

i am having trouble getting my RPI zero W to sign in to my network when loaded with the rooextend SD card. I have connected to the rooextend network and it gives me the landing page. It shows my home wifi network and allows me to put in my password, then when i click connect, it has the loading bar and resets, but then never actually attaches to the network.

Do you have any suggestions for what might be going wrong?

is it possible to attach a display to the RPI with rooextend loaded to manually connect to wifi?

5GHz rather than 2.4GHz wifi? Pi Zero W is 2.4 only.
Or a mesh router that does both?
If the latter, some can be forced into 2.4GHz only briefly while a new device joins.

1 Like

Please check if your WiFi encryption is set to WPA-PSK and 2.4GHz.
Others with trouble had a different router setting.
An other reason may be that you are too far away from your router.
A lot of people with mesh also had trouble.

You check this with a plain Raspbian. If it connects at the same Pi position rooExtend also should do.

Best DrCWO

Hi DrCWO
thanks for that advice! thats got my RPI onto the wifi and its now showing within the extension section of roon. Now i am afraid that i am stuck connecting the dial to the RPI via bluetooth

rooDial within roon is saying “status: Unpaired, KEF LS50w, not licensed (.)” no matter how long i wait with the pairing light flashing on the dial

are my speakers somehow interfering? what would you suggest now?

Thanks again for your support

Pairing is active for a limited time after boot in rooExtend.
Try to reboot your Pi and retry.

This advice is only valid if the Surface Dial was not paired with another device before. If you paired it for example with a PC you have to turn off this PC, take out batteries for 10s of the Dial.
After rebooting the Pi again press the button on the Dial to pair. The white light should flash for 10 to 30s and then get off. After this the pairing with the Pi should be completed.

The dial was previously connected to my surface computer, but i have taken the batteries out of reset it. I’ve tried what you have said and no joy.

should i start he dial pairing when the roodial extension appears in roon, so when i connect the RPI to power?

Is there anything else i could try?

Make sure that your surface is turned off (or disable bluetooth) until your Surface dial is paired with the Pi otherwise the dial will try to pair with the previous device.

The roodial extension should be visible in Roon/Settings/extension, once pairing is successful you will see R/L appear as you rotate the dial, it is then ready to configures your local settings (zones etc.).
Carl’s setup instructions work well and are a good reference if you’re having problems.

1 Like

Please follow the hints of @PixelPopper

Please describe what you see observing the flashing light of the Surface Dial after pressing the button.

Dr Oehlrich, currently Rpi’s are very difficult and/or expensive to purchase. The one that I can find at a very good price is the Pico W. Do you think this would work with rooDial?

rooDial works perfectly on a Pi Zero W if that’s what you mean?

1 Like

Thanks for the reply, but I do mean Pico W, not Zero W. Zero W is not available right now.

Sorry no, Pico W is not able to run linux which is the base for rooExtend.

1 Like

Given how hard it is to score an RPi in any version at the moment, is it possible to get RooExtend(Dial) installed on a Pentium-based NUC? People used basic Nuc as a RPi alternative. Let me know if this is possible.

I am sorry but it is not :cold_sweat:
I only can provide and support a SD-Card image for the Pi at the moment.

Soon there will be my rooExtend box in the „official“ HiFi market. It is a ready to run box so no SD-Card flashing and tinkering.
ATR Audiotrade will sell it worldwide soon but it will be more expensive as a DIY solution.
Best DrCWO