rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

I had problem re-pair my old Surface Dial (2WR-00006) after it went in to ‘sleeping’ mode, could not ‘wake’ it up from sleeping mode and the pairing LED did not turn on!!
Got it replaced by a 2WR-00007 and it works fine… so far!
Is some of the batches of the Dial flawed??
What’s difference with the model nr. 2WR-0000x?

I have no idea, but you are number five getting problems :japanese_goblin:

Common behaviour if Dial is broken.

1 Like

I must be doing something wrong, but I can’t quite the image to work on the PI. I’m using a mac, I’ve formatted a 32GB Sandisk card using disk util, but also using cli. I’ve burnt the image with balenaEtcher and also using dd. I am using a Pi4b with 4GB. When I insert the card and power up, I get a solid red light for power, and a flickering green light. After a while the red light goes out and the green light blinks but I don’t see the rooExtend wifi.

I’m using the v1.2 image. If I put the card back in the mac, is there a log file I could view to help troubleshoot. I also have something in the back of my mind that the Mac can do some weird things formatting USB disks

Any thoughts?

I actually experienced this as well. Saw the WiFi on 1.1, but did not on 1.2.

Currently connected to Ethernet so problem solved, if you are impatient, connect via Ethernet and see if you can flip to WiFi thorough the GUI.

Nick,
I also run a Pi4 here.
The behaviour you described seems to be all right. The red light went off after boot and the green light starts blinking. After that you have to wait for quite a while and then the rooExtend WiFi should show up. Please give it five to six minutes and check again.
I wonder if it has something to do with the country code. I put the settings of rooExtend in the technical thread. Please let us discuss this topic there…
rooDial technical integration discusions - Audio Products - Roon Labs Community

It’s interesting that there is an option inside the rooDial plugin that helps you to choose for which zone is being used with Roon, but which is the story behind it?

For those who don’t play multi-zone simultaneously, this is only creating hassle and the need of changing the settings inside the plugin instead of focusing on music. As you can see, I have few audio devices on which I am playing my music:

Today I realised that I was staring at Roon on Mac, trying to understand why the plugin reacts when I touch the Surface Dial and the volume doesn’t change when I set the music to play on other zone/device. What I am expecting is to see an option which allows me to:

  • set the master volume control for the device which is currently indicated as playing in Roon,


or

  • leave the possibility to control your desired zone, in the way that the feature is implemented now.

The way it works now is good for those who only want the remote, let’s say, in the living room… but it annoys me that when I move my music from livingroom to office, I need to manually change the dial from livingroom to office audio system.

Perhaps there is something to improve here? :slight_smile:

DrCWO, I have had no problems with the setup until the last couple of days. Recently the extension has been appearing/disappearing from Roon (and, as expected the dial stops working when the extension disappears). To be clear, the extension always shows up as ‘authorized’, but randomly disappears from ‘discovered’. I’m using 1.1.0. Your help is appreciated.

Here is a nice find for those who were annoyed by the fact that the Microsoft Surface Dial was not staying fixed on the desk while you were changing the volume. I was.

Buy rubber pads used for chairs and stick them to the bottom of the Surface Dial remote as I’ve did below:


These pads will raise a bit the profile of the remote and they give a good grip for those with larger hands. I wonder why Microsoft has not included a rubber pad in the box with the product, in order to fix this grip while the MS Surface Dial sits on a desk or a table… :roll_eyes:

On my Dial there is some really sticky rubber under the bottom …
Looking at your picture I think I see a small plastic tab sticking out from the side. Could you try to gently pull this? As far as I remember this will expose the sticky part under it.
Sorry if I should be mistaken …

1 Like

You should not remove the plastic label located under the Surface Dial, as it contains information regarding the product itself.

The most non-destructive option to which I can think about is sticking these adhesive tabs like I’ve did. For me it works, because I am controling my music from different places and the surfaces are different.

Ideally would be if someone could build a ruber sock which would cover the base of the Surface Dial, so that the product would not move so easily on a table.

The reason why the base of this product is pure plastic and has a non-adhesive surface is because it needs to move freely with ease on a Microsoft product with touch screen.

Any other ideas?

I think that removing the plastic is at least an option: See point 8.

Yes, listen to Elmar…
Just remove the tab, and a sticky rubbery surface will magically appear!

4 Likes

I have 2 knobs now…both have grippy rubber (yes remove the sheet from under the MSD) the one on the left is a balanced line volume controller for my active speakers.

1 Like

Guys, you were correct. I didn’t read those damn instructions… :smile:

My audiophile life has just improved since today after I bought this magic jog dial!

7 Likes

Andeas,
sorry to say but this exactly reflects the philosopy of the roon developers!
Select a zone and then action is for the selected zone. All roon volume extensions work like that and there is nothing I can do about it…
My hint, just buy one Dial for each playback device :wink:

1 Like

Microsoft suggest that if the dial “slides” wipe base with a damp cloth to restore “grip.”
I tried that & it works just fine.

Amazing. I did exactly the same a few hours ago after finding exactly the same problem after initial installation. Great minds …

I was reluctant to peel off the bottom label as it looked as if the Dial would then be too strongly stuck to wherever I first put it. I don’t want to have it in any permanent location at present.

don’t worry, it’s like a gecko’s foot, sticks and is easy to remove.

the other trick is to place it down on a cleaned and dust free surface, ideally glass or metal or painted gloss works best but then leave it there…if you dont move it much it should stay put pretty well but a wipe with a damp microfibre cloth works wonders…steer clear of anything like a tissue though.

Edit - Actually I just put mine down on a metal (magnetic) surface and it was sucked down magnetically. very handy as its on the edge of my desk now and wont get knocked off easily being magnetically secured.