Roon 1.5 Sound Quality

Right, I have just spent hours and hours playing and trying to figure out what could be making the difference.

I could have hit on it in my case, and I mean COULD, as I don’t know for sure.

Remember I upscale to DSD256 in Roon and run Roon Rock… I found the SDM Gain Adjustment was set to 0db by default. When I start introducing a negative db number things get much much better.

Now, this made me suspicious of what the default setting was in 1.4. I’ve done some searches but can only find reference for 1.3 (back then this was called DSD Gain Adjustment) and the default setting then was apparently -3db, from what I could find from googling.

Could it be that the default setting in 1.4 was -3db as well? I’ve never touched this setting before. If so, it means I’ve run -3db all the way up to when I updated to Roon 1.5 and then the setting has become 0db.

This is what I think has happened.

Now, I know this only applies to people using the upsample to DSD, but it’s seems like this might be the culprit for my setup.

I will have to listen more tomorrow as it is late now, but everything is sounding much more like it was. Less digital, less harsh (and note that I did say I thought everything was louder on 1.5 so this would explain that too).

In this particular instance Roon could be right that nothing changed but overlooked a setting that was changing in this release!

Can someone from Roon check this out and give me a prize if I’ve troubleshot this properly? (only joking, but I have done a lot of software testing before and have good ears).

I’m interested if anyone else who is complaining and is upscaling to DSD could try looking and seeing if the value is set at 0db and can try at -3db and see if things suddenly come right.

Of course, if my ears tell me different tomorrow I will be back to say so!

I just checked iTunes no processing no SRC vs Roon 1.5 with no processing no SRC (fixed volume of course - so no volume control on either application). Mac Mini i5 2.8GHz.

Result was that 16 bit 44.1 KHz sounded identical on both setups.

Conclusion: with no processing and no volume control Roon 1.5 is the same as Apple audio on iTunes (both are bit perfect apps or supposed to be)

So the problem reported must be either something due to processing or volume control in Roon 1.5, windows or other software or the way MQA unfolding (only recently available in 1.5) definitely adds brightness.

Anecdotal validation: I tried upsampling - several levels of upsampling, but found the result a bit harsh and returned to no upsampling. Maybe there would be a difference if I played with that gain adjustment, but haven’t been aware of that until now.

@Rhythmatist Yes, digital clipping of sorts. My point is I’ve never touched that setting. So, I’m suspicious that upgrading to 1.5 has taken that setting from -3db to 0db and hence the sound changing for the worse.

I know it only applies to this specific case of upscaling to DSD but I believe this has likely been a probable change of default value Roon did not intend? That’s my guess anyway! It’s easy for developers to miss something like this.

I knew something had changed for the worse from 1.4 to 1.5, it was clear to me, now I think I have put my finger on the problem. It’s hardly an obvious one to spot or one to expect either, which is usually the case with the development and testing of things like this.

Brian,

You are correct. I think MQA files are in general brighter than regular files but this is probably a mastering or filtering difference and not a fault in Roon.

I have concluded that Roon 1.5 is identical to iTunes for regular redbook files with all processing and volume control switched off in both apps (bit perfect in theory)

Sorry if I mislead anyone. I realize conjecture is better avoided until things have been rigorously tested - my bad!

The default SDM gain adjustment was changed from -3dB to 0dB in Build 216 (April 2017).

It was changed because:

  • The main purpose of that setting was to manage modulator instability, which was made pretty much impossible as of that build due to improvements in the S-D modulators
  • Setting that setting to anything other than 0dB causes a level offset between DSD content played bit-perfect and upsampled/processed DSD content. So if you set your output to DSD256, then real DSD256 files will be “louder” than upsampled Redbook files. This is inappropriate, and breaks volume leveling
  • We already have a place to add signal headroom before processing–the Headroom Adjustment section. And that works without producing any inconsistencies from track to track.

It’s possible if for some reason you re-set-up your audio device from scratch recently that it got the new default. But the 1.4->1.5 migration wouldn’t have touched this setting.

If my head were on straight, we probably wouldn’t have had that setting at all, and would use the main headroom setting for all headroom management. The idea of a DSD-specific headroom adjustment isn’t great product design.

2 Likes

Thanks for clarifying. I concur that in my case I did not get MORE treble ! More subtlety in treble can be confused with more level as both would equally catch ear attention. Then this can be “polluted” by other causes, see the precision balance analogy.

I am very carefully adjusting the tonal balance using subtle corrections in Roon DSP and cross-checking with/without - I do not hear insertion losses by the way which is a fantastic achievement per se, it enables really this painless fine tuning which is so painstaking to do in the analog domain (do not misread me, it takes place AFTER all the best ¨physical work* has been done, not before !).

If it might help, using my Rosita Neutron Star USB converter, I hear differences of musicality between USB links of 120 cm, 90 cm and 30 cm, which is better and that I am using now with an Apple Mac Book Air and USB2, used on battery… The USB protocol is quite simple and is not as robust to various noise sources as often assumed. For digital jitter reduction, USB path length reduction is a simple way that also reduces noise. I know there are buffers and other tricks to help accommodate with input jitter, but limiting these issues in the first place remains preferable, all things being equal.

I not sure I hear a difference in Roon 1.5. in my HiFi set.

I do know there is a dramatic difference in sound quality on my mobile phone/Audioquest Dragonfly Red/B&W P7 between Tidal via Roon Tidal via Tidal app. Tidal via Roon sounds harsh and lacks dynamic.

yep, there was something different in the sound. better. clearer, more transparent. but this is only slight difference. i’m happier for it.

OK, after confirming today with fresh ears, the problem with sound quality was definitely down to the fact that the SDM Gain Adjustment had changed to 0db. I’ve never touched the setting, putting it to -3db (apparently what it was in previous versions) and everything is sounding great again! :slight_smile:

It will be interesting to hear if others who use roon to upscale to DSD go looking and find the same thing.

Interesting that the default was changed to 0db a while back, as many people who don’t have full knowledge of all the settings might even try DSD upscaling then dismiss it for sounding worse when in fact some sort of clipping is what’s causing it.

Anyway, one happy customer again here. I actually feel like I’ve got my system back and have been listening to it for hours already today instead of turning it off within a few tracks.

Will check this when I am home! Thanks

It was changed over a year ago.

I never take that kind of information as clear fact, done too much testing in my time. I’ve seen things in dropdowns which aren’t actually applied (not in Roon specifically). Software testing is a pain and it’s easy for a odd quirk to get through into a release.

Not saying they have, but I know I have not touched that setting before and now it’s sounding like it should again. I actually diary the settings changes I did so I could always know what I have changed.

It’s not finger pointing, or guesswork, just that I’ve done a lot of testing in my time and odd sequences of events can throw up quirks that developers haven’t spotted or accounted for. (Otherwise bug fixes wouldn’t come out all the time for most software!)

I’m happy anyway, my setup is sounding great again.

1 Like

Mods have shifted some of the extended side discussions off into their own threads. Just keeping socks in the sock drawer.:slightly_smiling_face:

2 Likes

Hmmm…mine doesn’t have those options.

Is it because I’m accessing the setting via my iPad mini 2 (I don’t use a computer to access Roon)?

I agree that SQ changed in 1.5 in unpleasant way. It is too much for me to elaborate case, but since 1.5 I have changed my player to the other one.

1 Like

It’s possible that this happens on an iPad, but not on a PC or Mac. I don’t have an iOS or Android device to check this. Anyone else?

Yes, Geoff and @Saturn94, you can only adjust the install settings using the Windows or Mac versions of Roon.

Cheers, Greg

Same SQ issue on all platforms, tried myself .

2 posts were split to a new topic: Grounding at multiple points?