Roon 1.8 (Build 748/756/763/764) Feedback

There was no change of meta data service in this release.

I think the UI used to be elegant. The album view was reminiscent of their groundbreaking Sooloos. The new view, with its immovable sidebar and the huge wasted real estate caused by the overpowering “My Abums” heading shows far fewer album covers. Dissapointed.


Two gone feature I miss in v1.8:

  1. Edition count number: If I have 6 editions of Beethoven Symphony No.9, in v1.7 there’s a “6” on the end of the title. But now only a small cds icon. The more editions, the more cds appears. But still not accurate.

  2. Display boxset by disks. Now if I want to play one specific disk in a 100CD boxset. I have to choose from a long list first. But in v1.7, only click the disk number and a “play” button shows up. And now I have to surf the long list to check if one disk is lost. (I love to rip CDs even if they’re in large boxset. In that situation, I want to make sure I didn’t skip one.)


I have to agree with a lot of others: I can live with some of the changes (thought I seriously preferred the more professional look of the previous interface), but that purple highlight color has GOT to go. I hate it already, and it makes me not want to use Roon at all :frowning:


My Core and remotes got an update: 1.8 Build 756. Must be fixing some bugs because it looks the same to me.

1 Like

The sidebar can be hidden via Settings.

1 Like

I updated to Build 756. Now searches are as fast as they used to be (or even a bit faster). A search for “Miles Davis” takes 0.8 seconds here. Switching between pages takes less than half a second (page refresh). Startup is still very slow, though (19-20 seconds). [<-> iMac 2019 3,6 GHz 8‑Core i9; WiFi]

1 Like

Roon 1.8 is not working in my setup at all

  • Playlist with Tidal and my own music crashes my windows 10 clients. And on android it only shows my own music all entries from Tidal is gone.
  • Settings menu is gone
  • IOS app crashes

The Settings Menu has a fix in Build 756 released a couple hours ago. Have you updated your software yet?

I don’t see this build on Play Store? Maybe I need to wait a bit before it shows up.

I have just updated, and it seems to have fixed the issues

I must be being dense, I’m not seeing where.

I second this. Especially the vertical scrolling and the MQA and bitrate badge.

1 Like

Я на ROON с декабря прошлого года и еще нет постоянной подписки. У меня NUC c roon core и пульт планшет samsung tab A7 . Что сильно не нравилось это мелкий шрифт и постоянное отсутствие связи планшета с NUC при включении. Постояно нужно перезаспускать wi fi. Сейчас эти проблемы одновременно исчезли с новой версией. Других проблем нет вообще никаких! Все стабильно, на этой версии. Может я не успел привыкнуть к 1.7 , поэтому претензий к 1.8 нет. Сейчас задумался какую подписку купить годовую или постоянную. Сейчас в России принимаются законы ,которые позволят в обозримом будующем заблокировать навсегда google и другие связанные сервисы. Как тогда будет работать roon?


I’ve been on ROON since last December and don’t have a permanent subscription yet. I have a NUC with a roon core and a samsung tab A7 remote control. What I really disliked was the small print and the constant lack of communication between the tablet and the NUC when turned on. You constantly need to restart wi fi. Now these problems have simultaneously disappeared with the new version. There are no other problems at all! Everything is stable on this version. Maybe I didn’t have time to get used to 1.7, so there are no complaints about 1.8. Now I thought about which subscription to buy an annual or permanent one. Now in Russia laws are being passed that will allow for the foreseeable future to block google and other related services forever. How will roon work then?

1 Like

I’m on the PC version - click “Settings” on the sidebar, then “General”, and under “Browsing Preferences” the first option is “Always show the sidebar” – change to “No”. The sidebar will collapse into a “hamburger” icon :slight_smile:

1 Like

Looks like they are adding the album descriptions back.

You can set Windows to individual scaling per program I think.

I can play Tidal on build 748, but now cannot play Tidal on 756.

I have tried to reset all the hardware and software but with no luck.

Each day when I sit down for a bit of critical listening, I switch over the M Scaler to batter power. Afterwards, I disconnect it until the next morning when I pop it back on the normal power brick for headphone duty while working. Normally this is not a problem and Roon would remember the M Scaler.

With Roon 1.8… no, it shows up in the Audio section as if it has been setup but no longer shows when you select source. Restart Roon server and hey, there it is again. Not the end of the world but it is somewhat annoying!