Roon Arc not working, ISP done all they can

Zyxel is the only router.
It’s a fiber optic connection. Bahnhof says that they do not perform NAT from the Optic to Ethernet modem.
Earlier I got rid of the multiple NAT error when I closed VPN, but it’s off now.
I have had four support calls to Bahnhof with four different technicians. I will try again and hopefully get one that understands my questions, that I really doesn’t understad fully myself

Are you sure you have a true static public IP4 address, and not one that is provided via CGNAT? Apparently, many Swedish ISPs use CGNAT which is a problem…

That tells me that your support person at Bahnhof does not have a full understanding of the technology they are using… :roll_eyes:

Well, that’s a concrete question, that I can ask when I call. I certainly hope that that it’s the right one since I now pay extra!

I suppose so. But they do go and ask some colleagues sometimes if they are stumped, so they do try, I think

I had the same problem. Behind a CGNAT. I found a solution and put it in this thread, maybe it can work for you.

https://community.roonlabs.com/t/tailscale-implementation-with-arc-to-circumnavigate-isp-cgnat/215356

OK, that looks interesting. But too much to ingest on my lunch break. I have to come back to that.
I have chatted with Bahnhof and they deny that my IP-adress is a CGNAT-adress.

Well Bahnhof tells me that it’s not a CGNAT provided adress but a public IP4

Well, very strange that you’re seeing a multiple NAT being reported in the error message.

Can you remove any port forwarding rules from the Zyxel that you may have set up, enable UPnP on it, and see what Roon errors you get then?

100.x.x.x is most definitely a CGNAT IP address

CGNAT uses 100.64.0.0/10 (100.64.0.0 >> 100.127.255.255)

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

A few minutes later, back to this:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xx.xx”,“router_external_ip”:“100.124.150.200”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

OK, I’ve edited out your public IP address from that error message - like your personal email address, that’s not something you should be revealing in a public forum.

That form of error message is shown in the ARC Port Forwarding FAQ, and tells us that we need to do manual port forwarding.

At least the multiple NAT message seems to have gone away - perhaps there was something misconfigured in the modem?

But first, try the steps outlined in the FAQ under “Other Tests” and see if that gives any positive results.

Well I have tried all of that except firmware update. I couldn’t do one when I tried yesterday, but I’ll have another try.
But now it’s back to multiple NAT again. I’ll see what Bahnhof has to say.

I will ask ISP one more time.

Use GRC shields up to see if the port is open.

No point in trying to fix roon if the traffic isn’t even getting to the router or through the port forward.

Ports are filtered according to scan with ipfingerprints, so not open I should think. On hold for ISP support right now. I will ask them (again)

most of the online scanners will say closed even if the port forward is working but roon is not responding.

GRC will say if the port is open even if nothing on the other side responds, it’s a much better indication if port forwarding is working

My Private IP was connected to wrong MAC adress. Now the error message, after Core reboot and toggled UPnP off and on again:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH xx.xx.xx.xx:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“xx.xx.xx.xx”,“router_external_ip”:“xx.xx.xx.xx”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

I have confirmed with the ISP, that the IP adress is in fact my Private IP. They say that the manual port forward rule seems OK and that everything should work. Scanning with ipfingerprints and GRC ShieldsUp both report ports are not open.
Any suggestions?