Roon cannot find UPnP device (Devialet Phantom Classic)

Sorry, but it’s not on the list (Partner Devices Matrix). Do they support Devialet AIR?

Devialet AIR

Roon supports the Devialet AIR protocol and can stream to Devialet Expert products.

I don’t get a list when I am in settings, it’s only the Roon symbol that’s moving and nothing happens further. My Phantoms do not have the AIR support. I have asked Devialet yesterday and they told me that I can connect these via UPnP to Roon.

Roon does not support UPnP/DLNA.


Connected Audio Outputs

Connected outputs include USB DACs, sound cards, even the built-in headphone jack on your laptop or tablet. These guides will help you get set up.

Networked Audio Outputs

Roon also supports several network-based output options.

  • Roon Ready Devices - Hardware products that speak to Roon Natively using RAAT
  • Roon Bridge - Let you locate audio outputs anywhere on your home network.
  • Airplay - iTunes and iOS devices.
  • Sonos - Sonos products
  • Squeezebox - SlimDevices and Logitech products
  • Devialet - Roon includes built-in support for the Devialet AIR protocol
  • Meridian - Ethernet-based streaming to Meridian products
  • HQPlayer - An extremely high quality DSP-focused media player
1 Like

Thank you, clear, so I need the AIR protocol via the Devialet Dialog. Can I stream high res through AIR as far as you know?

I am sorry, I think the AIR protocol is only available for Devialet Expert. De Dialog is Airplay and that’s something else I presume.

Why is Devialet calling the Phantom Roon tested as I cannot connect them to Roon as no Phantom will have AIR?

I don’t know anything that goes beyond the linked documents above.

As the Phantoms are (still?) listed on the Roon web presence as Roon Tested devices, you might want to try to connect them via USB. Roon Tested is usually used for USB devices (see the following out-take from the Partner Devices Matrix already linked above) where the Phantoms are not (yet?) listed:

Roon Tested USB Devices

Roon speaks to any USB device that is recognized as a sound card by the underlying operating system.

Unless otherwise noted, all of the below devices support USB Audio 2.0.

One of the most difficult user-experience details for device manufacturers is volume control. We’ve noted our experience with tested devices below, to help you make an informed decision. If you are planning to use the device in fixed output mode, or with a software volume control, this column will be less interesting.

When it comes to DSD playback, not all formats work on all platforms. For the most part, devices that support DSD64 and DSD128 do so on all platforms. Some devices can only accomplish DSD256 playback using ASIO drivers on Windows.

As always, the primary source for information about devices and their capabilities should be the manufacturers themselves. This page is purely for the convenience of our users.

Thanks! Even more strange to call them tested as no Phantom will have USB possibilities, only Optical and Ethernet. I will contact Devialet to let them know.

An additional reading that never got an official comment:

As a quick fix you could connect the Chromecast Audio to one of your Phantoms. The CC Audio is capable of 24/96 if I’m not mistaken. There’s a Roon Extension allowing you to control the Phantom volume from Roon. It works quite well. A Raspberry Pi with a HiFiBerry HAT will be capable of 24/192 over toslink.

If your Phantoms are AirPlay compatible, you can stream 16/44 from Roon. High res will be downsampeled to 16/44. If your Phantoms aren’t AirPlay compatible, your Dialog might be. Hopefully Devialet will implement RAAT in the (near) future.

The only way to use Phantoms in Roon without buying anything else is to activate them via Airplay. As mentioned above, go to Settings/Audio and they should be listed as an Airplay endpoint option, which you should be able to enable (if you aren’t seeing them as an Airplay endpoint, something else is up).

This will suffice for CD quality playback, but won’t do hi-res. For that, you need to connect a RAAT-compatible endpoint to the toslink input on one of the Phantom (if you have a stereo pair, either one of the speakers can “host” the endpoint and it will be shared across the speakers).

I have a Raspberry Pi, with a Hifiberry Digi+ connected to it so it has a toslink output, which is running the Ropieee software. This gives me a true RAAT/Roon Ready connection for the phantoms. There are easier ways to do this if the above felt like a bunch of different things to google, but it’s going to be more expensive. EG: connecting a Auralic Aries Mini or a Bluesound Node will do the same thing as my Pi set up, but for considerable more money.

The unsubstantiated rumor is that full Roon compatibility is coming to the Phantom through a future upgrade to the new DOS2 firmware. This would provide feature parity between the Expert line and the Phantom line, which is one of the stated goals of the DOS2 software; but don’t hold out for that: it hasn’t been officially stated that I know of; it’s just a dream of the Phantom owner collective.

Off topic: hey @ragwo have you been able to get the phantom volume control extension to work with DOS2 (did you upgrade?). Since upgrading the firmware on the Phantom, Danny’s extension can no longer find my Phantom set up. I changed internet providers around the the same time though, so it could be another issue I just need to spend time triaging.

I’m still on DOS1, if it’s not working on DOS2 it’s another good reason not to upgrade.

1 Like

I have the Roon core in Asustor AS6302T, and with DOS2. I think I did connected the Phantom with Roon Remote thru upnp from iPad once…
But not anymore now…
I think it can search the Phantom as upnp in the “other network device” list together with the Airplay options. You can choose to use airplay or upnp.
But after a week or so for not using it, it is gone…
I use the Phantom is not for 16bits, that’s why I don’t want AirPlay at all!!
I use Roon is because it can play my DFF file while other media server thru Mconnect won’t.
But now the Roon get me a combined problem, play DFF at 16bits AirPlay…
Please help for a way to keep the upnp live.

I updated my Phantoms to DOS 2

Danny’s extension finds the Phantoms - no issues there. (However, it takes a small edit to Danny’s source code regarding the name of the Phantom - see that thread for more info)

However, the extension is only able to change the volume if the Phantoms are actively using UPNP. If playing something via the optical input, like I do with Hifiberry Digi +, the extension cannot change the volume.

For example, while playing music using Audirvana to the Phantoms, using UPNP, I can use Danny’s extension to change the volume. But If I stop that and move to playing via Roon, no more volume control.

Thanks for the reply. I wonder if maybe the new implementation of UPnP is able to deactivate itself if it isn’t the active source. That may throw a significant wrench in the extension. Thanks for confirming that the naming convention was indeed the culprit for locating the phantom on my network.

Sorry. I derailed this post a bit talking about the extension that leverages UPnP on the Phantom to control the volume.

@Calvin_So: Roon doesn’t support UPnP. If you saw the Phantom appearing in Other Devices, it was definitely just as an Airplay device. Your best bet for hi res material on your Phantom is to connect a RAAT endpoint to the optical input (see this response above: Roon cannot find UPnP device (Devialet Phantom Classic)), or to petition Devialet to support RAAT in DOS2.

See this


It works perfectly for Phantoms.

No need for a Rpi/Hifiberry/Toslink and no need for any special volume control via extensions. I can control the Phantom’s volume via Roon. You do need to run the little program on an always on computer/NAS somewhere on the same network.

Hi there…I’m also on the pursue of using the HiRes capabilities on our Phantom’s, but since we still don’t have Roon native support and Toslink only goes to 96/24…the above software seems a great solution to network the Phantom and use the internal DAC to his full potential of 192/24…but I’m having issues with the Bridge on my Win10 PC… :frowning: …Roon stops playing tracks 96/24 exactly at 3:20s…not sure why…anyone has the Config.xml (and Roon settings) that can share so I can try to find my problem…any pointers or challenges that you found when setting up the Bridge? Many thanks for any support on this…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.